summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2021-01-25 23:45:35 +0100
committerLucki2021-01-25 23:45:35 +0100
commita7de6a93c611be657eabcc09f90e8bc4713c7847 (patch)
treee6a108e2398956136694cfc379be3afaccc7c158
parentf859aff1fa46ff0d1c0ad4f296c3c6fc25d6f0f5 (diff)
downloadaur-a7de6a93c611be657eabcc09f90e8bc4713c7847.tar.gz
upgpkg: docspell 0.19.0-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d49d8202c22..1d9a9d3121aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = docspell
pkgdesc = Assists in organizing your piles of documents, resulting from scanners, e-mails and other sources with miminal effort.
pkgver = 0.19.0
- pkgrel = 1
+ pkgrel = 2
url = https://docspell.org/
changelog = .CHANGELOG
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index b208c6afbd7b..05267a1b4856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=docspell
pkgname=('docspell-joex' 'docspell-restserver' 'docspell-tools')
pkgver=0.19.0
-pkgrel=1
+pkgrel=2
changelog=.CHANGELOG
arch=('any')
url="https://docspell.org/"
@@ -32,12 +32,15 @@ sha512sums=('1fd070456dde479d160fdd6179762ad7928e10eb721824dfdf5524101cf7a926374
prepare() {
# shellcheck disable=2016
- sed -i -e 's@url = "jdbc:h2:\/\/"\${java\.io\.tmpdir}"@url = "jdbc:h2:///var/lib/docspell@' \
+ sed -i -e 's@url = "jdbc:h2://"${java.io.tmpdir}"@url = "jdbc:h2:///var/lib/docspell@' \
"${pkgname[0]}-$pkgver/conf/${pkgname[0]}.conf" \
"${pkgname[1]}-$pkgver/conf/$pkgbase-server.conf"
sed -i -e 's@/usr/local/share/docspell/native.py@/usr/share/docspell-tools/native.py@' \
"${pkgname[2]}-$pkgver/firefox/native/app_manifest.json"
+
+ sed -i -e 's@DS_SH_CMD="ds.sh"@DS_SH_CMD="docspell-ds"@' \
+ "${pkgname[2]}-$pkgver/firefox/native/native.py"
}
# You do not need to compile Java applications from source.
@@ -126,5 +129,5 @@ package_docspell-tools() {
python -O -m compileall "$pkgdir/usr/share/${pkgname[2]}/firefox/native/native.py"
# Scripts
- find . -type f -name "*.sh" -exec sh -c 'install -Dm 755 "$3" "$1/usr/bin/$2-$(basename $3)"' _ "$pkgdir" "$pkgbase" {} \;
+ find . -type f -name "*.sh" -exec sh -c 'install -Dm 755 "$3" "$1/usr/bin/$2-$(basename "$3" .sh)"' _ "$pkgdir" "$pkgbase" {} \;
}