summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToynbee Idea2015-07-22 21:42:59 -0400
committerToynbee Idea2015-07-22 21:42:59 -0400
commitb98bad7ca18b5a3f164a19009d365bd217e175aa (patch)
tree7ae4c03bc5c1cf836ab96377b878c1ba5a2a33fc
downloadaur-b98bad7ca18b5a3f164a19009d365bd217e175aa.tar.gz
First attempt
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD55
-rw-r--r--dod-wizardlands-1.1.3-1.src.tar.gzbin0 -> 1187 bytes
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8fe43f8c4c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = dod-wizardlands
+ pkgdesc = Conquest of the Wizardlands: DLC expansion for Dungeons of Dredmor
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = http://dungeonsofdredmor.com/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = dungeons-of-dredmor
+
+pkgname = dod-wizardlands
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f3cff3e61ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Contributor: Babken Vardanyan <483ken 4tgma1l>
+# Contributor: Tom Boshoven <tomboshoven@gmail.com>
+# Contributor: Zachary A. Jones <jazzplayerl9@gmail.com>
+
+pkgname=dod-wizardlands
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="Conquest of the Wizardlands: DLC expansion for Dungeons of Dredmor"
+arch=(i686 x86_64)
+url="http://dungeonsofdredmor.com/"
+license=(unknown)
+depends=(dungeons-of-dredmor)
+PKGEXT='.pkg.tar'
+_gamepkg="Dredmor_humble-linux-conquestofthewizardlands-${pkgver}.tar.gz"
+_gamedir="dungeons-of-dredmor"
+_execu="Dredmor-amd64"
+[ "$CARCH" = 'x86_64' ] && _execu="Dredmor-x86"
+package() {
+
+ cd "${srcdir}"
+ msg "You need a full copy of this game in order to install it"
+ msg "Searching for ${_gamepkg} in dir: $(readlink -f `pwd`/..)"
+ if [[ -f "../${_gamepkg}" ]]; then
+ msg "Found game package, installing..."
+ ln -fs "../${_gamepkg}" .
+ elif [[ -f "${_gamepkg}" ]]; then
+ msg "Found game package in ${srcdir}, installing..."
+ elif [ -n "${_humbleintbundlekey}" ]; then
+ msg "Game package not found, trying to download..."
+ rm -f index.html\?key\=${_humbleintbundlekey}*
+ wget http://www.humblebundle.com/?key=${_humbleintbundlekey}
+ wget $(cat index.html\?key\=${_humbleintbundlekey} | grep "${_gamepkg}" | cut -d "'" -f 10)
+ mv ${_gamepkg}* ${_gamepkg}
+ else
+ msg "Game package not found and download failed."
+ msg "You can add \'export _humbleintbundlekey\=\<Your key here\>\' to \.bashrc if you want automated download ability."
+ error "Please type absolute path to ${_gamepkg} (/home/joe):"
+ read pkgpath
+ if [[ -f "${pkgpath}/${_gamepkg}" ]]; then
+ msg "Found game package, installing..."
+ ln -fs "${pkgpath}/${_gamepkg}" .
+ else
+ error "Unable to find game package."
+ return 1
+ fi
+ fi
+
+ mkdir "$srcdir/dredmor"
+ tar xvf "$srcdir/${_gamepkg}" -C "$srcdir/dredmor"
+ cd "$srcdir"
+ install -d "$pkgdir/opt/dredmor"
+
+ cp -R "$srcdir/dredmor" "$pkgdir/opt"
+
+ }
diff --git a/dod-wizardlands-1.1.3-1.src.tar.gz b/dod-wizardlands-1.1.3-1.src.tar.gz
new file mode 100644
index 000000000000..75d04e4d049b
--- /dev/null
+++ b/dod-wizardlands-1.1.3-1.src.tar.gz
Binary files differ