summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2017-04-30 20:50:42 -0400
committerYaohan Chen2017-04-30 20:50:42 -0400
commitbf5b9eaeea8ddd701f226dc3f5c558cc7c74268d (patch)
tree528e9ac2dd85892b7b7539f1914105edb55db6b4
parentcec117cb6d4f550e54f14d233362dead9fc890f7 (diff)
downloadaur-bf5b9eaeea8ddd701f226dc3f5c558cc7c74268d.tar.gz
Switch back to air-generic-launcher.sh
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
-rw-r--r--air-generic-launcher.sh15
-rw-r--r--transition.conf.patch12
4 files changed, 63 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c4e188e34c1..21cc4be82048 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Apr 28 06:36:52 UTC 2017
+# Mon May 1 00:50:37 UTC 2017
pkgbase = dofus
pkgdesc = A manga inspired, Massively Multiplayer Online Role-playing Game (MMORPG) for Adobe AIR .
- pkgver = 2.40
- pkgrel = 6
+ pkgver = 2.41
+ pkgrel = 1
url = http://www.dofus.com/
install = dofus.install
arch = i686
@@ -12,8 +12,12 @@ pkgbase = dofus
depends = adobe-air-sdk
source = dofus.desktop
source = dofus.sh
+ source = air-generic-launcher.sh
+ source = transition.conf.patch
md5sums = fcde25db66f15fe137d0412562d28a51
md5sums = 6aa8411d57ad0b3b6d3244f60a7f24e8
+ md5sums = f179eaa5e6e6674b1853cf826fc33c3a
+ md5sums = f81ccb681ae63b4a28e1cc3023f8d84a
source_i686 = http://dl.ak.ankama.com/games/installers/dofus-x86.tar.gz
depends_i686 = gtk2
depends_i686 = alsa-lib
diff --git a/PKGBUILD b/PKGBUILD
index bc1bf4f30745..b17b9bbcaf7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,12 @@
# Contributor: p2k <Patrick.Schneider@uni-ulm.de>
# Contributor: Schtroumpfette <fpeterschmitt@voila.fr>
+# 1: use adl to launch the game. Otherwise, use official game binaries directly.
+USE_ADL=1
+
pkgname=dofus
-pkgver=2.40
-pkgrel=6
+pkgver=2.41
+pkgrel=1
pkgdesc='A manga inspired, Massively Multiplayer Online Role-playing Game (MMORPG) for Adobe AIR .'
arch=('i686' 'x86_64')
url='http://www.dofus.com/'
@@ -17,14 +20,27 @@ depends_i686+=('gtk2' 'alsa-lib' 'alsa-plugins')
optdeppends=('pulseaudio-alsa: Required for the game to play sounds with PulseAudio')
source=('dofus.desktop'
- 'dofus.sh')
+ 'dofus.sh'
+ 'air-generic-launcher.sh'
+ 'transition.conf.patch')
source_i686=('http://dl.ak.ankama.com/games/installers/dofus-x86.tar.gz')
source_x86_64=('http://dl.ak.ankama.com/games/installers/dofus-amd64.tar.gz')
md5sums=('fcde25db66f15fe137d0412562d28a51'
- '6aa8411d57ad0b3b6d3244f60a7f24e8')
+ '6aa8411d57ad0b3b6d3244f60a7f24e8'
+ 'f179eaa5e6e6674b1853cf826fc33c3a'
+ 'f81ccb681ae63b4a28e1cc3023f8d84a')
md5sums_i686=('c885019d953b751d2e2177d6386cbce2')
md5sums_x86_64=('877c5c9fdad16fb7386726a745f500fc')
+prepare() {
+ if [ "$USE_ADL" -eq "1" ]
+ then
+ cd "$srcidr"
+ msg2 'Modifying transition configuration to use adl-based launchers'
+ patch -p0 < transition.conf.patch
+ fi
+}
+
package() {
msg2 'Installing main applications...'
installdir='opt/ankama/dofus'
@@ -46,8 +62,15 @@ package() {
install -Dm644 "$icon" "$pkgdir/usr/share/icons/hicolor/$size/apps/dofus.png"
done
- msg2 'Installing link to bypass Adobe Air detection...'
- ln -s '/opt/adobe-air-sdk/runtimes/air/linux/Adobe AIR/' "$pkgdir/opt/Adobe AIR"
+ if [ "$USE_ADL" -eq "1" ]
+ then
+ msg2 'Installing adl based launchers...'
+ install -Dm755 'air-generic-launcher.sh' "$pkgdir/$installdir/bin/air-generic-launcher.sh"
+ install -Dm755 'air-generic-launcher.sh' "$pkgdir/$installdir/share/reg/bin/air-generic-launcher.sh"
+ else
+ msg2 'Installing link to bypass Adobe Air detection...'
+ ln -s '/opt/adobe-air-sdk/runtimes/air/linux/Adobe AIR/' "$pkgdir/opt/Adobe AIR"
+ fi
}
# vim:set ts=2 sw=2 et:
diff --git a/air-generic-launcher.sh b/air-generic-launcher.sh
new file mode 100644
index 000000000000..5271757d3b10
--- /dev/null
+++ b/air-generic-launcher.sh
@@ -0,0 +1,15 @@
+#!/bin/bash
+
+# This is a generic launcher script for AIR applications on Arch Linux
+
+SCRIPT_PATH=`readlink -f $0`
+SCRIPT_DIR=`dirname $SCRIPT_PATH`
+BASE_DIR=`readlink -f $SCRIPT_DIR/..`
+
+if [ "`uname -m`" == "x86_64" ]; then
+ export GTK_PATH=/usr/lib32/gtk-2.0
+ export G_FILENAME_ENCODING=UTF-8
+fi
+
+/opt/adobe-air-sdk/bin/adl -nodebug $BASE_DIR/share/META-INF/AIR/application.xml $BASE_DIR/share -- $*
+
diff --git a/transition.conf.patch b/transition.conf.patch
new file mode 100644
index 000000000000..4fc73fc693c7
--- /dev/null
+++ b/transition.conf.patch
@@ -0,0 +1,12 @@
+--- Dofus/transition.conf 2014-12-04 05:27:44.000000000 -0500
++++ Dofus/transition.conf 2017-04-30 20:33:46.417694334 -0400
+@@ -21,3 +21,9 @@
+ update.projects *= "transition"
+ update.projects *= "game"
+
++bypass_air_installation = true
++dofus.reg.path = "${root}/share/reg/bin/air-generic-launcher.sh"
++
++launcher.command = """
++"${root}/bin/air-generic-launcher.sh" --lang=${i18n.lang} --update-server-port=${service_port} --updater_version=v2
++"""