summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVolker Schatz2015-06-08 23:40:47 +0200
committerVolker Schatz2015-06-08 23:40:47 +0200
commit8aeff45fdbefd0b309a697cd32050db046e67236 (patch)
treea5ef829f7e18027227477852d4362313a6a48f6b
downloadaur-8aeff45fdbefd0b309a697cd32050db046e67236.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efc09b778d70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dog
+ pkgdesc = A better cat, supporting HTTP and hex dumping
+ pkgver = 1.7
+ pkgrel = 3
+ url = http://packages.debian.org/sid/dog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://archive.debian.org/debian/pool/main/d/dog/dog_1.7.orig.tar.gz
+ source = http://archive.debian.org/debian/pool/main/d/dog/dog_1.7-10.diff.gz
+ md5sums = c93a8aa17c5e75ea1d32cd897b0f838e
+ md5sums = 18d77b7d0046dc8c14d5d08c9f067c79
+
+pkgname = dog
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7bc6c69ccb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Volker Schatz <rot13: nepu@ibyxrefpungm.pbz> (try tr a-z n-za-m)
+# Contributor: Marko Turk <marko.c4@gmail.com>
+pkgname=dog
+pkgver=1.7
+pkgrel=3
+pkgdesc="A better cat, supporting HTTP and hex dumping"
+url="http://packages.debian.org/sid/dog"
+arch=('i686' 'x86_64')
+license=('GPL')
+source=(
+"http://archive.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.orig.tar.gz"
+"http://archive.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver-10.diff.gz")
+md5sums=('c93a8aa17c5e75ea1d32cd897b0f838e'
+ '18d77b7d0046dc8c14d5d08c9f067c79')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver.orig"
+ zcat "../${pkgname}_$pkgver-10.diff.gz" | patch -p1
+ cat debian/patches/{0[0-9],1}* | patch -p1
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver.orig"
+ install -m 755 -D dog "$pkgdir"/usr/bin/dog
+ install -m 644 -D dog.1 "$pkgdir"/usr/man/man1/dog.1
+}
+
+# vim:set ts=2 sw=2 et: