summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2015-12-01 21:13:53 -0500
committeracerix2015-12-01 21:13:53 -0500
commit5b9f5dfa4e23ef14f78e090e98a6d255ec571664 (patch)
tree1ec7b67dc61dbd92f4d0a15b9b2a3b722554b30f
parent27cb8272e589b26557c2d1c795d9962081d8d07b (diff)
downloadaur-5b9f5dfa4e23ef14f78e090e98a6d255ec571664.tar.gz
dont download files included in the package...
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 4 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45709706f568..facbc9182632 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,13 +11,7 @@ pkgbase = dogecoin-daemon
makedepends = protobuf
conflicts = dogecoin-qt
source = https://github.com/dogecoin/dogecoin/archive/master.tar.gz
- source = https://raw.github.com/dogecoin/dogecoin/master/contrib/debian/examples/dogecoin.conf
- source = https://raw.github.com/dogecoin/dogecoin/master/contrib/debian/manpages/dogecoind.1
- source = https://raw.github.com/dogecoin/dogecoin/master/contrib/debian/manpages/dogecoin.conf.5
sha256sums = 8dc2125a5e36fd20b471ab63a8db837566528b3a23079fdc24da8573d7d98d1a
- sha256sums = 1daa77c34dc9b849da6582212e700c8c7ff32a1825cb03ab24fa4df0e2921609
- sha256sums = e1ff69595c1eb43e801fae557fd395b65bb806dbc2dc0fe16807ab0344e8a866
- sha256sums = 34afb1af9e1e628dc32b7a320e23b66b3f384a64cb7cfca500332489a9ca6cd5
pkgname = dogecoin-daemon
pkgdesc = Dogecoin is a peer-to-peer network based digital currency - daemon
diff --git a/PKGBUILD b/PKGBUILD
index e3fa58c3fd5c..2f692ed6be2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,18 +10,11 @@ url='http://dogecoin.com/'
makedepends=('boost' 'automoc4' 'protobuf')
conflicts=('dogecoin-qt') # /usr/bin/dogecoind exists in filesystem
license=('MIT')
-_git_base_url=github.com/$pkg_base/$pkg_base
source=(
- https://$_git_base_url/archive/$_git_branch.tar.gz
- https://raw.$_git_base_url/$_git_branch/contrib/debian/examples/$pkg_base.conf
- https://raw.$_git_base_url/$_git_branch/contrib/debian/manpages/$pkg_base'd.1'
- https://raw.$_git_base_url/$_git_branch/contrib/debian/manpages/$pkg_base.conf.5
+ https://github.com/$pkg_base/$pkg_base/archive/$_git_branch.tar.gz
)
sha256sums=(
'8dc2125a5e36fd20b471ab63a8db837566528b3a23079fdc24da8573d7d98d1a'
- '1daa77c34dc9b849da6582212e700c8c7ff32a1825cb03ab24fa4df0e2921609'
- 'e1ff69595c1eb43e801fae557fd395b65bb806dbc2dc0fe16807ab0344e8a866'
- '34afb1af9e1e628dc32b7a320e23b66b3f384a64cb7cfca500332489a9ca6cd5'
)
install=$pkgname.install
@@ -37,9 +30,9 @@ package_dogecoin-daemon() {
depends=(boost-libs openssl)
cd $srcdir/$pkg_base-$_git_branch
install -Dm755 src/$pkg_base'd' $pkgdir/usr/bin/$pkg_base'd'
- install -Dm644 $srcdir/$pkg_base.conf $pkgdir/usr/share/doc/$pkgname/examples/$pkg_base.conf
- install -Dm644 $srcdir/$pkg_base'd.1' $pkgdir/usr/share/man/man1/$pkg_base'd.1'
- install -Dm644 $srcdir/$pkg_base.conf.5 $pkgdir/usr/share/man/man5/$pkg_base.conf.5
+ install -Dm644 contrib/debian/examples/$pkg_base.conf $pkgdir/usr/share/doc/$pkgname/examples/$pkg_base.conf
+ install -Dm644 contrib/debian/manpages/$pkg_base'd.1' $pkgdir/usr/share/man/man1/$pkg_base'd.1'
+ install -Dm644 contrib/debian/manpages/$pkg_base.conf.5 $pkgdir/usr/share/man/man5/$pkg_base.conf.5
install -Dm644 COPYING '$pkgdir/usr/share/licenses/$pkgname/COPYING'
}