summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2015-10-06 19:20:59 -0400
committeracerix2015-10-06 19:20:59 -0400
commitcfa3ff5005c6d70ec30762cbaab7cd03c54b7ae0 (patch)
treebdeb7587b25d954ab26bed998d2bf67f5eb1fbf5
parent7d2015d739ffa9b5d180910bb6f129fce7d1dd3f (diff)
downloadaur-cfa3ff5005c6d70ec30762cbaab7cd03c54b7ae0.tar.gz
remove upnp to fix compilation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65b682538a9b..d8bfb69b037c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = dogecoin-daemon
pkgver = 1.8.3
- pkgrel = 1
+ pkgrel = 2
url = http://dogecoin.com/
arch = i686
arch = x86_64
license = MIT
makedepends = boost
makedepends = automoc4
- makedepends = miniupnpc
makedepends = protobuf
source = https://github.com/dogecoin/dogecoin/archive/1.8-maint.tar.gz
source = https://raw.github.com/dogecoin/dogecoin/1.8-maint/contrib/debian/examples/bitcoin.conf
@@ -21,6 +20,5 @@ pkgbase = dogecoin-daemon
pkgname = dogecoin-daemon
pkgdesc = Dogecoin is a peer-to-peer network based digital currency - daemon
depends = boost-libs
- depends = miniupnpc
depends = openssl
diff --git a/PKGBUILD b/PKGBUILD
index 023d33767c01..5107d8986724 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@ pkg_base=dogecoin
pkgname=('dogecoin-daemon')
pkgver=1.8.3
_git_branch=1.8-maint
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://dogecoin.com/"
-makedepends=('boost' 'automoc4' 'miniupnpc' 'protobuf')
+makedepends=('boost' 'automoc4' 'protobuf')
license=('MIT')
source=(https://github.com/dogecoin/dogecoin/archive/$_git_branch.tar.gz
https://raw.github.com/dogecoin/dogecoin/$_git_branch/contrib/debian/examples/bitcoin.conf
@@ -22,13 +22,13 @@ build() {
cd "$srcdir/$pkg_base-$_git_branch"
./autogen.sh
CXXFLAGS="$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1"
- ./configure --prefix=/usr --with-incompatible-bdb
+ ./configure --prefix=/usr --with-gui=no --with-tests=no --without-miniupnpc --with-incompatible-bdb
make
}
package_dogecoin-daemon() {
pkgdesc="Dogecoin is a peer-to-peer network based digital currency - daemon"
- depends=(boost-libs miniupnpc openssl)
+ depends=(boost-libs openssl)
cd "$srcdir/$pkg_base-$_git_branch"
install -Dm755 src/dogecoind "$pkgdir"/usr/bin/dogecoind
install -Dm644 "$srcdir"/bitcoin.conf \