summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThermi2015-07-07 22:23:17 +0200
committerThermi2015-07-07 22:23:17 +0200
commit924cb5cc81eb8483f28241ed8e504057e405768a (patch)
tree4bc31b41a8c3e81bdd6167ba2037d20ce5fff85a
downloadaur-924cb5cc81eb8483f28241ed8e504057e405768a.tar.gz
Initial Commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD50
-rw-r--r--dogecoin.desktop10
-rw-r--r--dogecoin.install11
-rw-r--r--fixing-boost.patch12
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d66a04521f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = dogecoin-qt
+ pkgdesc = Cryptocurrency
+ pkgver = 1.8.2
+ pkgrel = 2
+ url = http://dogecoin.com/
+ install = dogecoin.install
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = boost
+ makedepends = gcc
+ makedepends = make
+ makedepends = git
+ makedepends = qt4
+ makedepends = miniupnpc
+ makedepends = boost-libs
+ makedepends = protobuf
+ makedepends = openssl
+ makedepends = db
+ depends = miniupnpc
+ depends = boost-libs
+ depends = protobuf
+ depends = openssl
+ depends = db
+ provides = dogecoin-qt
+ source = https://github.com/dogecoin/dogecoin/archive/v1.8.2.tar.gz
+ source = dogecoin.desktop
+ source = fixing-boost.patch
+ sha256sums = 87060dfe6d9770f8af17c447120cb6a059bbd84687dfd6a1f0787c9d75d75d9e
+ sha256sums = 04d41773462ad6609658e291d22b15cd8d58b8eb5e4391a80cd1dae75e7df0e6
+ sha256sums = 3b335f979bc54d5c8760c84192a3b1224e0fa0d7afaa2fb806c4a3b777c2bded
+
+pkgname = dogecoin-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df3a01fb0a61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+#Maintainer thermi
+#I Used the packet "dogecoin-qt-git" of Gee as a base for this one
+#Based of primecoin-qt by Daniel Spies
+
+pkgname=dogecoin-qt
+_binname=dogecoin
+pkgver=1.8.2
+pkgrel=2
+pkgdesc="Cryptocurrency"
+arch=('x86_64' 'i686')
+url="http://dogecoin.com/"
+license=('MIT')
+provides=('dogecoin-qt')
+depends=('miniupnpc' 'boost-libs' 'protobuf' 'openssl' 'db')
+makedepends=('boost' 'gcc' 'make' 'git' 'qt4' 'miniupnpc' 'boost-libs' 'protobuf' 'openssl' 'db')
+source=("https://github.com/dogecoin/dogecoin/archive/v${pkgver}.tar.gz"
+ "dogecoin.desktop"
+ "fixing-boost.patch"
+ )
+install=dogecoin.install
+
+sha256sums=('87060dfe6d9770f8af17c447120cb6a059bbd84687dfd6a1f0787c9d75d75d9e'
+ '04d41773462ad6609658e291d22b15cd8d58b8eb5e4391a80cd1dae75e7df0e6'
+ '3b335f979bc54d5c8760c84192a3b1224e0fa0d7afaa2fb806c4a3b777c2bded')
+
+prepare() {
+ cd "${srcdir}/dogecoin-$pkgver/"
+ patch -p1 -i $srcdir/fixing-boost.patch
+}
+
+build() {
+ cd "${srcdir}/dogecoin-$pkgver/"
+
+ ./autogen.sh
+
+ # --with-incompatible-bdb is needed, because dogecon-qt wants version 5.1, but Arch is already on 5.3
+ ./configure QMAKE_CFLAGS_RELEASE="$CPPFLAGS $CFLAGS" QMAKE_CXXFLAGS_RELEASE="$CPPFLAGS $CXXFLAGS" \
+ QMAKE_LFLAGS_RELEASE="$LDFLAGS" --with-incompatible-bdb --prefix=/usr \
+ --sbindir=/usr/bin --sysconfdir=/etc --libexecdir=/usr/lib
+
+ make ${MAKEFLAGS}
+}
+
+package() {
+ install -Dm644 ${_binname}.desktop "${pkgdir}/usr/share/applications/${_binname}.desktop"
+ cd "$srcdir/dogecoin-$pkgver"
+ mkdir -p -m 755 "${pkgdir}/usr/share/dogecoin-qt/"
+ install -Dm644 share/pixmaps/bitcoin256.xpm "${pkgdir}/usr/share/pixmaps/dogecoin.xpm"
+ make DESTDIR=${pkgdir} install
+}
diff --git a/dogecoin.desktop b/dogecoin.desktop
new file mode 100644
index 000000000000..16fc26eb9c32
--- /dev/null
+++ b/dogecoin.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=DogeCoin
+Comment=DogeCoin P2P Cryptocurrency
+Exec=/usr/bin/dogecoin-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/dogecoin.xpm
+MimeType=x-scheme-handler/dogecoin;
+Categories=Network;
diff --git a/dogecoin.install b/dogecoin.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/dogecoin.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/fixing-boost.patch b/fixing-boost.patch
new file mode 100644
index 000000000000..ec5223cf20d6
--- /dev/null
+++ b/fixing-boost.patch
@@ -0,0 +1,12 @@
+diff -aur dogecoin-1.8.2.pristine/src/rpcrawtransaction.cpp dogecoin-1.8.2.new/src/rpcrawtransaction.cpp
+--- dogecoin-1.8.2.pristine/src/rpcrawtransaction.cpp 2015-01-17 19:22:54.000000000 +0100
++++ dogecoin-1.8.2.new/src/rpcrawtransaction.cpp 2015-05-24 10:57:09.750066113 +0200
+@@ -296,7 +296,7 @@
+ CTxDestination address;
+ if (ExtractDestination(pk, address))
+ {
+- const CScriptID& hash = boost::get<const CScriptID&>(address);
++ const CScriptID& hash = boost::relaxed_get<const CScriptID&>(address);
+ CScript redeemScript;
+ if (pwalletMain->GetCScript(hash, redeemScript))
+ entry.push_back(Pair("redeemScript", HexStr(redeemScript.begin(), redeemScript.end())));