summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Gee2020-12-22 05:26:26 -0800
committerJohn-Gee2020-12-22 05:27:21 -0800
commite79c81b2850dc42e663f7c38fbdd14dbe3f73699 (patch)
tree8454a76a420875be2624098b29c72fbf3f3ce750
parentf1c939270522ef96c836821477841e05b46b0033 (diff)
downloadaur-e79c81b2850dc42e663f7c38fbdd14dbe3f73699.tar.gz
Should build with current Arch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
-rw-r--r--boost.patch81
-rw-r--r--deque.patch11
-rw-r--r--qpainterpath.patch11
5 files changed, 133 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b413712ca81e..5fdb6719bc67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = dogecoin-qt
makedepends = gcc
makedepends = make
makedepends = git
- makedepends = qt4
+ makedepends = qt5-tools
makedepends = miniupnpc
makedepends = boost-libs
makedepends = protobuf
@@ -25,8 +25,14 @@ pkgbase = dogecoin-qt
depends = libevent
provides = dogecoin-qt
source = https://github.com/dogecoin/dogecoin/archive/v1.14.2.tar.gz
+ source = boost.patch
+ source = deque.patch
+ source = qpainterpath.patch
source = dogecoin.desktop
sha256sums = 416581d0af2df05ededb400b9434765eeaeb1396c9f3ef80a7b59a88c74a90cc
+ sha256sums = e6d3eef4e71719afd748bfd312955c32bc50b3ea2b0a92297e6982b42b0c210e
+ sha256sums = 792f4073d0de5017c9750a5f4a653759a79020d0de69e60320fcba0e4030005a
+ sha256sums = 1d503bd528f960a863f702a87a7ae283b6f6b29050b7faa552c3967514b0ece9
sha256sums = 04d41773462ad6609658e291d22b15cd8d58b8eb5e4391a80cd1dae75e7df0e6
pkgname = dogecoin-qt
diff --git a/PKGBUILD b/PKGBUILD
index 461c3c6434e1..a592cf9dd906 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,18 +12,30 @@ url="http://dogecoin.com/"
license=('MIT')
provides=('dogecoin-qt')
depends=('miniupnpc' 'boost-libs' 'protobuf' 'openssl-1.0' 'db' 'libevent')
-makedepends=('boost' 'gcc' 'make' 'git' 'qt4' 'miniupnpc' 'boost-libs' 'protobuf' 'openssl' 'db')
-source=("https://github.com/dogecoin/dogecoin/archive/v${pkgver}.tar.gz"
- "dogecoin.desktop"
- )
+makedepends=('boost' 'gcc' 'make' 'git' 'qt5-tools' 'miniupnpc' 'boost-libs' 'protobuf' 'openssl' 'db')
+source=("https://github.com/$_binname/$_binname/archive/v${pkgver}.tar.gz"
+ "boost.patch"
+ "deque.patch"
+ "qpainterpath.patch"
+ "$_binname.desktop")
-install=dogecoin.install
+install=$_binname.install
sha256sums=('416581d0af2df05ededb400b9434765eeaeb1396c9f3ef80a7b59a88c74a90cc'
+ 'e6d3eef4e71719afd748bfd312955c32bc50b3ea2b0a92297e6982b42b0c210e'
+ '792f4073d0de5017c9750a5f4a653759a79020d0de69e60320fcba0e4030005a'
+ '1d503bd528f960a863f702a87a7ae283b6f6b29050b7faa552c3967514b0ece9'
'04d41773462ad6609658e291d22b15cd8d58b8eb5e4391a80cd1dae75e7df0e6')
+prepare() {
+ cd "$srcdir/$_binname-$pkgver"
+ patch -p2 <$srcdir/deque.patch
+ patch -p1 <$srcdir/qpainterpath.patch
+ patch -p2 <$srcdir/boost.patch
+}
+
build() {
- cd "${srcdir}/dogecoin-$pkgver/"
+ cd "$srcdir/$_binname-$pkgver/"
./autogen.sh
@@ -33,13 +45,13 @@ build() {
QMAKE_LFLAGS_RELEASE="$LDFLAGS" --with-incompatible-bdb --prefix=/usr \
--sbindir=/usr/bin --sysconfdir=/etc --libexecdir=/usr/lib
- make ${MAKEFLAGS}
+ make
}
package() {
- install -Dm644 "${srcdir}/${_binname}.desktop" "${pkgdir}/usr/share/applications/${_binname}.desktop"
- cd "${srcdir}/dogecoin-${pkgver}/"
- mkdir -p -m 755 "${pkgdir}/usr/share/dogecoin-qt/"
- install -Dm644 share/pixmaps/bitcoin256.xpm "${pkgdir}/usr/share/pixmaps/dogecoin.xpm"
+ install -Dm644 "$srcdir/$_binname.desktop" "$pkgdir/usr/share/applications/$_binname.desktop"
+ cd "$srcdir/$_binname-$pkgver/"
+ mkdir -p -m 755 "$pkgdir/usr/share/$_binname-qt/"
+ install -Dm644 share/pixmaps/bitcoin256.xpm "$pkgdir/usr/share/pixmaps/$_binname.xpm"
make DESTDIR=${pkgdir} install
}
diff --git a/boost.patch b/boost.patch
new file mode 100644
index 000000000000..350a3f832363
--- /dev/null
+++ b/boost.patch
@@ -0,0 +1,81 @@
+diff -ur src2/dogecoin-1.14.2/src/validation.cpp src/dogecoin-1.14.2/src/validation.cpp
+--- src2/dogecoin-1.14.2/src/validation.cpp 2019-04-08 14:28:20.000000000 +0700
++++ src/dogecoin-1.14.2/src/validation.cpp 2020-02-03 18:31:55.196768990 +0700
+@@ -44,6 +44,7 @@
+
+ #include <boost/algorithm/string/replace.hpp>
+ #include <boost/algorithm/string/join.hpp>
++#include <boost/bind.hpp>
+ #include <boost/filesystem.hpp>
+ #include <boost/filesystem/fstream.hpp>
+ #include <boost/math/distributions/poisson.hpp>
+
+--- src2/dogecoin-1.14.2/src/validationinterface.cpp 2020-12-22 05:09:29.305584746 -0800
++++ src/dogecoin-1.14.2/src/validationinterface.cpp 2020-12-22 04:55:54.489730962 -0800
+@@ -5,6 +5,8 @@
+
+ #include "validationinterface.h"
+
++#include <boost/bind.hpp>
++
+ static CMainSignals g_signals;
+
+ CMainSignals& GetMainSignals()
+
+--- src2/dogecoin-1.14.2/src/qt/bitcoingui.cpp 2020-12-22 05:14:22.863474268 -0800
++++ src2/dogecoin-1.14.2/src/qt/bitcoingui.cpp 2020-12-22 05:05:15.267433930 -0800
+@@ -38,6 +38,8 @@
+
+ #include <iostream>
+
++#include <boost/bind.hpp>
++
+ #include <QAction>
+ #include <QApplication>
+ #include <QDateTime>
+
+--- src2/dogecoin-1.14.2/src/qt/clientmodel.cpp 2020-12-22 05:14:33.973393228 -0800
++++ src2/dogecoin-1.14.2/src/qt/clientmodel.cpp 2020-12-22 05:05:34.335287787 -0800
+@@ -21,6 +21,8 @@
+
+ #include <stdint.h>
+
++#include <boost/bind.hpp>
++
+ #include <QDebug>
+ #include <QTimer>
+
+--- src2/dogecoin-1.14.2/src/qt/splashscreen.cpp 2020-12-22 05:14:44.537316110 -0800
++++ src2/dogecoin-1.14.2/src/qt/splashscreen.cpp 2020-12-22 05:05:50.163166476 -0800
+@@ -20,6 +20,8 @@
+ #include "wallet/wallet.h"
+ #endif
+
++#include <boost/bind.hpp>
++
+ #include <QApplication>
+ #include <QCloseEvent>
+ #include <QDesktopWidget>
+
+--- src2/dogecoin-1.14.2/src/qt/transactiontablemodel.cpp 2020-12-22 05:14:54.453243665 -0800
++++ src2/dogecoin-1.14.2/src/qt/transactiontablemodel.cpp 2020-12-22 05:06:09.833015722 -0800
+@@ -26,6 +26,7 @@
+ #include <QIcon>
+ #include <QList>
+
++#include <boost/bind.hpp>
+ #include <boost/foreach.hpp>
+
+ // Amount column is right-aligned it contains numbers
+
+--- src2/dogecoin-1.14.2/src/qt/walletmodel.cpp 2020-12-22 05:15:01.839189671 -0800
++++ src2/dogecoin-1.14.2/src/qt/walletmodel.cpp 2020-12-22 05:06:28.748870741 -0800
+@@ -28,6 +28,7 @@
+ #include <QSet>
+ #include <QTimer>
+
++#include <boost/bind.hpp>
+ #include <boost/foreach.hpp>
+
+ WalletModel::WalletModel(const PlatformStyle *platformStyle, CWallet *_wallet, OptionsModel *_optionsModel, QObject *parent) :
+
diff --git a/deque.patch b/deque.patch
new file mode 100644
index 000000000000..293723ed7747
--- /dev/null
+++ b/deque.patch
@@ -0,0 +1,11 @@
+diff -ur src2/dogecoin-1.14.2/src/httpserver.cpp src/dogecoin-1.14.2/src/httpserver.cpp
+--- src2/dogecoin-1.14.2/src/httpserver.cpp 2019-04-08 14:28:20.000000000 +0700
++++ src/dogecoin-1.14.2/src/httpserver.cpp 2020-02-03 18:31:55.196768990 +0700
+@@ -19,6 +19,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <signal.h>
++#include <deque>
+ #include <future>
+
+ #include <event2/event.h>
diff --git a/qpainterpath.patch b/qpainterpath.patch
new file mode 100644
index 000000000000..d0e2ffd624f1
--- /dev/null
+++ b/qpainterpath.patch
@@ -0,0 +1,11 @@
+diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
+--- a/src/qt/trafficgraphwidget.cpp
++++ b/src/qt/trafficgraphwidget.cpp
+@@ -6,6 +6,7 @@
+ #include "clientmodel.h"
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QColor>
+ #include <QTimer
+