summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Pérez2021-06-18 12:31:58 -0600
committerLuis Pérez2021-06-18 12:31:58 -0600
commit5077f305148a8db1f45bff4c4aa90d6194b058ae (patch)
tree047d5d471909ed5ffb21818284db31424d0bcc84
parent53190d54ca7d54dce5a8b3b1ad05b5109e8cbb41 (diff)
downloadaur-5077f305148a8db1f45bff4c4aa90d6194b058ae.tar.gz
adding docs and completions
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bb79efd96ee..cf990cb9a635 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = doggo
pkgdesc = Command-line DNS Client for Humans.
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mr-karan/doggo
arch = x86_64
license = GPL
makedepends = go
provides = doggo
conflicts = doggo-git
- source = https://github.com/mr-karan/doggo/archive//v0.4.0.tar.gz
+ source = https://github.com/mr-karan/doggo/archive/v0.4.0.tar.gz
sha256sums = 8d7e6ff2538e9e6b86d4af734ccd15282347f307eae275076742f9105404d2dc
pkgname = doggo
-
diff --git a/PKGBUILD b/PKGBUILD
index 834ccc83f316..feb637f18602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Luis Pérez <luis.perez@protonmail.com>
+# Contributor: djmattyg007 <internet@matthewgamble.net>
+
pkgname=doggo
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='Command-line DNS Client for Humans.'
arch=('x86_64')
url="https://github.com/mr-karan/doggo"
license=('GPL')
makedepends=('go')
-source=("${url}/archive//v${pkgver}.tar.gz")
+source=("${url}/archive/v${pkgver}.tar.gz")
conflicts=('doggo-git')
provides=('doggo')
sha256sums=('8d7e6ff2538e9e6b86d4af734ccd15282347f307eae275076742f9105404d2dc')
@@ -30,5 +32,8 @@ build() {
package() {
cd "$pkgname-$pkgver"
- install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm755 build/"$pkgname" "$pkgdir"/usr/bin/"$pkgname"
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/"$pkgname"/README.md
+ install -Dm644 completions/"${pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}"
+ install -Dm644 completions/"${pkgname}.zsh" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
}