summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsysroot2020-12-18 19:40:45 +0000
committersysroot2020-12-18 19:40:45 +0000
commitc53e65a1b197f345dfc4d14fa97538432915facf (patch)
treead1ee51177426272cea16264217599ed3d07d91d
downloadaur-c53e65a1b197f345dfc4d14fa97538432915facf.tar.gz
Update AUR package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fbd0b9aedeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = doggo
+ pkgdesc = Command-line DNS Client for Humans.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/mr-karan/doggo/archive/
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ source = https://github.com/mr-karan/doggo/archive//v0.1.0.tar.gz
+ sha256sums = 7edcb5b6d85c09607e003dfaf9fb82dd6d40d400c845c06272f3090cb1ffa494
+
+pkgname = doggo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67e7985ee402
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Luis PĂ©rez <luis.perez@protonmail.com>
+pkgname=doggo
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Command-line DNS Client for Humans.'
+arch=('x86_64')
+url="https://github.com/mr-karan/doggo/archive/"
+license=('GPL')
+makedepends=('go')
+source=("$url/v$pkgver.tar.gz")
+sha256sums=('7edcb5b6d85c09607e003dfaf9fb82dd6d40d400c845c06272f3090cb1ffa494')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build/$pkgname ./cmd/...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}