summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-22 08:23:20 +0300
committerDimitris Kiziridis2020-04-22 08:23:20 +0300
commit73add3d20cebb99c2eb1613909f09629cb3492d2 (patch)
tree1b0b91d2ff9976d91ccdf6e3194bee0cb485ece4
downloadaur-73add3d20cebb99c2eb1613909f09629cb3492d2.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43b0b51980b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dogo-git
+ pkgdesc = Monitoring changes in the source file and automatically compile and run (restart)
+ pkgver = 1.0_beta2.r9.g7887b84
+ pkgrel = 1
+ url = https://github.com/liudng/dogo
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = dep
+ makedepends = go-pie
+ provides = dogo
+ source = git+https://github.com/liudng/dogo
+ md5sums = SKIP
+
+pkgname = dogo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f713f68a6b78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=dogo-git
+pkgver=1.0_beta2.r9.g7887b84
+pkgrel=1
+pkgdesc="Monitoring changes in the source file and automatically compile and run (restart)"
+arch=('x86_64')
+url='https://github.com/liudng/dogo'
+license=('BSD')
+provides=("${pkgname%-git}")
+makedepends=('git' 'dep' 'go-pie')
+source=("git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ mkdir -p gopath/src/github.com/${pkgname%-git}
+ ln -rTsf ${pkgname%-git} gopath/src/github.com/${pkgname%-git}/${pkgname%-git}
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/${pkgname%-git}/${pkgname%-git}
+ dep init -v
+ dep ensure -v
+}
+
+build(){
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/${pkgname%-git}/${pkgname%-git}
+ go install -v .
+}
+
+package() {
+ install -Dm755 "${srcdir}/gopath/bin/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+} \ No newline at end of file