summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2020-04-24 10:02:48 +0200
committerAchilleas Pipinellis2020-04-24 10:02:48 +0200
commit5f079c1c85f42bff7d6cfd241af73bed23876076 (patch)
tree94de95068e73ce5b39a5db4f90fc8ed029bc0b3f
parent74e9f77680ee254d7c0a5856e4ffae5cc0c66588 (diff)
downloadaur-5f079c1c85f42bff7d6cfd241af73bed23876076.tar.gz
Add a build step, fix depends, add zst to .gitignore
According to https://wiki.archlinux.org/index.php/Python_package_guidelines#setuptools, > if the PKGBUILD only installs the Python package for a single version > of Python, setuptools should be moved from makedepends to depends.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
3 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50a3df394dca..b8694758be6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = doh-cli
pkgdesc = a simple DNS over HTTPS client
pkgver = 0.3
- pkgrel = 2
+ pkgrel = 3
url = https://pypi.python.org/pypi/doh-cli
arch = any
license = GPL3
- makedepends = python-setuptools
+ depends = python-setuptools
depends = python-requests
depends = python-dnspython
source = https://files.pythonhosted.org/packages/source/d/doh-cli/doh-cli-0.3.tar.gz
diff --git a/.gitignore b/.gitignore
index ee7e3d3a3c5a..590d8a1cc38f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.xz
*.gz
+*.zst
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index ccb876f24b14..bca2c71694eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
# Maintainer : Achilleas Pipinellis <axil archlinux gr>
pkgname=doh-cli
pkgver=0.3
-pkgrel=2
+pkgrel=3
pkgdesc="a simple DNS over HTTPS client"
arch=('any')
url="https://pypi.python.org/pypi/doh-cli"
license=('GPL3')
-depends=('python')
-makedepends=('python-setuptools')
-depends=('python-requests' 'python-dnspython')
+depends=('python-setuptools' 'python-requests' 'python-dnspython')
source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz)
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
package() {
cd ${pkgname}-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
sha256sums=('d42c76c690628b3ed9f6d015ca40214fb030a4065fa52f954a7c59d1bc52ba8d')
+sha256sums=('d42c76c690628b3ed9f6d015ca40214fb030a4065fa52f954a7c59d1bc52ba8d')