summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorExcitable Snowball2018-06-02 05:05:49 -0700
committerExcitable Snowball2018-06-02 05:05:49 -0700
commitcf4806ea2d25ff6b72248ab6371ea39d1c11b227 (patch)
treeb7824af20ddb3c725593d00f6e4b95948282cf13
downloadaur-cf4806ea2d25ff6b72248ab6371ea39d1c11b227.tar.gz
0.3.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c3671efb410
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = doi2bib
+ pkgdesc = Generate a bibtex given a doi
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/bibcure/doi2bib
+ arch = any
+ license = AGPL3
+ depends = python-requests
+ depends = python-bibtexparser
+ depends = python-future
+ source = doi2bib-0.3.0.tar.gz::https://github.com/bibcure/doi2bib/archive/0.3.0.tar.gz
+ sha256sums = 94857e12d71727bd9bfc9e4667a31c68b159ba1de60fb8a2adf0905baca2827a
+
+pkgname = doi2bib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd531c296f12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Excitable Snowball <excitablesnowball@gmail.com>
+
+pkgname=doi2bib
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Generate a bibtex given a doi"
+url="https://github.com/bibcure/doi2bib"
+arch=('any')
+license=('AGPL3')
+depends=('python-requests' 'python-bibtexparser' 'python-future')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bibcure/doi2bib/archive/$pkgver.tar.gz")
+sha256sums=('94857e12d71727bd9bfc9e4667a31c68b159ba1de60fb8a2adf0905baca2827a')
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}