summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Sayahi2022-09-10 21:15:46 -0400
committerEmil Sayahi2022-09-10 21:15:46 -0400
commit39bdd580ca51e4c8b74c15017cfecb5083d35031 (patch)
tree3c86f0df29a0b6d53de7d35e27be35e3fb63517f
parentcba3ab0b779615ed81d1d95b210add6ade5a04b7 (diff)
downloadaur-39bdd580ca51e4c8b74c15017cfecb5083d35031.tar.gz
Manually commiting
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ed29e101e94..f1eb8c88817b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = dokkoo-bin
pkgdesc = Mokk (Macro Output Key Kit) implementation written in Rust.
- pkgver = 0.3.0
+ pkgver = 0.3.3
pkgrel = 1
url = https://github.com/Dirout/dokkoo
arch = x86_64
license = AGPL-3.0-or-later
provides = dokkoo
- source = https://github.com/Dirout/dokkoo/releases/download/v0.3.0/dokkoo-0.3.0-x86_64.tar.gz
- sha256sums = 02cd1c0185d2fe38b0e2f5a35c078764e2c8745c06c4d860ea1101e0b82b58ad
+ conflicts = dokkoo
+ source = https://github.com/Dirout/dokkoo/releases/download/v0.3.3/dokkoo-0.3.3-x86_64.tar.gz
+ sha256sums = be730ebbb25ab061dd65f8ad361e39da9116e930c8c47ec5a60f9d423987e7fb
pkgname = dokkoo-bin
diff --git a/PKGBUILD b/PKGBUILD
index b3a14618bc0a..a9cca4360e57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
# Maintainer: Emil Sayahi <limesayahi@gmail.com>
+#
+# This PKGBUILD was generated by `cargo aur`: https://crates.io/crates/cargo-aur
+
pkgname=dokkoo-bin
-pkgver=0.3.0
+pkgver=0.3.3
pkgrel=1
pkgdesc="Mokk (Macro Output Key Kit) implementation written in Rust."
url="https://github.com/Dirout/dokkoo"
license=("AGPL-3.0-or-later")
arch=("x86_64")
provides=("dokkoo")
+conflicts=("dokkoo")
+
source=("https://github.com/Dirout/dokkoo/releases/download/v$pkgver/dokkoo-$pkgver-x86_64.tar.gz")
-sha256sums=("02cd1c0185d2fe38b0e2f5a35c078764e2c8745c06c4d860ea1101e0b82b58ad")
+sha256sums=("be730ebbb25ab061dd65f8ad361e39da9116e930c8c47ec5a60f9d423987e7fb")
package() {
- install -Dm755 dokkoo -t "$pkgdir/usr/bin/"
+ install -Dm755 dokkoo -t "$pkgdir/usr/bin"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}