summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authord1ceward2018-07-11 10:17:50 +0200
committerd1ceward2018-07-11 10:17:50 +0200
commit172860ec86dbf70aada6a748c5de7078eb115a4e (patch)
tree62d9072cfa9cb5e349a871946282a0eda7d41798
parent28ad0df82ed11970c9ead7f047a0474603136809 (diff)
downloadaur-172860ec86dbf70aada6a748c5de7078eb115a4e.tar.gz
Upgrade to dokku 0.12.10
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--dokku.install11
3 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 925bce35e4df..dd7e128c9e38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dokku
pkgdesc = Docker powered mini-Heroku in around 100 lines of Bash.
- pkgver = 0.12.5
+ pkgver = 0.12.10
pkgrel = 1
url = https://github.com/dokku/dokku
install = dokku.install
@@ -19,10 +19,10 @@ pkgbase = dokku
depends = plugn>=0.3.0
depends = python
depends = sshcommand>=0.7.0
- source = https://github.com/dokku/dokku/archive/v0.12.5.zip
+ source = https://github.com/dokku/dokku/archive/v0.12.10.zip
source = dokku.install
- sha256sums = 6d24045a6230acf4e707a89d65cd49565a712478c1bfeb1af1152fb774e9fdfb
- sha256sums = 3d5a12c09fdc25dce99961ee33df0a0d22c26a53e6307eb52c4d728c46a36698
+ sha256sums = 13deaebf07db417ec4a93c9d9c6b6463a2c79a3ffc5a3a5453574d6fd4d39465
+ sha256sums = caa9152e782dbeb1f6176fedab3314cdde737e815998393799a67cc24dd32109
pkgname = dokku
diff --git a/PKGBUILD b/PKGBUILD
index 445a72b012d0..11c31ee32369 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=dokku
-pkgver=0.12.5
+pkgver=0.12.10
pkgrel=1
pkgdesc="Docker powered mini-Heroku in around 100 lines of Bash."
arch=(any)
@@ -26,8 +26,8 @@ source=(
"https://github.com/dokku/dokku/archive/v${pkgver}.zip"
"${pkgname}.install"
)
-sha256sums=('6d24045a6230acf4e707a89d65cd49565a712478c1bfeb1af1152fb774e9fdfb'
- '3d5a12c09fdc25dce99961ee33df0a0d22c26a53e6307eb52c4d728c46a36698')
+sha256sums=('13deaebf07db417ec4a93c9d9c6b6463a2c79a3ffc5a3a5453574d6fd4d39465'
+ 'caa9152e782dbeb1f6176fedab3314cdde737e815998393799a67cc24dd32109')
install=${pkgname}.install
package() {
@@ -38,7 +38,6 @@ package() {
go get github.com/ryanuber/columnize
go get github.com/dokku/dokku/plugins/config
env PLUGIN_MAKE_TARGET=build make go-build
- mkdir -p "${pkgdir}/var/lib/dokku/core-plugins/available"
cp common.mk "${pkgdir}/var/lib/dokku/core-plugins/common.mk"
cp -r plugins/* "${pkgdir}/var/lib/dokku/core-plugins/available"
find plugins/ -mindepth 1 -maxdepth 1 -type d -printf '%f\n' | while read plugin; do cd "${pkgdir}/var/lib/dokku/core-plugins/available/${plugin}" && if [ -e Makefile ]; then make src-clean; fi; done
diff --git a/dokku.install b/dokku.install
index fe9136b431d3..338ced8eb5c3 100644
--- a/dokku.install
+++ b/dokku.install
@@ -18,6 +18,17 @@ post_install() {
mkdir -p ${DOKKU_LIB_ROOT}/core-plugins/enabled ${DOKKU_LIB_ROOT}/plugins/enabled
touch ${DOKKU_LIB_ROOT}/core-plugins/config.toml ${DOKKU_LIB_ROOT}/plugins/config.toml
+ echo "Migrating old plugins"
+ find ${DOKKU_LIB_ROOT}/plugins/ -mindepth 1 -maxdepth 1 -type d -printf '%f\n' | while read -r plugin; do
+ if [ "$plugin" = "available" ] || [ "$plugin" = "enabled" ]; then
+ continue
+ elif [ -f ${DOKKU_LIB_ROOT}/plugins/$plugin/.core ]; then
+ rm -rf ${DOKKU_LIB_ROOT}/plugins/$plugin
+ elif [ ! -d ${DOKKU_LIB_ROOT}/plugins/available/$plugin ]; then
+ mv ${DOKKU_LIB_ROOT}/plugins/$plugin ${DOKKU_LIB_ROOT}/plugins/available;
+ fi
+ done
+
echo "Enabling all core plugins"
find ${DOKKU_LIB_ROOT}/core-plugins/available -mindepth 1 -maxdepth 1 -type d -printf '%f\n' | while read -r plugin; do
if [ ! -d ${DOKKU_LIB_ROOT}/plugins/available/$plugin ]; then