summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien LEFEBVRE (d1ceward)2023-08-23 14:02:38 +0200
committerFabien LEFEBVRE (d1ceward)2023-08-23 14:02:38 +0200
commit7346a3e6595c52fb5d071d5f70256af624262912 (patch)
treeb10de46a33b641a933d90a4424d0e93168d35bbe
parentc7849a4461d6609eb56306562df144088b674d87 (diff)
downloadaur-7346a3e6595c52fb5d071d5f70256af624262912.tar.gz
upgpkg: dokku 0.31.1-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--crontab_calls.patch27
-rw-r--r--systemd_calls.patch2
4 files changed, 8 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b293bd120422..b705cfbdb6f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dokku
pkgdesc = Docker-powered PaaS that helps build and manage the lifecycle of applications
- pkgver = 0.30.11
+ pkgver = 0.31.1
pkgrel = 1
url = https://github.com/dokku/dokku
install = dokku.install
@@ -33,15 +33,13 @@ pkgbase = dokku
depends = sudo
depends = sshcommand
depends = unzip
- source = https://github.com/dokku/dokku/archive/v0.30.11.zip
+ source = https://github.com/dokku/dokku/archive/v0.31.1.zip
source = dokku.install
- source = crontab_calls.patch
source = systemd_calls.patch
source = LICENSE
- sha256sums = 224d5a1a613aa5980774e3fda4b845bc24672f18c72382f699f2204a8ce1d24f
+ sha256sums = 3baae355ef48ba263065c588c4dc34046d8f7e50ad60d9d35282d622e5dcbead
sha256sums = c0b40188052a29dcfb3d8595a23a1a49adf6abc85c78ee99b530fae60cab932a
- sha256sums = 55993df7e243de7a009da05f802cb0b306dc67aa181a510f6825a8b2874b2397
- sha256sums = c600fefea1c93e9f94192741adc679fb0a05674775d3677954f10db4e09205c6
+ sha256sums = aec08deb0b1d466f37a0c76f93fc507d443ab8bd770cc0c1097ffeffa75cf9a4
sha256sums = b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046
pkgname = dokku
diff --git a/PKGBUILD b/PKGBUILD
index 42441f963440..6bd1dcf4b9fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
pkgname=dokku
-pkgver=0.30.11
+pkgver=0.31.1
pkgrel=1
pkgdesc='Docker-powered PaaS that helps build and manage the lifecycle of applications'
arch=('any')
@@ -38,13 +38,11 @@ depends=(
)
source=("${url}/archive/v${pkgver}.zip"
"${pkgname}.install"
- "crontab_calls.patch"
"systemd_calls.patch"
"LICENSE")
-sha256sums=('224d5a1a613aa5980774e3fda4b845bc24672f18c72382f699f2204a8ce1d24f'
+sha256sums=('3baae355ef48ba263065c588c4dc34046d8f7e50ad60d9d35282d622e5dcbead'
'c0b40188052a29dcfb3d8595a23a1a49adf6abc85c78ee99b530fae60cab932a'
- '55993df7e243de7a009da05f802cb0b306dc67aa181a510f6825a8b2874b2397'
- 'c600fefea1c93e9f94192741adc679fb0a05674775d3677954f10db4e09205c6'
+ 'aec08deb0b1d466f37a0c76f93fc507d443ab8bd770cc0c1097ffeffa75cf9a4'
'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
install="${pkgname}.install"
@@ -58,9 +56,6 @@ build() {
cd "${pkgname}-${pkgver}"
- # Fix issue on crontab calls with arch linux cron implementation
- patch -p1 -i "${srcdir}/crontab_calls.patch"
-
# Fix issue with invalid service manager call for arch linux
patch -p1 -i "${srcdir}/systemd_calls.patch"
diff --git a/crontab_calls.patch b/crontab_calls.patch
deleted file mode 100644
index ad27e4d4d1f2..000000000000
--- a/crontab_calls.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/plugins/cron/functions.go 2022-12-09 00:42:16.085851600 +0100
-+++ b/plugins/cron/functions.go 2022-12-09 00:44:28.535851600 +0100
-@@ -81,13 +81,13 @@
- }
-
- func deleteCrontab() error {
-- command := common.NewShellCmd("sudo /usr/bin/crontab -l -u dokku")
-+ command := common.NewShellCmd("sudo /usr/bin/crontab -l")
- command.ShowOutput = false
- if !command.Execute() {
- return nil
- }
-
-- command = common.NewShellCmd("sudo /usr/bin/crontab -r -u dokku")
-+ command = common.NewShellCmd("sudo /usr/bin/crontab -r")
- command.ShowOutput = false
- out, err := command.CombinedOutput()
- if err != nil {
-@@ -163,7 +163,7 @@
- return fmt.Errorf("Unable to template out schedule file: %v", err)
- }
-
-- command := common.NewShellCmd(fmt.Sprintf("sudo /usr/bin/crontab -u dokku %s", tmpFile.Name()))
-+ command := common.NewShellCmd(fmt.Sprintf("sudo /usr/bin/crontab %s", tmpFile.Name()))
- command.ShowOutput = false
- out, err := command.CombinedOutput()
- if err != nil {
diff --git a/systemd_calls.patch b/systemd_calls.patch
index fc321b10ef53..390b8b062400 100644
--- a/systemd_calls.patch
+++ b/systemd_calls.patch
@@ -1,6 +1,6 @@
--- a/plugins/20_events/install 2021-09-10 15:49:02.645000000 +0200
+++ b/plugins/20_events/install 2021-09-06 20:04:19.000000000 +0200
-@@ -78,7 +78,7 @@
+@@ -77,7 +77,7 @@
fi
if [[ -f "$DOKKU_RSYSLOG_FILTER" && "$flag_rsyslog_needs_restart" == "y" ]]; then