summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien LEFEBVRE2018-03-21 14:37:15 +0100
committerFabien LEFEBVRE2018-03-21 14:37:15 +0100
commit85cadaee6829e3302febc9bb463e37e3c9f5a587 (patch)
tree9a78afb90c19918d8a54b773a267282c9518d872
parentefc2afab72831b1795e7278440add76f809c06ec (diff)
downloadaur-85cadaee6829e3302febc9bb463e37e3c9f5a587.tar.gz
Upgraded dokku 0.8.0 to 0.11.6
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--dokku.install1
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb05bc644bfc..7622f45efddb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Apr 11 01:18:24 UTC 2017
pkgbase = dokku
pkgdesc = Docker powered mini-Heroku in around 100 lines of Bash.
- pkgver = 0.9.3
+ pkgver = 0.11.6
pkgrel = 1
url = https://github.com/dokku/dokku
install = dokku.install
@@ -13,16 +11,16 @@ pkgbase = dokku
depends = nginx
depends = plugn>=0.3.0
depends = sshcommand>=0.7.0
- depends = herokuish>=0.3.27
+ depends = herokuish>=0.4.0
depends = openbsd-netcat
depends = gliderlabs-sigil
depends = lsb-release
depends = bind-tools
depends = python
- source = https://github.com/dokku/dokku/archive/v0.9.3.zip
+ source = https://github.com/dokku/dokku/archive/v0.11.6.zip
source = dokku.install
- sha256sums = 28f2cf4f0de5c2425da017c6dfba8559aca85fac267bb7067032587c1e32196e
- sha256sums = 99a9d421fe100ef889f0f23be409289c8e627e55e6d5231c79a50d5da290eeb7
+ sha256sums = 35f24644a287d58a1aaf6205d33ffccbbf3725ed93d73d9a4b46eea8e234b6b1
+ sha256sums = bef43a69c56acf0b927cb5c1b92ef60044f7c963ce04cfd28d2f2c5ee2320afe
pkgname = dokku
diff --git a/PKGBUILD b/PKGBUILD
index a1c2e0ab70a2..eb754ed3e277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Morris Jobke <hey AT morrisjobke.de>
# Maintainer: Martin Mlynář <nexus+arch@smoula.net>
pkgname=dokku
-pkgver=0.9.3
+pkgver=0.11.6
pkgrel=1
pkgdesc="Docker powered mini-Heroku in around 100 lines of Bash."
arch=(any)
@@ -15,7 +15,7 @@ depends=(
'nginx'
'plugn>=0.3.0'
'sshcommand>=0.7.0'
- 'herokuish>=0.3.27'
+ 'herokuish>=0.4.0'
'openbsd-netcat'
'gliderlabs-sigil'
'lsb-release'
@@ -27,8 +27,8 @@ source=(
"https://github.com/dokku/dokku/archive/v${pkgver}.zip"
"${pkgname}.install"
)
-sha256sums=('28f2cf4f0de5c2425da017c6dfba8559aca85fac267bb7067032587c1e32196e'
- '99a9d421fe100ef889f0f23be409289c8e627e55e6d5231c79a50d5da290eeb7')
+sha256sums=('35f24644a287d58a1aaf6205d33ffccbbf3725ed93d73d9a4b46eea8e234b6b1'
+ 'bef43a69c56acf0b927cb5c1b92ef60044f7c963ce04cfd28d2f2c5ee2320afe')
install=${pkgname}.install
package() {
@@ -38,8 +38,11 @@ package() {
install -Dm755 dokku "${pkgdir}/usr/bin/dokku"
+ make go-build
mkdir -p "${pkgdir}/var/lib/dokku/core-plugins/available"
+ cp common.mk "${pkgdir}/var/lib/dokku/core-plugins/common.mk"
cp -r plugins/* "${pkgdir}/var/lib/dokku/core-plugins/available"
+ find plugins/ -mindepth 1 -maxdepth 1 -type d -printf '%f\n' | while read plugin; do cd "${pkgdir}/var/lib/dokku/core-plugins/available/${plugin}" && if [ -e Makefile ]; then make src-clean; fi; done
find plugins/ -mindepth 1 -maxdepth 1 -type d -printf '%f\n' | while read plugin; do touch "${pkgdir}/var/lib/dokku/core-plugins/available/${plugin}/.core"; done
-
+ rm "${pkgdir}/var/lib/dokku/core-plugins/common.mk"
}
diff --git a/dokku.install b/dokku.install
index daac6d899495..9c1c8fe1f07f 100644
--- a/dokku.install
+++ b/dokku.install
@@ -78,5 +78,6 @@ post_remove() {
rm -f /etc/systemd/system/dokku-redeploy.service
rm -f /etc/update-motd.d/99-dokku
rm -rf /var/dokku
+ rm -rf /var/lib/dokku
rm -rf /etc/nginx/conf.d/dokku.conf
}