summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authord1ceward2019-01-15 13:35:06 +0100
committerd1ceward2019-01-15 13:35:06 +0100
commit8ac685f607567e31c01dc61edfb0ed3b05f7157f (patch)
tree898c220484ec667d85f6ffd681008008c942d42f
parent9817588608d78dbb20258d4443f7d3b758bf562d (diff)
downloadaur-8ac685f607567e31c01dc61edfb0ed3b05f7157f.tar.gz
upgpkg: dokku 0.14.2-3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD37
-rw-r--r--dokku.install6
3 files changed, 29 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dacb149f23b..a59b287ccab4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = dokku
pkgdesc = Docker powered mini-Heroku in around 100 lines of Bash.
pkgver = 0.14.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/dokku/dokku
install = dokku.install
arch = any
license = MIT
depends = bind-tools
depends = docker
+ depends = go
depends = gliderlabs-sigil
depends = herokuish
depends = net-tools
@@ -19,7 +20,7 @@ pkgbase = dokku
source = https://github.com/dokku/dokku/archive/v0.14.2.zip
source = dokku.install
sha256sums = 39c4ba9c8a84f60f21bbf4cadd80a9af76e348ee01b0a0843ef614a1253e9674
- sha256sums = 391a0a4ee19fabff11e6ea73425c6ebfe8a9a1f240d228891b97d4b3207a6851
+ sha256sums = c2d7561e5e9931b13421af629672fe417ab36db0f803cadacbf3614507cc0601
pkgname = dokku
diff --git a/PKGBUILD b/PKGBUILD
index 1ff20924e92f..4037e18f2ffc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=dokku
pkgver=0.14.2
-pkgrel=2
+pkgrel=3
pkgdesc="Docker powered mini-Heroku in around 100 lines of Bash."
arch=(any)
url="https://github.com/dokku/dokku"
@@ -12,6 +12,7 @@ license=(MIT)
depends=(
'bind-tools'
'docker'
+ 'go'
'gliderlabs-sigil'
'herokuish'
'net-tools'
@@ -26,31 +27,39 @@ source=(
"${pkgname}.install"
)
sha256sums=('39c4ba9c8a84f60f21bbf4cadd80a9af76e348ee01b0a0843ef614a1253e9674'
- '391a0a4ee19fabff11e6ea73425c6ebfe8a9a1f240d228891b97d4b3207a6851')
+ 'c2d7561e5e9931b13421af629672fe417ab36db0f803cadacbf3614507cc0601')
install="${pkgname}.install"
+prepare() {
+ # Setup go directory
+ mkdir -p gopath/src/github.com/dokku
+ ln -rTsf "${srcdir}/${pkgname}-${pkgver}" "gopath/src/github.com/dokku/${pkgname}"
+ export GOPATH="${srcdir}/gopath"
+
+ # Get go dependencies
+ go get github.com/ryanuber/columnize
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
# Install executable
install -Dm755 dokku "${pkgdir}/usr/bin/dokku"
- # Build go plugins
- make go-build
+ # Add .core and build go plugins
+ for plugin in plugins/*; do
+ if [ -e "${plugin}/Makefile" ]; then make -C "${plugin}" build; fi
+ touch .core
+ done
+
+ # Clean go plugins
+ for plugin in plugins/*; do
+ if [ -e "${plugin}/Makefile" ]; then make -C "${plugin}" src-clean; fi
+ done
# Move all files in place
mkdir -p "${pkgdir}/var/lib/dokku/core-plugins/available"
cp -r plugins/* "${pkgdir}/var/lib/dokku/core-plugins/available"
- cp common.mk "${pkgdir}/var/lib/dokku/core-plugins/common.mk"
-
- find plugins/ -mindepth 1 -maxdepth 1 -type d -printf '%f\n' | while read plugin; do
- # Clean plugins
- cd "${pkgdir}/var/lib/dokku/core-plugins/available/${plugin}"
- if [ -e Makefile ]; then make src-clean ;fi
-
- touch "${pkgdir}/var/lib/dokku/core-plugins/available/${plugin}/.core"
- done
- rm "${pkgdir}/var/lib/dokku/core-plugins/common.mk"
# Version
echo $pkgver > "${pkgdir}/var/lib/dokku/VERSION"
diff --git a/dokku.install b/dokku.install
index fc2a0ae0b3f8..20fb8bd293cd 100644
--- a/dokku.install
+++ b/dokku.install
@@ -43,9 +43,6 @@ post_install() {
fi
done
find -L $DOKKU_LIB_ROOT -type l -delete
-
- echo "Install all core plugins"
- dokku plugin:install --core
chown dokku:dokku -R "$DOKKU_LIB_ROOT/plugins" "$DOKKU_LIB_ROOT/core-plugins"
echo "Ensure proper sshcommand path"
@@ -57,6 +54,9 @@ post_install() {
rm "$DOKKU_ROOT/.ssh/authorized_keys"
fi
+ echo "Install all core plugins"
+ dokku plugin:install --core
+
echo "Update version file"
rm -f "$DOKKU_ROOT/VERSION"
cp "$DOKKU_LIB_ROOT/VERSION" "$DOKKU_ROOT/VERSION"