summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien LEFEBVRE2021-10-25 15:35:50 +0200
committerFabien LEFEBVRE2021-10-25 15:35:50 +0200
commitb3a6b8f8cd9a993aeff4d5607a20b667d8f2f88b (patch)
tree258298df2fae45bf31c0c193553261a542687fd9
parent24ff29510c6cfa69da2a8e0b8bb1d3f31b39b86c (diff)
downloadaur-b3a6b8f8cd9a993aeff4d5607a20b667d8f2f88b.tar.gz
upgpkg: dokku 0.25.7-2
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD32
3 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cd537082f5b..00bfa2cd38f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dokku
pkgdesc = Docker-powered PaaS that helps build and manage the lifecycle of applications
pkgver = 0.25.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dokku/dokku
install = dokku.install
arch = any
diff --git a/.gitignore b/.gitignore
index 1dc327437eb7..e9884e7ba72b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
-src/
-pkg/
-*.zip
+/src/
+/pkg/
+/*.zip
+/*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 039244b151be..99f63b6ea546 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dokku
pkgver=0.25.7
-pkgrel=1
+pkgrel=2
pkgdesc='Docker-powered PaaS that helps build and manage the lifecycle of applications'
arch=('any')
url='https://github.com/dokku/dokku'
@@ -35,8 +35,8 @@ depends=(
'sshcommand'
'unzip'
)
-source=("https://github.com/dokku/dokku/archive/v$pkgver.zip"
- "$pkgname.install"
+source=("${url}/archive/v${pkgver}.zip"
+ "${pkgname}.install"
"crontab_calls.patch"
"systemd_calls.patch"
"LICENSE")
@@ -45,7 +45,7 @@ sha256sums=('a10eece94f2eeb83e48dbda8a7f92b9251b9db718e92c924b6e6fcf69651ac37'
'88fae4d0578b9badaa91d1d4771952b4c7560ba2f56f4eda990034078a44431e'
'c600fefea1c93e9f94192741adc679fb0a05674775d3677954f10db4e09205c6'
'b1ac2fed5ac269fb7bbf651a3d37ef5fd56d2c33320e17cb6e23a22a93f5c046')
-install="$pkgname.install"
+install="${pkgname}.install"
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
@@ -53,9 +53,9 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- export GOPATH="$srcdir/gopath"
+ export GOPATH="${srcdir}/gopath"
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
# Fix issue on crontab calls with arch linux cron implementation
patch -p1 -i "${srcdir}/crontab_calls.patch"
@@ -65,25 +65,29 @@ build() {
# Add .core and build go plugins
for plugin in plugins/*; do
- if [ -e "$plugin/Makefile" ]; then make -C $plugin build; fi
- touch "$plugin/.core"
+ if [ -e "${plugin}/Makefile" ]; then make -C $plugin build; fi
+ touch "${plugin}/.core"
done
# Clean go plugins
for plugin in plugins/*; do
- if [ -e "$plugin/Makefile" ]; then make -C $plugin src-clean; fi
+ if [ -e "${plugin}/Makefile" ]; then make -C $plugin src-clean; fi
done
}
package() {
+ cd "${srcdir}"
+
# Install executable and license
- install -Dm755 "$pkgname-$pkgver/dokku" "$pkgdir/usr/bin/dokku"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/dokku/LICENSE"
+ install -Dm755 "${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Move all files in place
- mkdir -p "$pkgdir/var/lib/dokku/core-plugins/available"
- cp -R "$srcdir/$pkgname-$pkgver/plugins/." "$pkgdir/var/lib/dokku/core-plugins/available"
+ mkdir -p "${pkgdir}/var/lib/dokku/core-plugins/available"
+ cp -R "${srcdir}/${pkgname}-${pkgver}/plugins/." "${pkgdir}/var/lib/dokku/core-plugins/available"
# Version
- echo $pkgver > "$pkgdir/var/lib/dokku/VERSION"
+ echo $pkgver > "${pkgdir}/var/lib/dokku/VERSION"
}