summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin -nexus- Mlynář2015-07-25 23:58:04 +0200
committerMartin -nexus- Mlynář2015-07-25 23:58:04 +0200
commit5e3a0844eeb7fc1834aa417f1cdbcf0b95aa2076 (patch)
treecd4ed147f3381db604a6fd12de619fd411e7872a
downloadaur-5e3a0844eeb7fc1834aa417f1cdbcf0b95aa2076.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD31
-rw-r--r--dokku-psql-single-container.install7
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..167a4999406e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dokku-psql-single-container
+ pkgdesc = Dokku plugin - postgresql, one-container
+ pkgver = 0.3.22
+ pkgrel = 1
+ url = https://github.com/Flink/dokku-psql-single-container
+ install = dokku-psql-single-container.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = dokku
+ source = git+https://github.com/Flink/dokku-psql-single-container.git#tag=v0.3.22
+ source = dokku-psql-single-container.install
+ sha256sums = SKIP
+ sha256sums = 10883701e5b6737064ffc10a932cfcd467ba45c6ee3ebd4f500a86ffc7f2fb06
+
+pkgname = dokku-psql-single-container
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..80eec11b09d2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*.sw[po]
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# AUR metadata
+.AURINFO
+
+pkg/
+src/
+dokku-psql-single-container/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6c38cd92a8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Martin Mlynář <nexus+arch@smoula.net>
+pkgname=dokku-psql-single-container
+pkgver=0.3.22
+pkgrel=1
+pkgdesc="Dokku plugin - postgresql, one-container"
+arch=(i686 x86_64)
+url="https://github.com/Flink/dokku-psql-single-container"
+license=(MIT)
+depends=(
+ 'dokku'
+)
+makedepends=(
+ 'git'
+)
+source=(
+ "git+https://github.com/Flink/dokku-psql-single-container.git#tag=v0.3.22"
+ "${pkgname}.install"
+)
+sha256sums=(
+ 'SKIP'
+ '10883701e5b6737064ffc10a932cfcd467ba45c6ee3ebd4f500a86ffc7f2fb06'
+)
+install=${pkgname}.install
+
+package() {
+ cd "${srcdir}/$pkgname"
+
+ mkdir -p "${pkgdir}"/var/lib/dokku/plugins/psql-sc
+ cp -r * "${pkgdir}"/var/lib/dokku/plugins/psql-sc
+}
+
diff --git a/dokku-psql-single-container.install b/dokku-psql-single-container.install
new file mode 100644
index 000000000000..bff13bcc12e2
--- /dev/null
+++ b/dokku-psql-single-container.install
@@ -0,0 +1,7 @@
+#!/bin/sh
+post_install() {
+ echo "
+ To finish installation run:
+ # dokku plugins-install
+"
+}