summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfengkx2021-02-23 16:58:30 +0800
committerfengkx2021-02-23 16:58:30 +0800
commit176822a96f29af0d0da884033a53f2d604ebed35 (patch)
treecf666dcd97e370e9fd788155e7c95dfda314d4ae
downloadaur-176822a96f29af0d0da884033a53f2d604ebed35.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b12e0a48bb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = doko-rs
+ pkgdesc = Docker-based development-only dependency manager
+ pkgver = 0.1.0
+ pkgrel = 0
+ url = https://github.com/fengkx/doko-rs/
+ arch = x86_64
+ license = Unlicense
+ depends = docker
+ source = doko-rs-0.1.0.tar.gz::https://github.com/fengkx/doko-rs/releases/download/v0.1.0/doko-v0.1.0-x86_64-unknown-linux-gnu.tar.gz
+ sha512sums = 34437f4cb1426a678b5c7604292f22828c2f4376469d7d5f1290978be75f64a2233310fcba42e8a62ca88fa758757bc093a25469692e05d6a166ed8a1734fbb3
+
+pkgname = doko-rs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..132d510b29a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=doko-rs
+_binname=doko
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Docker-based development-only dependency manager"
+arch=("x86_64")
+url="https://github.com/fengkx/doko-rs/"
+license=('Unlicense')
+depends=("docker")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fengkx/$pkgname/releases/download/v$pkgver/doko-v$pkgver-$arch-unknown-linux-gnu.tar.gz")
+sha512sums=("34437f4cb1426a678b5c7604292f22828c2f4376469d7d5f1290978be75f64a2233310fcba42e8a62ca88fa758757bc093a25469692e05d6a166ed8a1734fbb3")
+
+prepare() {
+ mv -f "doko-v$pkgver-$arch-unknown-linux-gnu" "$pkgname-$pkgver"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm +x "$_binname" ${pkgdir}/usr/bin/${_binname}
+
+}