summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2020-12-05 08:59:25 +0000
committerJonas Heinrich2020-12-05 08:59:25 +0000
commit61e16b5c9625b5f7bc7d5933a590b3ae50e1817f (patch)
tree038a58eae5e6df4c46e920f695a26d6036938de0
parent6f858ac935d064728bb4f5bd2eb499f54d829fad (diff)
downloadaur-61e16b5c9625b5f7bc7d5933a590b3ae50e1817f.tar.gz
fix pkgver function
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceaf6983de3d..f580f0752506 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Feb 8 11:07:45 UTC 2017
pkgbase = dokuwiki-git
pkgdesc = Simple to use and highly versatile Open Source wiki software
- pkgver = release_candidate_2009.12.02.r5954.g9c5f31158
+ pkgver = 0.0.20091252c.r8038.gf2a13d874
pkgrel = 1
url = https://www.dokuwiki.org/
arch = any
@@ -15,8 +13,8 @@ pkgbase = dokuwiki-git
backup = etc/httpd/conf/extra/dokuwiki.conf
source = git+https://github.com/splitbrain/dokuwiki.git
source = apache.example.conf
- md5sums = SKIP
- md5sums = c5bed40abf5bb737bad8df29bb7020dc
+ sha512sums = SKIP
+ sha512sums = d37c0288121eb509506e060473dc4fa11142a27442ba6c0bb35b43193089f1ae4c1cfea736866db9c2122f086a825220e497e04460c7f2e81966d5a6fbf9b1f6
pkgname = dokuwiki-git
diff --git a/PKGBUILD b/PKGBUILD
index 5e44fcbab040..3c894cf986b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
# $Id: PKGBUILD 194888 2016-11-07 16:13:16Z spupykin $
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Sébastien Luttringer
pkgname=dokuwiki-git
-pkgver=release_candidate_2009.12.02.r5954.g9c5f31158
+pkgver=0.0.20091252c.r8038.gf2a13d874
pkgrel=1
pkgdesc='Simple to use and highly versatile Open Source wiki software'
arch=('any')
@@ -15,14 +17,14 @@ backup=('etc/webapps/dokuwiki/.htaccess'
options=('!strip')
source=("git+https://github.com/splitbrain/dokuwiki.git"
'apache.example.conf')
-md5sums=('SKIP'
- 'c5bed40abf5bb737bad8df29bb7020dc')
+sha512sums=('SKIP'
+ 'd37c0288121eb509506e060473dc4fa11142a27442ba6c0bb35b43193089f1ae4c1cfea736866db9c2122f086a825220e497e04460c7f2e81966d5a6fbf9b1f6')
provides=("dokuwiki")
conflicts=("dokuwiki")
pkgver() {
cd "dokuwiki"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/upstream\///g'
}
package() {