summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2020-09-27 12:39:58 +0000
committerJonas Heinrich2020-09-27 12:39:58 +0000
commitf1edfcaa808b25c0a0b20ea1483064f7e29453aa (patch)
tree2af8c89740034c5ec013cce25057920f22802224
downloadaur-f1edfcaa808b25c0a0b20ea1483064f7e29453aa.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..968c7ea048d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dokuwiki-plugin-captcha
+ pkgdesc = Use a CAPTCHA challenge to protect DokuWiki against automated spam
+ pkgver = 2019.03.20
+ pkgrel = 1
+ url = http://www.dokuwiki.org/plugin:captcha
+ arch = any
+ license = GPL2
+ depends = dokuwiki
+ options = !strip
+ source = dokuwiki-plugin-captcha-2019.03.20.tar.gz::https://github.com/splitbrain/dokuwiki-plugin-captcha/archive/2019-03-20.tar.gz
+ sha512sums = 1b6788bdfbf68cbfe51e6ef65f9a266c3b5781e0b9d5a285fb41c9ebb646cc54f0af6d925c39a76127aaab8e5c2f1e1d324e474829b8452cc1a60c3b3d08df6c
+
+pkgname = dokuwiki-plugin-captcha
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..9b54d779a891
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=dokuwiki-plugin-captcha
+pkgver=2019.03.20
+pkgrel=1
+pkgdesc="Use a CAPTCHA challenge to protect DokuWiki against automated spam"
+arch=('any')
+url="http://www.dokuwiki.org/plugin:captcha"
+license=('GPL2')
+depends=('dokuwiki')
+makedepends=()
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/splitbrain/dokuwiki-plugin-captcha/archive/2019-03-20.tar.gz")
+sha512sums=('1b6788bdfbf68cbfe51e6ef65f9a266c3b5781e0b9d5a285fb41c9ebb646cc54f0af6d925c39a76127aaab8e5c2f1e1d324e474829b8452cc1a60c3b3d08df6c')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/dokuwiki/lib/plugins"
+ cp -a "${srcdir}/dokuwiki-plugin-captcha-2019-03-20" "${pkgdir}/usr/share/webapps/dokuwiki/lib/plugins/captcha"
+}