summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2020-09-27 12:51:09 +0000
committerJonas Heinrich2020-09-27 12:51:09 +0000
commit38e2c4c1a39ef3d81d30ac643f26b9d457aaf73a (patch)
tree423fb80922a109e97ec682709059dc4c0f5b5036
downloadaur-38e2c4c1a39ef3d81d30ac643f26b9d457aaf73a.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51ee3e11782c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dokuwiki-template-argon
+ pkgdesc = Dokuwiki Template based on the Argon Design System
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://www.dokuwiki.org/template:argon
+ arch = any
+ license = MIT
+ depends = dokuwiki
+ options = !strip
+ source = dokuwiki-template-argon-1.3.tar.gz::https://github.com/IceWreck/Argon-Dokuwiki-Template/archive/v1.3.tar.gz
+ sha512sums = 529a990b4f765b026412df4a54d7b1dc9445c37ae0a301b1189b224a54841e94b64a2c169627d3f6e718f491b8d598985487812daed272b5d2aa50e61439946d
+
+pkgname = dokuwiki-template-argon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14fccc9aabed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=dokuwiki-template-argon
+pkgver=1.3
+pkgrel=1
+pkgdesc="Dokuwiki Template based on the Argon Design System"
+arch=('any')
+url="https://www.dokuwiki.org/template:argon"
+license=('MIT')
+depends=('dokuwiki')
+makedepends=()
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/IceWreck/Argon-Dokuwiki-Template/archive/v${pkgver}.tar.gz")
+sha512sums=('529a990b4f765b026412df4a54d7b1dc9445c37ae0a301b1189b224a54841e94b64a2c169627d3f6e718f491b8d598985487812daed272b5d2aa50e61439946d')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/dokuwiki/lib/tpl"
+ cp -a "${srcdir}/Argon-Dokuwiki-Template-${pkgver}" "${pkgdir}/usr/share/webapps/dokuwiki/lib/tpl/argon"
+}