summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsigvaldm2018-06-23 11:02:00 +0200
committersigvaldm2018-06-23 11:02:00 +0200
commit31592fcf2728c7b0c144c99c9e1585810564b9ce (patch)
tree1a7d795edc9bde3e4e218ee15d57d0082182ab5e
parentf00580848832efc0ba24e92e7daae943675755f2 (diff)
downloadaur-31592fcf2728c7b0c144c99c9e1585810564b9ce.tar.gz
Remove old doxygen patch
-rw-r--r--PKGBUILD3
-rw-r--r--parse_doxygen.patch11
2 files changed, 0 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2b182d99062..c0c70422c082 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,8 +37,6 @@ build() {
[ -n "$PETSC_DIR" ] && source /etc/profile.d/petsc.sh
[ -n "$SLEPC_DIR" ] && source /etc/profile.d/slepc.sh
- # patch ../doc/parse_doxygen.py < ../../../parse_doxygen.patch
-
cmake ..\
-DCMAKE_INSTALL_PREFIX="${pkg}"/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -46,7 +44,6 @@ build() {
-DCMAKE_SKIP_BUILD_RPATH=TRUE \
-DCMAKE_SKIP_RPATH=TRUE \
-DCMAKE_BUILD_TYPE="Release"
- # -DDOLFIN_ENABLE_DOCS=FALSE \
make
}
diff --git a/parse_doxygen.patch b/parse_doxygen.patch
deleted file mode 100644
index 951eeebd1fb3..000000000000
--- a/parse_doxygen.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- parse_doxygen.py 2018-02-20 10:09:01.595734780 +0100
-+++ parse_doxygen.py.new 2018-02-20 10:09:35.768496224 +0100
-@@ -634,6 +634,8 @@
- def add_text(text):
- if text is not None and text.strip():
- tl = text.split('\n')
-+ if isinstance(lines[-1], bytes):
-+ lines[-1] = lines[-1].decode('utf-8')
- lines[-1] += tl[0]
- lines.extend([indent + line for line in tl[1:]])
- if text.endswith('\n'):