summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornw21902021-08-15 10:32:29 -0400
committernw21902021-08-15 10:32:29 -0400
commit786f4cbf5f7c13a4f54761e3f2884ceb1464b294 (patch)
tree9538f11710f98bd124d16c04ac09c71453026b57
parentacf365fd0a6e5ea80243a27621f7d9678f01d99f (diff)
downloadaur-786f4cbf5f7c13a4f54761e3f2884ceb1464b294.tar.gz
Add patch files as temporary workaround
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
-rw-r--r--endian.patch49
-rw-r--r--hdf5.patch13
-rw-r--r--min_element.patch38
5 files changed, 119 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5b8cc33e9cd..ca77675ff3af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,12 @@ pkgbase = dolfin
conflicts = dolfin-git
options = !emptydirs
source = dolfin-2019.1.0.post0.tar.gz::https://bitbucket.org/fenics-project/dolfin/downloads/dolfin-2019.1.0.post0.tar.gz
+ source = min_element.patch
+ source = hdf5.patch
+ source = endian.patch
sha256sums = 61abdcdb13684ba2a3ba4afb7ea6c7907aa0896a46439d3af7e8848483d4392f
+ sha256sums = 80cdfc689854cc4cada1a2bdbde298a27f4456ac1495dceeac030b5a9b02b27e
+ sha256sums = 2e718c5586228fa2031da4b95ef9bb54266fed4c15e195ef47470fddb3a99c36
+ sha256sums = 19dc90d5fa8139ed3311a1df89f74093478dd578833a898e901860349da45284
pkgname = dolfin
-
diff --git a/PKGBUILD b/PKGBUILD
index da83e4c2554e..e660b9645e15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Sigvald Marholm <marholm@marebakken.com>
+# Maintainer: Nick Winovich <nw2190@gmail.com>
# Maintainer: Georg S. Voelker <voelker@maibox.org>
# Based on dolfin-git, maintained by Lucas H. Gabrielli <heitzmann@gmail.com> and submitted by myles
@@ -22,11 +23,21 @@ optdepends=('scotch: libraries for graph, mesh and hypergraph partitioning'
'slepc: eigenvalue problem solvers'
'hdf5<=1.12.0-1: for reading/writing hdf5 files')
options=(!emptydirs)
-source=(${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/fenics-project/${_base}/downloads/${_base}-${pkgver}.tar.gz)
-sha256sums=('61abdcdb13684ba2a3ba4afb7ea6c7907aa0896a46439d3af7e8848483d4392f')
+source=(${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/fenics-project/${_base}/downloads/${_base}-${pkgver}.tar.gz min_element.patch hdf5.patch endian.patch)
+sha256sums=('61abdcdb13684ba2a3ba4afb7ea6c7907aa0896a46439d3af7e8848483d4392f'
+ '80cdfc689854cc4cada1a2bdbde298a27f4456ac1495dceeac030b5a9b02b27e'
+ '2e718c5586228fa2031da4b95ef9bb54266fed4c15e195ef47470fddb3a99c36'
+ '19dc90d5fa8139ed3311a1df89f74093478dd578833a898e901860349da45284')
export MAKEFLAGS="-j1"
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/min_element.patch"
+ patch --forward --strip=0 --input="${srcdir}/hdf5.patch"
+ patch --forward --strip=1 --input="${srcdir}/endian.patch"
+}
+
build() {
cd ${srcdir}/${_base}-${pkgver}
[ -d build ] && rm -rf build
@@ -53,5 +64,3 @@ package() {
cd ${srcdir}/${_base}-${pkgver}/build
make install DESTDIR="${pkgdir}"
}
-
-# vim: shiftwidth=2 softtabstop=2 tabstop=2 noexpandtab
diff --git a/endian.patch b/endian.patch
new file mode 100644
index 000000000000..dcd280c0ed72
--- /dev/null
+++ b/endian.patch
@@ -0,0 +1,49 @@
+From 50d619e29f7664825a87fa526d3d933b521fabf0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Stefan=20Br=C3=BCns?= <stefan.bruens@rwth-aachen.de>
+Date: Thu, 15 Oct 2020 16:44:30 +0200
+Subject: [PATCH] Use __BYTE_ORDER__ instead of removed Boost endian.hpp
+
+endian.hpp has been removed with Boost 1.73.
+---
+ dolfin/io/VTKFile.cpp | 5 ++---
+ dolfin/io/VTKWriter.cpp | 1 -
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/dolfin/io/VTKFile.cpp b/dolfin/io/VTKFile.cpp
+index 2fee53b..4dba84d 100644
+--- a/dolfin/io/VTKFile.cpp
++++ b/dolfin/io/VTKFile.cpp
+@@ -20,7 +20,6 @@
+ #include <vector>
+ #include <iomanip>
+ #include <boost/cstdint.hpp>
+-#include <boost/detail/endian.hpp>
+
+ #include "pugixml.hpp"
+
+@@ -614,9 +613,9 @@ void VTKFile::vtk_header_open(std::size_t num_vertices, std::size_t num_cells,
+ std::string endianness = "";
+ if (encode_string == "binary")
+ {
+- #if defined BOOST_LITTLE_ENDIAN
++ #if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
+ endianness = "byte_order=\"LittleEndian\"";
+- #elif defined BOOST_BIG_ENDIAN
++ #elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
+ endianness = "byte_order=\"BigEndian\"";;
+ #else
+ dolfin_error("VTKFile.cpp",
+diff --git a/dolfin/io/VTKWriter.cpp b/dolfin/io/VTKWriter.cpp
+index eff6934..b57a665 100644
+--- a/dolfin/io/VTKWriter.cpp
++++ b/dolfin/io/VTKWriter.cpp
+@@ -24,7 +24,6 @@
+ #include <sstream>
+ #include <vector>
+ #include <iomanip>
+-#include <boost/detail/endian.hpp>
+
+ #include <dolfin/fem/GenericDofMap.h>
+ #include <dolfin/fem/FiniteElement.h>
+--
+2.28.0
diff --git a/hdf5.patch b/hdf5.patch
new file mode 100644
index 000000000000..123add5326ca
--- /dev/null
+++ b/hdf5.patch
@@ -0,0 +1,13 @@
+--- dolfin/io/HDF5Interface.cpp
++++ dolfin/io/HDF5Interface.cpp
+@@ -281,8 +281,8 @@
+ return false;
+ }
+
+- H5O_info_t object_info;
+- H5Oget_info_by_name(hdf5_file_handle, group_name.c_str(), &object_info,
++ H5O_info1_t object_info;
++ H5Oget_info_by_name1(hdf5_file_handle, group_name.c_str(), &object_info,
+ lapl_id);
+
+ // Close link access properties \ No newline at end of file
diff --git a/min_element.patch b/min_element.patch
new file mode 100644
index 000000000000..a6c4d1d818be
--- /dev/null
+++ b/min_element.patch
@@ -0,0 +1,38 @@
+From 569bbc7f0d218432e76e68137b3f647b4b8faa6f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Stefan=20Br=C3=BCns?= <stefan.bruens@rwth-aachen.de>
+Date: Thu, 15 Oct 2020 16:09:19 +0200
+Subject: [PATCH] Add missing algorithm include for std::min_element/count
+
+algorithm is no longer pulled in implicitly by current boost versions,
+do it explicitly.
+---
+ dolfin/geometry/IntersectionConstruction.cpp | 1 +
+ dolfin/mesh/MeshFunction.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/dolfin/geometry/IntersectionConstruction.cpp b/dolfin/geometry/IntersectionConstruction.cpp
+index 765dbb6..7ba99a8 100644
+--- a/dolfin/geometry/IntersectionConstruction.cpp
++++ b/dolfin/geometry/IntersectionConstruction.cpp
+@@ -18,6 +18,7 @@
+ // First added: 2014-02-03
+ // Last changed: 2017-12-12
+
++#include <algorithm>
+ #include <iomanip>
+ #include <dolfin/mesh/MeshEntity.h>
+ #include "predicates.h"
+diff --git a/dolfin/mesh/MeshFunction.h b/dolfin/mesh/MeshFunction.h
+index 08cbc82..4e68324 100644
+--- a/dolfin/mesh/MeshFunction.h
++++ b/dolfin/mesh/MeshFunction.h
+@@ -27,6 +27,7 @@
+ #include <map>
+ #include <vector>
+
++#include <algorithm>
+ #include <memory>
+ #include <unordered_set>
+ #include <dolfin/common/Hierarchical.h>
+--
+2.28.0