summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-10-05 15:58:33 -0500
committerCarlos Aznarán2023-10-05 15:58:33 -0500
commit5b19de6720273f7f90e49f377c12a6ab6257ab76 (patch)
treedd7421da1c23b73fac14cc8793a75d1a355022c1
parentff98c08db148538e2076dc91b1bab64c1bcab90c (diff)
downloadaur-5b19de6720273f7f90e49f377c12a6ab6257ab76.tar.gz
Bump version to 0.7.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 24 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b77fb82331f8..9c20e2741eda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,23 @@
pkgbase = dolfinx
pkgdesc = Next generation FEniCS problem solving environment
- pkgver = 0.6.0
- pkgrel = 3
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://github.com/FEniCS/dolfinx
arch = x86_64
license = LGPL3
- checkdepends = catch2
+ checkdepends = catch2v3
makedepends = cmake
depends = boost
- depends = python-fenics-ffcx
depends = hdf5-openmpi
- depends = parmetis
depends = petsc
depends = pugixml
+ depends = python-fenics-ffcx
+ depends = scotch
optdepends = adios2: for use ADIOS2 writer
- optdepends = slepc: for use SLEPc eigen solver
- optdepends = scotch: for compute graph partition
optdepends = kahip: for compute graph partition in parallel
- source = dolfinx-0.6.0.tar.gz::https://github.com/FEniCS/dolfinx/archive/v0.6.0.tar.gz
- source = requires-fix.patch::https://github.com/FEniCS/dolfinx/pull/2513.patch
- source = enum-fix.patch::https://github.com/FEniCS/dolfinx/pull/2646.patch
- sha512sums = 6e4bbeca9045cdc558fa5cdfd23abe55bdb773b326381eaa25f843e70d9df39c5707bfdf5412ae1845fc680bbbc7cb641f9cf6e4eb2226a760ddaab8d04237bf
- sha512sums = 00c52da9c6af1babc57160930ff00e200cbfbe27baaa13874fa13dadbadfc03d42540873693cb451a5af6a9bc7bdab6d239b25ca5c8eecb21c40ea9cd47502c4
- sha512sums = 5c5ea77d17604b740419066f9342314461c9b48216b4021d6ee822338721859c2e9c5a4406fb489d03416567735f4238cc8900d592b87a13956c08010a35b856
+ optdepends = parmetis: for parallel graph partitioning
+ optdepends = slepc: for use SLEPc eigen solver
+ source = dolfinx-0.7.0.tar.gz::https://github.com/FEniCS/dolfinx/archive/v0.7.0.tar.gz
+ sha512sums = 69c7f740b69492894c2dad8a968e614abcba7faa345befa6383fa939442df1627bb05286ddbdc11fa96eb754d7e5983030a7df36320e238e0bfb6f21fc933059
pkgname = dolfinx
diff --git a/PKGBUILD b/PKGBUILD
index b082a903761f..ebe31705e791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,23 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
pkgname=dolfinx
pkgdesc="Next generation FEniCS problem solving environment"
-pkgver=0.6.0
-pkgrel=3
+pkgver=0.7.0
+pkgrel=1
arch=(x86_64)
url="https://github.com/FEniCS/${pkgname}"
license=(LGPL3)
makedepends=(cmake)
-depends=(boost python-fenics-ffcx hdf5-openmpi parmetis petsc pugixml)
-checkdepends=(catch2)
+depends=(boost hdf5-openmpi petsc pugixml python-fenics-ffcx scotch)
+checkdepends=(catch2v3)
optdepends=('adios2: for use ADIOS2 writer'
- 'slepc: for use SLEPc eigen solver'
- 'scotch: for compute graph partition'
- 'kahip: for compute graph partition in parallel')
-source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
- requires-fix.patch::${url}/pull/2513.patch
- enum-fix.patch::${url}/pull/2646.patch)
-sha512sums=('6e4bbeca9045cdc558fa5cdfd23abe55bdb773b326381eaa25f843e70d9df39c5707bfdf5412ae1845fc680bbbc7cb641f9cf6e4eb2226a760ddaab8d04237bf'
- '00c52da9c6af1babc57160930ff00e200cbfbe27baaa13874fa13dadbadfc03d42540873693cb451a5af6a9bc7bdab6d239b25ca5c8eecb21c40ea9cd47502c4'
- '5c5ea77d17604b740419066f9342314461c9b48216b4021d6ee822338721859c2e9c5a4406fb489d03416567735f4238cc8900d592b87a13956c08010a35b856')
+ 'kahip: for compute graph partition in parallel'
+ 'parmetis: for parallel graph partitioning'
+ 'slepc: for use SLEPc eigen solver')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('69c7f740b69492894c2dad8a968e614abcba7faa345befa6383fa939442df1627bb05286ddbdc11fa96eb754d7e5983030a7df36320e238e0bfb6f21fc933059')
prepare() {
- sed -i '/#include <vector>/a #include <cstdint>' ${pkgname}-${pkgver}/cpp/dolfinx/graph/AdjacencyList.h
- sed -i '/#include <vector>/a #include <cstdint>' ${pkgname}-${pkgver}/cpp/dolfinx/io/xdmf_mesh.h
- cd ${pkgname}-${pkgver}
- # https://github.com/FEniCS/dolfinx/issues/2645
- patch -p1 -i ../requires-fix.patch
- patch -p1 -i ../enum-fix.patch
- # gcc-13-compatibilty
+ sed -i '/#include <random>/a #include <functional>' ${pkgname}-${pkgver}/cpp/test/common/sort.cpp
}
build() {
@@ -45,6 +35,7 @@ build() {
-DDOLFINX_ENABLE_PARMETIS=ON \
-DDOLFINX_ENABLE_SCOTCH=ON \
-DDOLFINX_ENABLE_SLEPC=ON \
+ -DDOLFINX_SKIP_BUILD_TESTS=OFF \
-Wno-dev
cmake --build build --target all
}
@@ -53,18 +44,21 @@ check() {
if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
export OMPI_MCA_opal_warn_on_missing_libcuda=0
fi
+
ffcx ${pkgname}-${pkgver}/cpp/test/poisson.py -o ${pkgname}-${pkgver}/cpp/test
DESTDIR="${PWD}/tmp_install" cmake --build build --target install
+
CMAKE_PREFIX_PATH="${srcdir}/tmp_install/usr/lib/cmake/${pkgname}" cmake \
-S ${pkgname}-${pkgver}/cpp/test \
-B build_test
cmake --build build_test
ctest --test-dir build_test
+
CMAKE_PREFIX_PATH="${srcdir}/tmp_install/usr/lib/cmake/${pkgname}" cmake \
-S ${pkgname}-${pkgver}/cpp/demo \
-B build_demo
cmake --build build_demo
- ctest -E "(demo_poisson_mpi_*|demo_hyperelasticity_mpi_*|demo_interpolation-io_mpi_*|demo_interpolation_different_meshes_mpi_*|demo_poisson_matrix_free_mpi_*)" --test-dir build_demo
+ ctest -E "(demo_poisson_mpi_*|demo_hyperelasticity_mpi_*|demo_biharmonic_mpi_*)" --test-dir build_demo
}
package() {