summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-29 16:02:48 -0500
committerCarlos Aznarán2024-02-29 16:02:48 -0500
commit92d77933c76d5caaa98113e40218c488551cb20c (patch)
tree906da28dd96c28822496ea6ed7d49a2ef22d22cd
parentb0b89011254e1819f22e71594c7474a839905fd1 (diff)
downloadaur-92d77933c76d5caaa98113e40218c488551cb20c.tar.gz
Update license name
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c44b74eec2a..813eb5faae46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,11 +4,11 @@ pkgbase = dolfinx
pkgrel = 1
url = https://github.com/FEniCS/dolfinx
arch = x86_64
- license = LGPL3
+ license = LGPL-3.0-or-later
+ license = GPL-3.0-or-later
checkdepends = catch2
makedepends = cmake
depends = boost
- depends = hdf5-openmpi
depends = petsc
depends = pugixml
depends = python-fenics-ffcx
diff --git a/PKGBUILD b/PKGBUILD
index f03a65552dbf..837e73c1fad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@ pkgver=0.7.3
pkgrel=1
arch=(x86_64)
url="https://github.com/FEniCS/${pkgname}"
-license=(LGPL3)
+license=(LGPL-3.0-or-later GPL-3.0-or-later)
makedepends=(cmake)
-depends=(boost hdf5-openmpi petsc pugixml python-fenics-ffcx scotch)
+depends=(boost petsc pugixml python-fenics-ffcx scotch)
checkdepends=(catch2)
optdepends=('adios2: for use ADIOS2 writer'
'kahip: for compute graph partition in parallel'
@@ -37,10 +37,6 @@ build() {
}
check() {
- if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
- export OMPI_MCA_opal_warn_on_missing_libcuda=0
- fi
-
ffcx ${pkgname}-${pkgver}/cpp/test/poisson.py -o ${pkgname}-${pkgver}/cpp/test
DESTDIR="${PWD}/tmp_install" cmake --build build --target install