summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2017-05-23 00:38:47 -0700
committerpyamsoft2017-05-23 00:38:47 -0700
commit7fcb7358537104e41aac2c47c402c071a9ad20bf (patch)
treeacc5e264d610202b4bfc4e56bcf30a739662ac85
parent47bd13f001a63164ea4cb3ed84b6ae9ffb07bd5c (diff)
downloadaur-7fcb7358537104e41aac2c47c402c071a9ad20bf.tar.gz
Update for FM 5.0.3
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-RasterFont.cpp-compile-error.patch126
-rw-r--r--PKGBUILD13
3 files changed, 6 insertions, 141 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c11fbd194473..82d5f2688b43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dolphin-emu-faster-melee
pkgdesc = The FasterMelee NetPlay build of the Dolphin Emulator
- pkgver = 4.4
- pkgrel = 4
+ pkgver = 5.0.3
+ pkgrel = 1
url = http://fastermelee.net
install = faster-melee.install
arch = x86_64
@@ -22,15 +22,13 @@ pkgbase = dolphin-emu-faster-melee
optdepends = pulseaudio: PulseAudio backend
provides = dolphin-emu
options = !emptydirs
- source = dolphin-emu-faster-melee::git+https://github.com/Tinob/Ishiiruka.git#commit=0b00f1f6267190a8bf9a3584497a35d8762eb0a9
- source = 0001-Fix-RasterFont.cpp-compile-error.patch
+ source = dolphin-emu-faster-melee::git+https://github.com/Tinob/Ishiiruka.git#commit=d462ca38724db65d7f92f3edbd16b6657291e420
source = GALE01r2.ini
source = GALE01.ini
source = MNCE02.ini
source = NMNB01.ini
source = PALE02.ini
sha256sums = SKIP
- sha256sums = 7a512b04f1d067e7ba59f4b0c7b3720018eccfd6bb63cd5c47ac84ee82b3ccfa
sha256sums = eae12be9d008453d09bf1379315a2299eca9c76cc093727f8f41926193981c50
sha256sums = 62abf45f5064fac79aeead6340120be5beb8ad7a64f25fd85c07b45e3756df3f
sha256sums = 4dd62a40be7a41c92079c9ee23f5fd458c85f275431881c707450f634fdcf24c
diff --git a/0001-Fix-RasterFont.cpp-compile-error.patch b/0001-Fix-RasterFont.cpp-compile-error.patch
deleted file mode 100644
index 46af040d95ea..000000000000
--- a/0001-Fix-RasterFont.cpp-compile-error.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-From a6dcab66bc44acd052cd03dae21a18b76a07e104 Mon Sep 17 00:00:00 2001
-From: Connor Lirot <ccl2of4@tx.rr.com>
-Date: Sun, 26 Mar 2017 11:59:04 -0500
-Subject: [PATCH] Fix RasterFont.cpp compile error
-
----
- Source/Core/VideoBackends/OGL/RasterFont.cpp | 44 ++++++++++++++--------------
- 1 file changed, 22 insertions(+), 22 deletions(-)
-
-diff --git a/Source/Core/VideoBackends/OGL/RasterFont.cpp b/Source/Core/VideoBackends/OGL/RasterFont.cpp
-index 1f5a51feca..fdba875d13 100644
---- a/Source/Core/VideoBackends/OGL/RasterFont.cpp
-+++ b/Source/Core/VideoBackends/OGL/RasterFont.cpp
-@@ -15,12 +15,12 @@
- namespace OGL
- {
-
--static const int CHAR_WIDTH = 8;
--static const int CHAR_HEIGHT = 13;
--static const int CHAR_OFFSET = 32;
--static const int CHAR_COUNT = 95;
-+static const int CHARACTER_WIDTH = 8;
-+static const int CHARACTER_HEIGHT = 13;
-+static const int CHARACTER_OFFSET = 32;
-+static const int CHARACTER_COUNT = 95;
-
--static const u8 rasters[CHAR_COUNT][CHAR_HEIGHT] = {
-+static const u8 rasters[CHARACTER_COUNT][CHARACTER_HEIGHT] = {
- {0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00},
- {0x00, 0x00, 0x18, 0x18, 0x00, 0x00, 0x18, 0x18, 0x18, 0x18, 0x18, 0x18, 0x18},
- {0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x36, 0x36, 0x36, 0x36},
-@@ -146,27 +146,27 @@ RasterFont::RasterFont()
- glGenTextures(1, &texture);
- glActiveTexture(GL_TEXTURE8);
- glBindTexture(GL_TEXTURE_2D, texture);
-- std::vector<u32> texture_data(CHAR_WIDTH * CHAR_COUNT * CHAR_HEIGHT);
-- for (int y = 0; y < CHAR_HEIGHT; y++)
-+ std::vector<u32> texture_data(CHARACTER_WIDTH * CHARACTER_COUNT * CHARACTER_HEIGHT);
-+ for (int y = 0; y < CHARACTER_HEIGHT; y++)
- {
-- for (int c = 0; c < CHAR_COUNT; c++)
-+ for (int c = 0; c < CHARACTER_COUNT; c++)
- {
-- for (int x = 0; x < CHAR_WIDTH; x++)
-+ for (int x = 0; x < CHARACTER_WIDTH; x++)
- {
-- bool pixel = (0 != (rasters[c][y] & (1 << (CHAR_WIDTH - x - 1))));
-- texture_data[CHAR_WIDTH * CHAR_COUNT * y + CHAR_WIDTH * c + x] = pixel ? -1 : 0;
-+ bool pixel = (0 != (rasters[c][y] & (1 << (CHARACTER_WIDTH - x - 1))));
-+ texture_data[CHARACTER_WIDTH * CHARACTER_COUNT * y + CHARACTER_WIDTH * c + x] = pixel ? -1 : 0;
- }
- }
- }
- glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MAX_LEVEL, 0);
-- glTexImage2D(GL_TEXTURE_2D, 0, GL_RGBA, CHAR_WIDTH * CHAR_COUNT, CHAR_HEIGHT, 0, GL_RGBA, GL_UNSIGNED_BYTE, texture_data.data());
-+ glTexImage2D(GL_TEXTURE_2D, 0, GL_RGBA, CHARACTER_WIDTH * CHARACTER_COUNT, CHARACTER_HEIGHT, 0, GL_RGBA, GL_UNSIGNED_BYTE, texture_data.data());
-
- // generate shader
- ProgramShaderCache::CompileShader(s_shader, s_vertexShaderSrc, s_fragmentShaderSrc);
- s_shader.Bind();
-
- // bound uniforms
-- glUniform2f(glGetUniformLocation(s_shader.glprogid, "charSize"), 1.0f / GLfloat(CHAR_COUNT), 1.0f);
-+ glUniform2f(glGetUniformLocation(s_shader.glprogid, "charSize"), 1.0f / GLfloat(CHARACTER_COUNT), 1.0f);
- uniform_color_id = glGetUniformLocation(s_shader.glprogid, "color");
- glUniform4f(uniform_color_id, 1.0f, 1.0f, 1.0f, 1.0f);
- uniform_offset_id = glGetUniformLocation(s_shader.glprogid, "offset");
-@@ -196,8 +196,8 @@ void RasterFont::printMultilineText(const std::string& text, double start_x, dou
- std::vector<GLfloat> vertices(text.length() * 6 * 4);
-
- int usage = 0;
-- GLfloat delta_x = GLfloat(2 * CHAR_WIDTH) / GLfloat(bbWidth);
-- GLfloat delta_y = GLfloat(2 * CHAR_HEIGHT) / GLfloat(bbHeight);
-+ GLfloat delta_x = GLfloat(2 * CHARACTER_WIDTH) / GLfloat(bbWidth);
-+ GLfloat delta_y = GLfloat(2 * CHARACTER_HEIGHT) / GLfloat(bbHeight);
- GLfloat border_x = 2.0f / GLfloat(bbWidth);
- GLfloat border_y = 4.0f / GLfloat(bbHeight);
-
-@@ -220,37 +220,37 @@ void RasterFont::printMultilineText(const std::string& text, double start_x, dou
- continue;
- }
-
-- if (c < CHAR_OFFSET || c >= CHAR_COUNT + CHAR_OFFSET)
-+ if (c < CHARACTER_OFFSET || c >= CHARACTER_COUNT + CHARACTER_OFFSET)
- continue;
-
- vertices[usage++] = x;
- vertices[usage++] = y;
-- vertices[usage++] = GLfloat(c - CHAR_OFFSET);
-+ vertices[usage++] = GLfloat(c - CHARACTER_OFFSET);
- vertices[usage++] = 0.0f;
-
- vertices[usage++] = x + delta_x;
- vertices[usage++] = y;
-- vertices[usage++] = GLfloat(c - CHAR_OFFSET + 1);
-+ vertices[usage++] = GLfloat(c - CHARACTER_OFFSET + 1);
- vertices[usage++] = 0.0f;
-
- vertices[usage++] = x + delta_x;
- vertices[usage++] = y + delta_y;
-- vertices[usage++] = GLfloat(c - CHAR_OFFSET + 1);
-+ vertices[usage++] = GLfloat(c - CHARACTER_OFFSET + 1);
- vertices[usage++] = 1.0f;
-
- vertices[usage++] = x;
- vertices[usage++] = y;
-- vertices[usage++] = GLfloat(c - CHAR_OFFSET);
-+ vertices[usage++] = GLfloat(c - CHARACTER_OFFSET);
- vertices[usage++] = 0.0f;
-
- vertices[usage++] = x + delta_x;
- vertices[usage++] = y + delta_y;
-- vertices[usage++] = GLfloat(c - CHAR_OFFSET + 1);
-+ vertices[usage++] = GLfloat(c - CHARACTER_OFFSET + 1);
- vertices[usage++] = 1.0f;
-
- vertices[usage++] = x;
- vertices[usage++] = y + delta_y;
-- vertices[usage++] = GLfloat(c - CHAR_OFFSET);
-+ vertices[usage++] = GLfloat(c - CHARACTER_OFFSET);
- vertices[usage++] = 1.0f;
-
- x += delta_x + border_x;
---
-2.12.1
-
diff --git a/PKGBUILD b/PKGBUILD
index a44131635823..326531cfaa55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@
pkgname=dolphin-emu-faster-melee
# shellcheck disable=SC2034
-pkgver=4.4
+pkgver=5.0.3
# shellcheck disable=SC2034
-pkgrel=4
+pkgrel=1
# shellcheck disable=SC2034
pkgdesc='The FasterMelee NetPlay build of the Dolphin Emulator'
# shellcheck disable=SC2034
@@ -32,8 +32,7 @@ optdepends=('pulseaudio: PulseAudio backend')
options=('!emptydirs')
# The commit for FasterMelee 4.3 (unchanged for FasterMelee 4.4)
# shellcheck disable=SC2034
-source=("${pkgname}::git+https://github.com/Tinob/Ishiiruka.git#commit=0b00f1f6267190a8bf9a3584497a35d8762eb0a9"
- "0001-Fix-RasterFont.cpp-compile-error.patch"
+source=("${pkgname}::git+https://github.com/Tinob/Ishiiruka.git#commit=d462ca38724db65d7f92f3edbd16b6657291e420"
"GALE01r2.ini"
"GALE01.ini"
"MNCE02.ini"
@@ -42,7 +41,6 @@ source=("${pkgname}::git+https://github.com/Tinob/Ishiiruka.git#commit=0b00f1f62
)
# shellcheck disable=SC2034
sha256sums=('SKIP'
- '7a512b04f1d067e7ba59f4b0c7b3720018eccfd6bb63cd5c47ac84ee82b3ccfa'
'eae12be9d008453d09bf1379315a2299eca9c76cc093727f8f41926193981c50'
'62abf45f5064fac79aeead6340120be5beb8ad7a64f25fd85c07b45e3756df3f'
'4dd62a40be7a41c92079c9ee23f5fd458c85f275431881c707450f634fdcf24c'
@@ -59,11 +57,6 @@ prepare() {
msg "Failed to cd into ${srcdir}/${pkgname}"
return 1
}
-
- patch -p1 < ../0001-Fix-RasterFont.cpp-compile-error.patch || {
- msg "Failed to apply patch file"
- return 1
- }
}
build() {