summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2016-10-19 00:24:05 -0700
committerpyamsoft2016-10-19 00:24:05 -0700
commite3506dc7ed3e3598cec1f6c9ce677055a93ffa83 (patch)
treee8d138781cc3a93a6625b40c0bd8c2c95ba8ab44
downloadaur-e3506dc7ed3e3598cec1f6c9ce677055a93ffa83.tar.gz
Intial commit
Faster Melee 4.3 release
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD73
2 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..939268f23905
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = dolphin-emu-faster-melee
+ pkgdesc = The FasterMelee build of the Dolphin Emulator
+ pkgver = 4.3
+ pkgrel = 1
+ url = http://fastermelee.net
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = bluez-libs
+ depends = enet
+ depends = ffmpeg
+ depends = libao
+ depends = libevdev
+ depends = mbedtls
+ depends = miniupnpc
+ depends = openal
+ depends = portaudio
+ depends = soundtouch
+ depends = xdg-utils
+ depends = wxgtk
+ optdepends = pulseaudio: PulseAudio backend
+ options = !emptydirs
+ source = dolphin-emu-faster-melee::git+https://github.com/Tinob/Ishiiruka.git#commit=0b00f1f6267190a8bf9a3584497a35d8762eb0a9
+ sha256sums = SKIP
+
+pkgname = dolphin-emu-faster-melee
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97096fadf7d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: pyamsoft <pyam(dot)soft(at)gmail(dot)com>
+
+pkgname=dolphin-emu-faster-melee
+# shellcheck disable=SC2034
+pkgver=4.3
+# shellcheck disable=SC2034
+pkgrel=1
+# shellcheck disable=SC2034
+pkgdesc='The FasterMelee build of the Dolphin Emulator'
+# shellcheck disable=SC2034
+arch=('x86_64')
+# shellcheck disable=SC2034
+url='http://fastermelee.net'
+# shellcheck disable=SC2034
+license=('GPL')
+
+# shellcheck disable=SC2034
+makedepends=('cmake')
+
+# shellcheck disable=SC2034
+depends=('bluez-libs' 'enet' 'ffmpeg' 'libao' 'libevdev' 'mbedtls' 'miniupnpc'
+ 'openal' 'portaudio' 'soundtouch' 'xdg-utils' 'wxgtk')
+# shellcheck disable=SC2034
+optdepends=('pulseaudio: PulseAudio backend')
+
+# shellcheck disable=SC2034
+options=('!emptydirs')
+
+# The commit for FasterMelee 4.3
+# shellcheck disable=SC2034
+source=("${pkgname}::git+https://github.com/Tinob/Ishiiruka.git#commit=0b00f1f6267190a8bf9a3584497a35d8762eb0a9")
+
+# shellcheck disable=SC2034
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}" || {
+ msg "Failed to cd into ${srcdir}/${pkgname}"
+ return 1
+ }
+
+ mkdir build
+ cd build || {
+ msg "Failed to cd into ${srcdir}/${pkgname}/build"
+ return 1
+ }
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_CXX_FLAGS='-fno-pie' \
+ -DENABLE_LTO='TRUE' \
+ -DUSE_SHARED_ENET='TRUE' \
+ -DDISTRIBUTOR='pyamsoft'
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}" || {
+ msg "Failed to cd into ${srcdir}/${pkgname}"
+ return 1
+ }
+
+ cd build || {
+ msg "Failed to cd into ${srcdir}/${pkgname}/build"
+ return 1
+ }
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm 644 ../Data/51-usb-device.rules -t "${pkgdir}"/usr/lib/udev/rules.d/
+}
+
+# vim: ts=2 sw=2 et: