summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2016-12-25 21:34:28 -0800
committerpyamsoft2016-12-25 21:34:28 -0800
commitf491fc7193da49c0295eac934d4d463f4bd251f0 (patch)
treecd5610405e4bf2d621cbaa9ecdf17a0d6dc75e4c
parentfe889226170cdb0a8a9fcff5209365ec35f99b58 (diff)
downloadaur-f491fc7193da49c0295eac934d4d463f4bd251f0.tar.gz
Add faster melee install file, remove messages from the package function
-rw-r--r--PKGBUILD14
-rw-r--r--faster-melee.install16
2 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 091d477b124c..b91a45754046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,34 +13,29 @@ arch=('x86_64')
url='http://fastermelee.net'
# shellcheck disable=SC2034
license=('GPL')
-
+# shellcheck disable=SC2034
+install="faster-melee.net"
# shellcheck disable=SC2034
makedepends=('cmake')
-
# shellcheck disable=SC2034
depends=('bluez-libs' 'enet' 'ffmpeg' 'libao' 'libevdev' 'mbedtls' 'miniupnpc'
'portaudio' 'sfml' 'soundtouch' 'xdg-utils' 'wxgtk')
# shellcheck disable=SC2034
optdepends=('pulseaudio: PulseAudio backend')
-
# shellcheck disable=SC2034
options=('!emptydirs')
-
-# The commit for FasterMelee 4.3
+# The commit for FasterMelee 4.3 (unchanged for FasterMelee 4.4)
# shellcheck disable=SC2034
source=("${pkgname}::git+https://github.com/Tinob/Ishiiruka.git#commit=0b00f1f6267190a8bf9a3584497a35d8762eb0a9"
"GALE01.ini"
"GALE01r2.ini"
)
-
# shellcheck disable=SC2034
sha256sums=('SKIP'
'62abf45f5064fac79aeead6340120be5beb8ad7a64f25fd85c07b45e3756df3f'
'a2ab0e1b737ff8af5a0ccacc40147d331ba0abe5e19aac019add68e732289605')
-
# shellcheck disable=SC2034
provides=('dolphin-emu')
-
# shellcheck disable=SC2034
conflicts=('dolphin-emu' 'dolphin-emu-git')
@@ -84,9 +79,6 @@ package() {
# Patch Gecko Codes
cp -f "${srcdir}/GALE01r2.ini" "${pkgdir}"/usr/share/dolphin-emu/sys/GameSettings/GALE01r2.ini
-
- msg "Make sure you install the GALE01.ini config file into:"
- msg "${HOME}/.local/share/dolphin-emu/GameSettings/GALE01.ini"
}
# vim: ts=2 sw=2 et:
diff --git a/faster-melee.install b/faster-melee.install
new file mode 100644
index 000000000000..57fcfc905dc1
--- /dev/null
+++ b/faster-melee.install
@@ -0,0 +1,16 @@
+post_install() {
+ printf -- "%s\n" "$(cat << EOF
+
+ Make sure you install the GALE01.ini config file into:
+ ${HOME}/.local/share/dolphin-emu/GameSettings/GALE01.ini
+
+ See https://fastermelee.net for more information on the
+ Faster Melee build of the Dolphin Emulator.
+
+EOF
+)"
+}
+
+post_upgrade() {
+ post_install
+}