summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-22 01:39:42 +0100
committerDaniel Peukert2024-01-22 01:39:42 +0100
commit03fff1c8d6ada992c10f6e98e06775635fae3be8 (patch)
treeec28572b5c4dee95bff8f58263ec3612bea1f2bc
parent3830eacf73c4edcb531f033f5c343f25e87bf83d (diff)
downloadaur-03fff1c8d6ada992c10f6e98e06775635fae3be8.tar.gz
Fix dolphin-emu-git build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--minizip-ng.diff13
3 files changed, 9 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1723d7d48542..e063f35401e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r20840.g57327be7f3
+ pkgver = 5.0.r20967.g713572e874
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
arch = aarch64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = cmake
makedepends = git
makedepends = miniupnpc
@@ -25,7 +25,6 @@ pkgbase = dolphin-emu-git
depends = libxrandr
depends = lzo
depends = mbedtls2
- depends = minizip-ng
depends = pugixml
depends = sfml
depends = speexdsp
@@ -53,14 +52,12 @@ pkgbase = dolphin-emu-git
source = dolphin-emu-git-mgba::git+https://github.com/mgba-emu/mgba.git
source = dolphin-emu-git-rcheevos::git+https://github.com/RetroAchievements/rcheevos.git
source = dolphin-emu-git-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
- source = minizip-ng.diff
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = 568ca7db64149e9ac9409947689a8390783b891e6cff7b096690771512db3e19f9d8551a8739921d8a9f6ec4a9de747811a2efc8cdd4791d715677772db7fa8e
pkgname = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator - git version
@@ -76,7 +73,6 @@ pkgname = dolphin-emu-git
depends = libxrandr
depends = lzo
depends = mbedtls2
- depends = minizip-ng
depends = pugixml
depends = sfml
depends = speexdsp
diff --git a/PKGBUILD b/PKGBUILD
index c999c52f0adf..13859bf52a2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,17 @@ _noguipkgname="$_projectname-emu-nogui"
_toolpkgname="$_projectname-emu-tool"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git" "$_toolpkgname-git")
-pkgver='5.0.r20840.g57327be7f3'
+pkgver='5.0.r20967.g713572e874'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
arch=('x86_64' 'aarch64')
url="https://$_mainpkgname.org"
-license=('GPL2')
+license=('GPL-2.0-or-later')
depends=(
'alsa-lib' 'bluez-libs' 'bzip2' 'hidapi' 'libevdev' 'libgl' 'libpulse' 'libx11'
- 'libxi' 'libxrandr' 'lzo' 'mbedtls2' 'minizip-ng' 'pugixml' 'sfml' 'speexdsp'
- 'xz' 'zstd' 'cubeb' 'zlib-ng'
+ 'libxi' 'libxrandr' 'lzo' 'mbedtls2' 'pugixml' 'sfml' 'speexdsp' 'xz' 'zstd'
+ 'cubeb' 'zlib-ng'
'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libcurl.so' 'libfmt.so'
'libsfml-network.so' 'libsfml-system.so' 'libspng.so' 'libswscale.so'
'libudev.so' 'libusb-1.0.so' 'libxxhash.so'
@@ -33,15 +33,13 @@ source=(
"$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
"$pkgname-rcheevos::git+https://github.com/RetroAchievements/rcheevos.git"
"$pkgname-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git"
- 'minizip-ng.diff'
)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '568ca7db64149e9ac9409947689a8390783b891e6cff7b096690771512db3e19f9d8551a8739921d8a9f6ec4a9de747811a2efc8cdd4791d715677772db7fa8e')
+ 'SKIP')
_sourcedirectory="$pkgname"
@@ -50,9 +48,6 @@ prepare() {
if [ -d 'build/' ]; then rm -rf 'build/'; fi
mkdir 'build/'
- # Fix minizip-ng name for Arch
- patch --forward -p1 < "$srcdir/minizip-ng.diff"
-
# Provide submodules
declare -A _submodules=(
[enet]='enet/enet'
@@ -85,6 +80,7 @@ build() {
# USE_SYSTEM_LIBS - we want to use system libs where possible
# USE_SYSTEM_LIBMGBA - the current version of mgba in the repos is not compatible with Dolphin
# USE_SYSTEM_ENET - the current version of enet in the repos is not compatible with Dolphin
+ # USE_SYSTEM_MINIZIP - the current version of minizip-ng in the repos is not compatible with Dolphin
cmake -S '.' -B 'build/' -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
@@ -94,6 +90,7 @@ build() {
-DUSE_SYSTEM_LIBS=ON \
-DUSE_SYSTEM_LIBMGBA=OFF \
-DUSE_SYSTEM_ENET=OFF \
+ -DUSE_SYSTEM_MINIZIP=OFF \
-Wno-dev
cmake --build 'build/'
}
diff --git a/minizip-ng.diff b/minizip-ng.diff
deleted file mode 100644
index b63f499b0e83..000000000000
--- a/minizip-ng.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ed6c64a2fa..1ba0c73567 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -678,7 +678,7 @@ dolphin_find_optional_system_library_pkgconfig(ZSTD libzstd>=1.4.0 zstd::zstd Ex
-
- add_subdirectory(Externals/zlib-ng)
-
--dolphin_find_optional_system_library_pkgconfig(MINIZIP minizip>=3.0.0 minizip::minizip Externals/minizip)
-+dolphin_find_optional_system_library_pkgconfig(MINIZIP minizip-ng>=3.0.0 minizip::minizip Externals/minizip)
-
- dolphin_find_optional_system_library(LZO Externals/LZO)
-