summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-12-09 11:24:31 +0100
committerDaniel Peukert2023-12-09 11:24:31 +0100
commit051ab319a94d046aa896ac3e546ec8be654cfe17 (patch)
treef076376d3978542274a4ecdcb5e2cc90b3b5e588
parent2b953d18020677125e66fcf1065ec6cf2214a7ea (diff)
downloadaur-051ab319a94d046aa896ac3e546ec8be654cfe17.tar.gz
Fix dolphin-emu-git build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56af01463372..640472fccae7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r20507.g5f7e9d3bf1
+ pkgver = 5.0.r20580.gdd227fea5a
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ca038abf7422..540fbbee0ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _noguipkgname="$_projectname-emu-nogui"
_toolpkgname="$_projectname-emu-tool"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git" "$_toolpkgname-git")
-pkgver='5.0.r20507.g5f7e9d3bf1'
+pkgver='5.0.r20580.gdd227fea5a'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -81,6 +81,7 @@ build() {
# CMAKE_BUILD_TYPE - the dolphin-emu package in the repos uses 'None' for some reason, so we use it as well
# USE_SYSTEM_LIBS - we want to use system libs where possible
# USE_SYSTEM_LIBMGBA - the current version of mgba in the repos is not compatible with Dolphin
+ # USE_SYSTEM_ENET - the current version of enet in the repos is not compatible with Dolphin
cmake -S '.' -B 'build/' -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
@@ -89,6 +90,7 @@ build() {
-DENABLE_AUTOUPDATE=OFF \
-DUSE_SYSTEM_LIBS=ON \
-DUSE_SYSTEM_LIBMGBA=OFF \
+ -DUSE_SYSTEM_ENET=OFF \
-Wno-dev
cmake --build 'build/'
}