summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-08-05 00:39:34 +0200
committerDaniel Peukert2022-08-05 00:39:34 +0200
commit181217b4b3b8c404236df44ed5bd73771b3bbb0c (patch)
treefe20a47a327e553684ea7698aa2a35a013b5bc30
parent3f1e0d435e804f8cdc0785b5e5610a4949b7a20b (diff)
downloadaur-181217b4b3b8c404236df44ed5bd73771b3bbb0c.tar.gz
Add dolphin-emu-git zlib-ng and libspng external deps
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ce6c80cb4d3..c1ff4a9a7568 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r16907.g537fe33997
+ pkgver = 5.0.r17132.g5508c52a95
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
@@ -16,7 +16,6 @@ pkgbase = dolphin-emu-git
depends = hidapi
depends = libevdev
depends = libgl
- depends = libpng
depends = libpulse
depends = libx11
depends = libxi
@@ -26,7 +25,6 @@ pkgbase = dolphin-emu-git
depends = pugixml
depends = qt6-base
depends = sfml
- depends = zlib
depends = libavcodec.so
depends = libavformat.so
depends = libavutil.so
@@ -39,6 +37,10 @@ pkgbase = dolphin-emu-git
source = dolphin-emu-git::git+https://github.com/dolphin-emu/dolphin
source = dolphin-emu-git-mgba::git+https://github.com/mgba-emu/mgba.git
source = dolphin-emu-git-spirvcross::git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ source = dolphin-emu-git-zlibng::git+https://github.com/zlib-ng/zlib-ng.git
+ source = dolphin-emu-git-libspng::git+https://github.com/randy408/libspng.git
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 76b3c514e486..699f4a748602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r16907.g537fe33997'
+pkgver='5.0.r17132.g5508c52a95'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -14,9 +14,8 @@ arch=('x86_64' 'aarch64')
url="https://$_mainpkgname.org"
license=('GPL2')
depends=(
- 'alsa-lib' 'bluez-libs' 'enet' 'hidapi' 'libevdev' 'libgl' 'libpng'
- 'libpulse' 'libx11' 'libxi' 'libxrandr' 'lzo' 'mbedtls' 'pugixml' 'qt6-base'
- 'sfml' 'zlib'
+ 'alsa-lib' 'bluez-libs' 'enet' 'hidapi' 'libevdev' 'libgl' 'libpulse'
+ 'libx11' 'libxi' 'libxrandr' 'lzo' 'mbedtls' 'pugixml' 'qt6-base' 'sfml'
'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libcurl.so'
'libminiupnpc.so' 'libswscale.so' 'libudev.so' 'libusb-1.0.so'
)
@@ -26,9 +25,13 @@ source=(
"$pkgname::git+https://github.com/$_mainpkgname/$_projectname"
"$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
"$pkgname-spirvcross::git+https://github.com/KhronosGroup/SPIRV-Cross.git"
+ "$pkgname-zlibng::git+https://github.com/zlib-ng/zlib-ng.git"
+ "$pkgname-libspng::git+https://github.com/randy408/libspng.git"
)
sha512sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
_sourcedirectory="$pkgname"
@@ -49,6 +52,18 @@ prepare() {
git submodule init "$_spirvcrosspath"
git config "submodule.$_spirvcrosspath.url" "$srcdir/$pkgname-spirvcross/"
git submodule update "$_spirvcrosspath"
+
+ # Provide zlib-ng submodule
+ _zlibngpath='Externals/zlib-ng/zlib-ng'
+ git submodule init "$_zlibngpath"
+ git config "submodule.$_zlibngpath.url" "$srcdir/$pkgname-zlibng/"
+ git submodule update "$_zlibngpath"
+
+ # Provide libspng submodule
+ _libspngpath='Externals/libspng/libspng'
+ git submodule init "$_libspngpath"
+ git config "submodule.$_libspngpath.url" "$srcdir/$pkgname-libspng/"
+ git submodule update "$_libspngpath"
}
pkgver() {