summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-07-15 00:38:14 +0200
committerDaniel Peukert2022-07-15 00:38:14 +0200
commit3f1e0d435e804f8cdc0785b5e5610a4949b7a20b (patch)
tree67b1756ec6567fb98baebd22773e93dac17937f5
parent17106c0cd609377807163bb66526a24795e5394e (diff)
downloadaur-3f1e0d435e804f8cdc0785b5e5610a4949b7a20b.tar.gz
Add missing SPIRV-Cross submodule to dolphin-emu-git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf90a5e4e9d2..7ce6c80cb4d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r16541.gbb2a3d35b0
+ pkgver = 5.0.r16907.g537fe33997
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
@@ -38,6 +38,8 @@ pkgbase = dolphin-emu-git
optdepends = pulseaudio: PulseAudio backend
source = dolphin-emu-git::git+https://github.com/dolphin-emu/dolphin
source = dolphin-emu-git-mgba::git+https://github.com/mgba-emu/mgba.git
+ source = dolphin-emu-git-spirvcross::git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b64089f0c851..76b3c514e486 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r16541.gbb2a3d35b0'
+pkgver='5.0.r16907.g537fe33997'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -25,8 +25,10 @@ optdepends=('pulseaudio: PulseAudio backend')
source=(
"$pkgname::git+https://github.com/$_mainpkgname/$_projectname"
"$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
+ "$pkgname-spirvcross::git+https://github.com/KhronosGroup/SPIRV-Cross.git"
)
sha512sums=('SKIP'
+ 'SKIP'
'SKIP')
_sourcedirectory="$pkgname"
@@ -37,10 +39,16 @@ prepare() {
mkdir 'build/'
# Provide mgba submodule
- _mgbapath="Externals/mGBA/mgba"
+ _mgbapath='Externals/mGBA/mgba'
git submodule init "$_mgbapath"
git config "submodule.$_mgbapath.url" "$srcdir/$pkgname-mgba/"
git submodule update "$_mgbapath"
+
+ # Provide SPIRV-Cross submodule
+ _spirvcrosspath='Externals/spirv_cross/SPIRV-Cross'
+ git submodule init "$_spirvcrosspath"
+ git config "submodule.$_spirvcrosspath.url" "$srcdir/$pkgname-spirvcross/"
+ git submodule update "$_spirvcrosspath"
}
pkgver() {