summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-08-17 18:42:48 +0200
committerDaniel Peukert2021-08-17 18:42:48 +0200
commit5b17f320966dc90b6ab94088214a27c0fa52f316 (patch)
tree18cc7a6f0a2b92cf9df1b1cb4cbae7e152b3ca49
parentdea9d62993f0c9846fce8fa869136cb9fda07cf5 (diff)
downloadaur-5b17f320966dc90b6ab94088214a27c0fa52f316.tar.gz
Sync dolphin-emu-git PKGBUILD with dolphin-emu
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD30
2 files changed, 12 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf01e6643caf..0505553870c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r14885.g35c64d1f57
+ pkgver = 5.0.r14899.ga36855c983
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = dolphin-emu-git
license = GPL2
makedepends = cmake
makedepends = git
+ makedepends = ninja
makedepends = python
depends = alsa-lib
depends = bluez-libs
@@ -36,8 +37,6 @@ pkgbase = dolphin-emu-git
depends = libusb-1.0.so
optdepends = pulseaudio: PulseAudio backend
source = dolphin-emu-git::git+https://github.com/dolphin-emu/dolphin
- source = dolphin-emu-git-mgba::git+https://github.com/mgba-emu/mgba.git
- sha256sums = SKIP
sha256sums = SKIP
pkgname = dolphin-emu-git
diff --git a/PKGBUILD b/PKGBUILD
index 00e15aae731b..74125c44a3c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r14885.g35c64d1f57'
+pkgver='5.0.r14899.ga36855c983'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -20,14 +20,10 @@ depends=(
'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libcurl.so'
'libminiupnpc.so' 'libswscale.so' 'libudev.so' 'libusb-1.0.so'
)
-makedepends=('cmake' 'git' 'python')
+makedepends=('cmake' 'git' 'ninja' 'python')
optdepends=('pulseaudio: PulseAudio backend')
-source=(
- "$pkgname::git+https://github.com/$_mainpkgname/$_projectname"
- "$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
-)
-sha256sums=('SKIP'
- 'SKIP')
+source=("$pkgname::git+https://github.com/$_mainpkgname/$_projectname")
+sha256sums=('SKIP')
_sourcedirectory="$pkgname"
@@ -35,13 +31,6 @@ prepare() {
cd "$srcdir/$_sourcedirectory/"
if [ -d 'build/' ]; then rm -rf 'build/'; fi
mkdir 'build/'
-
- # Provide git submodule
- _submodule='mgba'
- _submodulepath="Externals/mGBA/$_submodule"
- git submodule init "$_submodulepath"
- git config "submodule.$_submodulepath.url" "$srcdir/$pkgname-$_submodule/"
- git submodule update "$_submodulepath"
}
pkgver() {
@@ -51,12 +40,13 @@ pkgver() {
build() {
cd "$srcdir/$_sourcedirectory/"
- cmake -S '.' -B 'build/' \
+ cmake -S '.' -B 'build/' -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DUSE_SHARED_ENET=ON \
- -DDISTRIBUTOR=archlinux.org
- make -C 'build/'
+ -DDISTRIBUTOR=archlinux.org \
+ -DUSE_MGBA=OFF \
+ -DUSE_SHARED_ENET=ON
+ cmake --build 'build/'
}
package_dolphin-emu-git() {
@@ -65,7 +55,7 @@ package_dolphin-emu-git() {
conflicts=("$_mainpkgname")
cd "$srcdir/$_sourcedirectory/"
- make DESTDIR="$pkgdir" -C 'build/' install
+ DESTDIR="$pkgdir" cmake --install 'build/'
install -Dm644 'Data/51-usb-device.rules' "$pkgdir/usr/lib/udev/rules.d/51-usb-device.rules"
rm -rf "$pkgdir/usr/bin/$_noguipkgname"