summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-09-11 22:57:39 +0200
committerDaniel Peukert2021-09-11 22:57:39 +0200
commit960d42902388cc08e6e14bffbf342c3ac8924fda (patch)
tree26295933087a987292d1be2fa72d25f1b4fc9026
parent5b17f320966dc90b6ab94088214a27c0fa52f316 (diff)
downloadaur-960d42902388cc08e6e14bffbf342c3ac8924fda.tar.gz
Add mgba back to dolphin-emu-git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0505553870c6..fcc8cf51f165 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r14899.ga36855c983
+ pkgver = 5.0.r15132.g1b32a61d6a
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
@@ -37,7 +37,9 @@ pkgbase = dolphin-emu-git
depends = libusb-1.0.so
optdepends = pulseaudio: PulseAudio backend
source = dolphin-emu-git::git+https://github.com/dolphin-emu/dolphin
- sha256sums = SKIP
+ source = dolphin-emu-git-mgba::git+https://github.com/mgba-emu/mgba.git
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator - git version
diff --git a/PKGBUILD b/PKGBUILD
index 74125c44a3c9..4e18a0898abe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r14899.ga36855c983'
+pkgver='5.0.r15132.g1b32a61d6a'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -22,8 +22,12 @@ depends=(
)
makedepends=('cmake' 'git' 'ninja' 'python')
optdepends=('pulseaudio: PulseAudio backend')
-source=("$pkgname::git+https://github.com/$_mainpkgname/$_projectname")
-sha256sums=('SKIP')
+source=(
+ "$pkgname::git+https://github.com/$_mainpkgname/$_projectname"
+ "$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
+)
+sha512sums=('SKIP'
+ 'SKIP')
_sourcedirectory="$pkgname"
@@ -31,6 +35,12 @@ prepare() {
cd "$srcdir/$_sourcedirectory/"
if [ -d 'build/' ]; then rm -rf 'build/'; fi
mkdir 'build/'
+
+ # Provide mgba submodule
+ _mgbapath="Externals/mGBA/mgba"
+ git submodule init "$_mgbapath"
+ git config "submodule.$_mgbapath.url" "$srcdir/$pkgname-mgba/"
+ git submodule update "$_mgbapath"
}
pkgver() {
@@ -44,7 +54,6 @@ build() {
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DDISTRIBUTOR=archlinux.org \
- -DUSE_MGBA=OFF \
-DUSE_SHARED_ENET=ON
cmake --build 'build/'
}