summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-12-24 17:43:43 +0100
committerDaniel Peukert2022-12-24 17:43:43 +0100
commitd3f2a21b30f12154283e7a1dcc26547beadcb79d (patch)
tree9271f82485404e6ea2a16980b6066394303cc946
parent81e0644a6ee640cf20d67332e858919bb3879318 (diff)
downloadaur-d3f2a21b30f12154283e7a1dcc26547beadcb79d.tar.gz
Add missing implot external dep to dolphin-emu-git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 934d2a69ba01..51ed2e04650b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r18076.gd853da3b0b
+ pkgver = 5.0.r18097.g582d6b738b
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
@@ -44,7 +44,9 @@ pkgbase = dolphin-emu-git
source = dolphin-emu-git-zlibng::git+https://github.com/zlib-ng/zlib-ng.git
source = dolphin-emu-git-libspng::git+https://github.com/randy408/libspng.git
source = dolphin-emu-git-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
- source = dolphin-emu-git-5.0.r18076.gd853da3b0b-1-system-libmgba.diff::https://github.com/dolphin-emu/dolphin/commit/afde3a0e0d2bc49a5d890d16611432aa6eb76428.diff
+ source = dolphin-emu-git-implot::git+https://github.com/epezent/implot.git
+ source = dolphin-emu-git-5.0.r18097.g582d6b738b-1-system-libmgba.diff::https://github.com/dolphin-emu/dolphin/commit/afde3a0e0d2bc49a5d890d16611432aa6eb76428.diff
+ sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0cc0f85a8089..4c27e3f64219 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r18076.gd853da3b0b'
+pkgver='5.0.r18097.g582d6b738b'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -28,6 +28,7 @@ source=(
"$pkgname-zlibng::git+https://github.com/zlib-ng/zlib-ng.git"
"$pkgname-libspng::git+https://github.com/randy408/libspng.git"
"$pkgname-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git"
+ "$pkgname-implot::git+https://github.com/epezent/implot.git"
"$pkgname-$pkgver-$pkgrel-system-libmgba.diff::https://github.com/$_mainpkgname/$_projectname/commit/afde3a0e0d2bc49a5d890d16611432aa6eb76428.diff" # https://github.com/dolphin-emu/dolphin/pull/11362
)
sha512sums=('SKIP'
@@ -35,6 +36,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'1fe1501ccacb158464bd17efaae5263f0bc8639edb40a29227969d803e1c99860373df40fe0da7828f4bd2fecff4801695f7d303a49bdfbb8087fbca3b1b468d')
_sourcedirectory="$pkgname"
@@ -70,6 +72,12 @@ prepare() {
git submodule init "$_vmapath"
git config "submodule.$_vmapath.url" "$srcdir/$pkgname-vma/"
git -c protocol.file.allow=always submodule update "$_vmapath"
+
+ # Provide implot submodule
+ _implotpath='Externals/implot/implot'
+ git submodule init "$_implotpath"
+ git config "submodule.$_implotpath.url" "$srcdir/$pkgname-implot/"
+ git -c protocol.file.allow=always submodule update "$_implotpath"
}
pkgver() {