summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-08-16 08:30:24 +0200
committerDaniel Peukert2021-08-16 08:30:24 +0200
commitdea9d62993f0c9846fce8fa869136cb9fda07cf5 (patch)
tree5901aab95cca1a64d7d4bfb204c880d7a5e513a1
parentc44c8b60acecfafffdaa300d6b3d735b9254967d (diff)
downloadaur-dea9d62993f0c9846fce8fa869136cb9fda07cf5.tar.gz
Add missing submodule to dolphin-emu-git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd2829e0fbe0..bf01e6643caf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r13467.g79a234eff7
- pkgrel = 2
+ pkgver = 5.0.r14885.g35c64d1f57
+ pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
arch = aarch64
@@ -36,6 +36,8 @@ pkgbase = dolphin-emu-git
depends = libusb-1.0.so
optdepends = pulseaudio: PulseAudio backend
source = dolphin-emu-git::git+https://github.com/dolphin-emu/dolphin
+ source = dolphin-emu-git-mgba::git+https://github.com/mgba-emu/mgba.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = dolphin-emu-git
diff --git a/PKGBUILD b/PKGBUILD
index 41a5bd0922c3..00e15aae731b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r13467.g79a234eff7'
-pkgrel='2'
+pkgver='5.0.r14885.g35c64d1f57'
+pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
arch=('x86_64' 'aarch64')
@@ -22,8 +22,12 @@ depends=(
)
makedepends=('cmake' 'git' 'python')
optdepends=('pulseaudio: PulseAudio backend')
-source=("$pkgname::git+https://github.com/$_mainpkgname/$_projectname")
-sha256sums=('SKIP')
+source=(
+ "$pkgname::git+https://github.com/$_mainpkgname/$_projectname"
+ "$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
+)
+sha256sums=('SKIP'
+ 'SKIP')
_sourcedirectory="$pkgname"
@@ -31,6 +35,13 @@ prepare() {
cd "$srcdir/$_sourcedirectory/"
if [ -d 'build/' ]; then rm -rf 'build/'; fi
mkdir 'build/'
+
+ # Provide git submodule
+ _submodule='mgba'
+ _submodulepath="Externals/mGBA/$_submodule"
+ git submodule init "$_submodulepath"
+ git config "submodule.$_submodulepath.url" "$srcdir/$pkgname-$_submodule/"
+ git submodule update "$_submodulepath"
}
pkgver() {