summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-07-29 20:44:47 +0200
committerDaniel Peukert2023-07-29 20:44:47 +0200
commite6c8d0c4271718051b58a0b57e661a46f736e321 (patch)
tree839dca0e82771fe67841c59a06d89d6a276c60f6
parent9d1d45a8541e944feb282ad849f337c83dd9ba09 (diff)
downloadaur-e6c8d0c4271718051b58a0b57e661a46f736e321.tar.gz
Add dolphin-emu-git patch for fmt 10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--fmt-10.diff62
3 files changed, 73 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ca3de19903a..c08ed2123b4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r19817.g3d9bc85912
+ pkgver = 5.0.r19859.g30c4ac34b0
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
@@ -49,12 +49,14 @@ pkgbase = dolphin-emu-git
source = dolphin-emu-git-rcheevos::git+https://github.com/RetroAchievements/rcheevos.git
source = dolphin-emu-git-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
source = minizip-ng.diff
+ source = fmt-10.diff
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = 568ca7db64149e9ac9409947689a8390783b891e6cff7b096690771512db3e19f9d8551a8739921d8a9f6ec4a9de747811a2efc8cdd4791d715677772db7fa8e
+ sha512sums = 57852e07fc6e296598a3351a2ad63ac5af8c0130e1d1d8f0f8f99d0730fe01b1cf206e31efe1837a33ff2971e08fd48e281edc4be625c4660a711062812ae0ee
pkgname = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator - git version
diff --git a/PKGBUILD b/PKGBUILD
index e2d8210f0669..f7b2dc91b3f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r19817.g3d9bc85912'
+pkgver='5.0.r19859.g30c4ac34b0'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -32,13 +32,15 @@ source=(
"$pkgname-rcheevos::git+https://github.com/RetroAchievements/rcheevos.git"
"$pkgname-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git"
'minizip-ng.diff'
+ 'fmt-10.diff'
)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '568ca7db64149e9ac9409947689a8390783b891e6cff7b096690771512db3e19f9d8551a8739921d8a9f6ec4a9de747811a2efc8cdd4791d715677772db7fa8e')
+ '568ca7db64149e9ac9409947689a8390783b891e6cff7b096690771512db3e19f9d8551a8739921d8a9f6ec4a9de747811a2efc8cdd4791d715677772db7fa8e'
+ '57852e07fc6e296598a3351a2ad63ac5af8c0130e1d1d8f0f8f99d0730fe01b1cf206e31efe1837a33ff2971e08fd48e281edc4be625c4660a711062812ae0ee')
_sourcedirectory="$pkgname"
@@ -50,6 +52,9 @@ prepare() {
# Fix minizip-ng name for Arch
patch --forward -p1 < "$srcdir/minizip-ng.diff"
+ # Fix build with fmt 10
+ patch --forward -p1 < "$srcdir/fmt-10.diff"
+
# Provide submodules
declare -A _submodules=(
[implot]='implot/implot'
@@ -73,7 +78,7 @@ pkgver() {
build() {
# CMAKE_BUILD_TYPE - the dolphin-emu package in the repos uses 'None' for some reason, so we use it as well
- # USE_SYSTEM_LIBS - we want to use systems libs where possible
+ # USE_SYSTEM_LIBS - we want to use system libs where possible
# USE_SYSTEM_LIBMGBA - the current version of mgba in the repos is not compatible with Dolphin
cd "$srcdir/$_sourcedirectory/"
cmake -S '.' -B 'build/' -G Ninja \
diff --git a/fmt-10.diff b/fmt-10.diff
new file mode 100644
index 000000000000..0b75184f3325
--- /dev/null
+++ b/fmt-10.diff
@@ -0,0 +1,62 @@
+diff --git a/Source/Core/Core/HW/WiiSave.cpp b/Source/Core/Core/HW/WiiSave.cpp
+index e706f19afe..8843f19ba6 100644
+--- a/Source/Core/Core/HW/WiiSave.cpp
++++ b/Source/Core/Core/HW/WiiSave.cpp
+@@ -113,7 +113,7 @@ public:
+ if (header.banner_size > sizeof(header.banner))
+ {
+ ERROR_LOG_FMT(CORE, "NandStorage::ReadHeader: {} corrupted banner_size: {:x}", banner_path,
+- header.banner_size);
++ static_cast<int>(header.banner_size));
+ return {};
+ }
+ header.tid = m_tid;
+@@ -556,7 +556,7 @@ CopyResult Import(const std::string& data_bin_path, std::function<bool()> can_ov
+ if (!WiiUtils::EnsureTMDIsImported(*ios.GetFS(), ios.GetESCore(), header->tid))
+ {
+ ERROR_LOG_FMT(CORE, "WiiSave::Import: Failed to find or import TMD for title {:16x}",
+- header->tid);
++ static_cast<int>(header->tid));
+ return CopyResult::TitleMissing;
+ }
+
+diff --git a/Source/Core/DiscIO/NANDImporter.cpp b/Source/Core/DiscIO/NANDImporter.cpp
+index 8ab09da8b3..a098a0ea86 100644
+--- a/Source/Core/DiscIO/NANDImporter.cpp
++++ b/Source/Core/DiscIO/NANDImporter.cpp
+@@ -105,7 +105,7 @@ bool NANDImporter::FindSuperblock()
+ continue;
+ }
+
+- INFO_LOG_FMT(DISCIO, "Superblock #{} has version {:#x}", i, superblock->version);
++ INFO_LOG_FMT(DISCIO, "Superblock #{} has version {:#x}", i, static_cast<int>(superblock->version));
+
+ if (!m_superblock || superblock->version > m_superblock->version)
+ m_superblock = std::move(superblock);
+@@ -117,7 +117,7 @@ bool NANDImporter::FindSuperblock()
+ return false;
+ }
+
+- INFO_LOG_FMT(DISCIO, "Using superblock version {:#x}", m_superblock->version);
++ INFO_LOG_FMT(DISCIO, "Using superblock version {:#x}", static_cast<int>(m_superblock->version));
+ return true;
+ }
+
+@@ -144,7 +144,7 @@ void NANDImporter::ProcessEntry(u16 entry_number, const std::string& parent_path
+ const NANDFSTEntry entry = m_superblock->fst[entry_number];
+
+ const std::string path = GetPath(entry, parent_path);
+- INFO_LOG_FMT(DISCIO, "Entry: {} Path: {}", entry, path);
++ INFO_LOG_FMT(DISCIO, "Entry: {} Path: {}", entry.name, path);
+ m_update_callback();
+
+ Type type = static_cast<Type>(entry.mode & 3);
+@@ -161,7 +161,7 @@ void NANDImporter::ProcessEntry(u16 entry_number, const std::string& parent_path
+ }
+ else
+ {
+- ERROR_LOG_FMT(DISCIO, "Ignoring unknown entry type for {}", entry);
++ ERROR_LOG_FMT(DISCIO, "Ignoring unknown entry type for {}", entry.name);
+ }
+
+ entry_number = entry.sib;