summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlailect2016-08-03 17:26:39 -0400
committerPlailect2016-08-03 17:26:39 -0400
commitc38626d553a6138ea9094ad1aef1909fcdbf0e21 (patch)
tree8a697fa41bb10617df0aaa5d17febf95133f6b7b
parentd216e49b4c4656423a251c6d978b29e3a6c68137 (diff)
downloadaur-c38626d553a6138ea9094ad1aef1909fcdbf0e21.tar.gz
implemented pull request 4066
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37563e53a420..c2fa947ed8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,6 +25,9 @@ pkgver() {
}
prepare() {
+ sed -i -e 's/#include <vector>/#include <vector>\n#include <curl\/curlver\.h>/' Source/Core/Common/Analytics.h
+ sed -i -e 's/#include "Common\/Flag\.h"/#include "Common\/Flag\.h"\n\n#if LIBCURL_VERSION_MAJOR >= 7 \&\& LIBCURL_VERSION_MINOR >= 50\ntypedef struct Curl_easy CURL;\n#else/' Source/Core/Common/Analytics.h
+ sed -i -e 's/typedef void CURL;/typedef void CURL;\n#endif/' Source/Core/Common/Analytics.h
cd dolphin-emu
if [[ -d build ]]; then