summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach Jaggi2015-06-27 13:34:30 -0400
committerZach Jaggi2015-06-27 13:34:30 -0400
commit82d56cd983b2865354ad39499171c2ca9b1b8cd2 (patch)
treeec3393c839e16d0055a6859f886ece5eb8c3f41e
downloadaur-82d56cd983b2865354ad39499171c2ca9b1b8cd2.tar.gz
Initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD71
2 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d60a7cc2ee6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = dolphin-emu-osvr-git
+ pkgdesc = A GameCube / Wii / Triforce emulator, with OSVR cross-HMD support
+ pkgver = 4.0.2.r6333.58c706e
+ pkgrel = 1
+ url = http://www.dolphin-emu.org/
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = qt5-base
+ depends = bluez-libs
+ depends = ffmpeg
+ depends = libao
+ depends = mbedtls
+ depends = miniupnpc
+ depends = portaudio
+ depends = sdl2
+ depends = sfml
+ depends = soundtouch
+ depends = xdg-utils
+ depends = wxgtk
+ depends = osvr-core-git
+ depends = osvr-libfunctionality-git
+ optdepends = pulseaudio: PulseAudio backend
+ options = !emptydirs
+ source = dolphin-emu::git+https://github.com/feilen/dolphin.git#branch=osvr
+ sha256sums = SKIP
+
+pkgname = dolphin-emu-osvr-git
+ provides = dolphin-emu
+ conflicts = dolphin-emu
+
+pkgname = dolphin-emu-osvr-cli-git
+ depends = dolphin-emu-git
+
+pkgname = dolphin-emu-osvr-qt-git
+ depends = dolphin-emu-git
+ depends = qt5-base
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5bd2e94fd76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Zachary Jaggi <feilen1000@gmail.com>
+
+pkgbase=dolphin-emu-osvr-git
+pkgname=('dolphin-emu-osvr-git' 'dolphin-emu-osvr-cli-git' 'dolphin-emu-osvr-qt-git')
+pkgver=4.0.2.r6333.58c706e
+pkgrel=1
+pkgdesc='A GameCube / Wii / Triforce emulator, with OSVR cross-HMD support'
+arch=('x86_64')
+url='http://www.dolphin-emu.org/'
+license=('GPL2')
+depends=('bluez-libs' 'ffmpeg' 'libao' 'mbedtls' 'miniupnpc' 'portaudio'
+ 'sdl2' 'sfml' 'soundtouch' 'xdg-utils' 'wxgtk' 'osvr-core-git' 'osvr-libfunctionality-git')
+makedepends=('cmake' 'git' 'qt5-base')
+optdepends=('pulseaudio: PulseAudio backend')
+options=('!emptydirs')
+source=('dolphin-emu::git+https://github.com/feilen/dolphin.git#branch=osvr')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dolphin-emu
+
+ tag='4.0.2'
+
+ echo "${tag}.r$(git rev-list --count ${tag}..HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd dolphin-emu
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_CXX_FLAGS='-fno-inline-functions -fpermissive' \
+ -DENABLE_LTO='TRUE' \
+ -DENABLE_QT='TRUE'
+ make
+}
+
+package_dolphin-emu-osvr-git() {
+ provides=('dolphin-emu')
+ conflicts=('dolphin-emu')
+
+ cd dolphin-emu/build
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/bin/dolphin-emu-nogui
+}
+
+package_dolphin-emu-osvr-cli-git() {
+ depends=('dolphin-emu-git')
+
+ cd dolphin-emu/build
+
+ install -dm 755 "${pkgdir}"/usr/bin
+ install -m 755 Binaries/dolphin-emu-nogui "${pkgdir}"/usr/bin/dolphin-emu-cli
+}
+
+package_dolphin-emu-osvr-qt-git() {
+ depends=('dolphin-emu-git' 'qt5-base')
+
+ cd dolphin-emu/build
+
+ install -dm 755 "${pkgdir}"/usr/bin
+ install -m 755 Binaries/dolphin-emu-qt "${pkgdir}"/usr/bin/
+}
+
+# vim: ts=2 sw=2 et: