summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-26 20:23:46 -0800
committerxiota2023-12-26 20:43:55 -0800
commit084169c9db00fe1b0f761938678c709a65be7b10 (patch)
tree18afcda47bebea4dee4ef4cae61f56a60123ceb5
parentbdddddb4a2ecbe35ea84a6afbdc7106b4a0d71b7 (diff)
downloadaur-084169c9db00fe1b0f761938678c709a65be7b10.tar.gz
1.0.7.r0
-rw-r--r--.SRCINFO68
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD348
-rw-r--r--primehack-rename.patch181
4 files changed, 528 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 228101f76da7..715cc662d6d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,43 +1,65 @@
pkgbase = dolphin-emu-primehack-git
- pkgdesc = Dolphin fork intended to give Metroid Prime Trilogy mouselook controls
- pkgver = 1.0.4.r951.ge353752b6d
+ pkgdesc = A Gamecube and Wii emulator with mouselook controls
+ pkgver = 1.0.7.r0.gbd2591a28a
pkgrel = 1
- url = https://dolphin-emu.org
+ url = https://github.com/shiiion/dolphin
arch = x86_64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = cmake
makedepends = git
makedepends = python
+ makedepends = clang
+ makedepends = lld
+ makedepends = llvm
depends = alsa-lib
depends = bluez-libs
- depends = enet
- depends = hidapi
+ depends = curl
+ depends = ffmpeg
+ depends = gcc-libs
+ depends = glibc
depends = libevdev
depends = libgl
- depends = libpng
depends = libpulse
+ depends = libudev.so
depends = libx11
depends = libxi
depends = libxrandr
+ depends = qt6-base
+ depends = qt6-svg
+ depends = bzip2
+ depends = cubeb
+ depends = curl
+ depends = fmt
+ depends = hidapi
+ depends = libiconv
+ depends = liblzma.so
+ depends = libspng
+ depends = libusb
+ depends = lz4
depends = lzo
- depends = mbedtls
+ depends = mbedtls2
+ depends = miniupnpc
+ depends = minizip-ng
depends = pugixml
- depends = qt5-base
+ depends = sdl2
depends = sfml
- depends = zlib
- depends = libavcodec.so
- depends = libavformat.so
- depends = libavutil.so
- depends = libcurl.so
- depends = libminiupnpc.so
- depends = libswscale.so
- depends = libudev.so
- depends = libusb-1.0.so
- optdepends = pulseaudio: PulseAudio backend
- source = dolphin::git+https://github.com/shiiion/dolphin.git
+ depends = zstd
+ provides = dolphin-emu-primehack
+ conflicts = dolphin-emu-primehack
+ options = !emptydirs
+ source = dolphin-emu-primehack::git+https://github.com/shiiion/dolphin.git
+ source = primehack-rename.patch
+ source = epezent.implot::git+https://github.com/epezent/implot.git
+ source = gpuopen-librariesandsdks.vulkanmemoryallocator::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
+ source = mgba-emu.mgba::git+https://github.com/mgba-emu/mgba.git
+ source = retroachievements.rcheevos::git+https://github.com/RetroAchievements/rcheevos.git
+ source = zlib-ng::git+https://github.com/zlib-ng/zlib-ng.git
+ sha256sums = SKIP
+ sha256sums = 632cb45fc540536f615caf72c0736682fa30776a10bf42dd94bae417845c213d
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = dolphin-emu-primehack-git
- pkgdesc = Dolphin fork intended to give Metroid Prime Trilogy mouselook controls
- provides = dolphin-emu-git
- conflicts = dolphin-emu-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 9909b4153e4a..e9676943e000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,313 @@
-# Maintainer: Nick Lay <layns(at)mail(dot)uc(dot)edu>
-# Contributor: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Lightning <sgsdxzy@gmail.com>
+# Maintainer:
+# Contributor: Nick Lay <layns(at)mail(dot)uc(dot)edu>
-# Based on the dolphin-emu-git PKGBUILD with modifications
+##
-_mainpkgname="dolphin-emu"
-pkgname=("$_mainpkgname-primehack-git")
-pkgver=1.0.4.r951.ge353752b6d
+: ${_build_clang:=true}
+
+: ${_build_avx:=false}
+: ${_build_git:=true}
+
+[[ "${_build_avx::1}" == "t" ]] && _pkgtype+="-avx"
+[[ "${_build_git::1}" == "t" ]] && _pkgtype+="-git"
+
+# basic info
+_pkgname="dolphin-emu-primehack"
+pkgname="$_pkgname${_pkgtype:-}"
+pkgver=1.0.7.r0.gbd2591a28a
pkgrel=1
-pkgdesc='Dolphin fork intended to give Metroid Prime Trilogy mouselook controls'
+pkgdesc='A Gamecube and Wii emulator with mouselook controls'
+url="https://github.com/shiiion/dolphin"
+license=('GPL-2.0-or-later')
arch=('x86_64')
-url="https://dolphin-emu.org"
-license=('GPL2')
-depends=(
- 'alsa-lib' 'bluez-libs' 'enet' 'hidapi' 'libevdev' 'libgl' 'libpng'
- 'libpulse' 'libx11' 'libxi' 'libxrandr' 'lzo' 'mbedtls' 'pugixml' 'qt5-base'
- 'sfml' 'zlib'
- 'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libcurl.so'
- 'libminiupnpc.so' 'libswscale.so' 'libudev.so' 'libusb-1.0.so'
-)
-makedepends=('cmake' 'git' 'python')
-optdepends=('pulseaudio: PulseAudio backend')
-source=("dolphin::git+https://github.com/shiiion/dolphin.git")
-sha256sums=('SKIP')
-
-_sourcedirectory="dolphin"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- git submodule update --init
- if [ -d 'build/' ]; then rm -rf 'build/'; fi
- mkdir 'build/'
+# main package
+_main_package() {
+ depends=(
+ alsa-lib
+ bluez-libs
+ curl
+ ffmpeg
+ gcc-libs
+ glibc
+ libevdev
+ libgl
+ libpulse
+ libudev.so
+ libx11
+ libxi
+ libxrandr
+ qt6-base
+ qt6-svg
+
+ ## optional
+ bzip2
+ cubeb
+ curl
+ fmt
+ hidapi
+ libiconv
+ liblzma.so
+ libspng
+ libusb
+ lz4
+ lzo
+ mbedtls2
+ miniupnpc
+ minizip-ng
+ pugixml
+ sdl2
+ sfml
+ zstd
+
+ ## broken
+ #enet
+ #libmgba
+ #xxhash
+ #zlib-ng
+ )
+ makedepends+=(
+ cmake
+ git
+ python
+ )
+
+ options=(!emptydirs)
+
+ if [[ "${_build_clang::1}" == "t" ]] ; then
+ makedepends+=(
+ clang
+ lld
+ llvm
+ )
+ else
+ options+=(!lto)
+ fi
+
+ if [[ "${_build_git::1}" != "t" ]] ; then
+ _main_stable
+ else
+ _main_git
+ fi
+
+ _source_dolphin_emu
+}
+
+# submodules
+_source_dolphin_emu() {
+ source+=(
+ #'bylaws.libadrenotools'::'git+https://github.com/bylaws/libadrenotools.git'
+ #'curl'::'git+https://github.com/curl/curl.git'
+ #'dolphin-emu.ext-win-ffmpeg'::'git+https://github.com/dolphin-emu/ext-win-ffmpeg.git'
+ #'dolphin-emu.ext-win-qt'::'git+https://github.com/dolphin-emu/ext-win-qt.git'
+ #'fmtlib.fmt'::'git+https://github.com/fmtlib/fmt.git'
+ #'google.googletest'::'git+https://github.com/google/googletest.git'
+ #'khronosgroup.spirv-cross'::'git+https://github.com/KhronosGroup/SPIRV-Cross.git'
+ #'libsdl-org.sdl'::'git+https://github.com/libsdl-org/SDL.git'
+ #'libusb'::'git+https://github.com/libusb/libusb.git'
+ #'lsalzman.enet'::'git+https://github.com/lsalzman/enet.git'
+ #'lz4'::'git+https://github.com/lz4/lz4.git'
+ #'mozilla.cubeb'::'git+https://github.com/mozilla/cubeb.git'
+ #'randy408.libspng'::'git+https://github.com/randy408/libspng.git'
+ #'cyan4973.xxhash'::'git+https://github.com/Cyan4973/xxHash.git'
+
+ 'epezent.implot'::'git+https://github.com/epezent/implot.git'
+ 'gpuopen-librariesandsdks.vulkanmemoryallocator'::'git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git'
+ 'mgba-emu.mgba'::'git+https://github.com/mgba-emu/mgba.git'
+ 'retroachievements.rcheevos'::'git+https://github.com/RetroAchievements/rcheevos.git'
+ 'zlib-ng'::'git+https://github.com/zlib-ng/zlib-ng.git'
+ )
+ sha256sums+=(
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+ #'SKIP'
+
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ )
+
+ _prepare_dolphin_emu() (
+ cd "${srcdir:?}/$_pkgsrc"
+ local -A _submodules=(
+ #['bylaws.libadrenotools']='Externals/libadrenotools'
+ #['curl']='Externals/curl/curl'
+ #['cyan4973.xxhash']='Externals/xxhash/xxHash'
+ #['dolphin-emu.ext-win-ffmpeg']='Externals/FFmpeg-bin'
+ #['dolphin-emu.ext-win-qt']='Externals/Qt'
+ #['fmtlib.fmt']='Externals/fmt/fmt'
+ #['google.googletest']='Externals/gtest'
+ #['khronosgroup.spirv-cross']='Externals/spirv_cross/SPIRV-Cross'
+ #['libsdl-org.sdl']='Externals/SDL/SDL'
+ #['libusb']='Externals/libusb/libusb'
+ #['lsalzman.enet']='Externals/enet/enet'
+ #['lz4']='Externals/lz4/lz4'
+ #['mozilla.cubeb']='Externals/cubeb/cubeb'
+ #['randy408.libspng']='Externals/libspng/libspng'
+
+ ['epezent.implot']='Externals/implot/implot'
+ ['gpuopen-librariesandsdks.vulkanmemoryallocator']='Externals/VulkanMemoryAllocator'
+ ['mgba-emu.mgba']='Externals/mGBA/mgba'
+ ['retroachievements.rcheevos']='Externals/rcheevos/rcheevos'
+ ['zlib-ng']='Externals/zlib-ng/zlib-ng'
+ )
+ _submodule_update
+ )
}
-pkgver() {
- cd "$srcdir/$_sourcedirectory/"
- git describe --long --tags | sed -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
+# stable package
+_main_stable() {
+ :
+}
+
+# git package
+_main_git() {
+ provides=("$_pkgname")
+ conflicts=("$_pkgname")
+
+ _pkgsrc="$_pkgname"
+ source=(
+ "$_pkgname"::"git+$url.git"
+ "primehack-rename.patch"
+ )
+ sha256sums+=(
+ 'SKIP'
+ '632cb45fc540536f615caf72c0736682fa30776a10bf42dd94bae417845c213d'
+ )
+
+ pkgver() {
+ cd "$_pkgsrc"
+
+ local _regex='^.* scm_rev_str = ".*\[v([0-9\.]+)\].*$'
+ local _file='Source/Core/Common/Version.cpp'
+
+ local _line=$(grep -Esm1 "$_regex" "$_file")
+ local _line_num=$(grep -Ensm1 "$_regex" "$_file" | cut -d':' -f1)
+
+ local _version=$(sed -E "s@$_regex@\1@" <<< "$_line")
+
+ local _commit=$(git blame -L $_line_num,$_line_num -- "$_file" | awk '{print $1;}')
+
+ local _revision=$(git rev-list --count --cherry-pick $_commit...HEAD)
+ local _hash=$(git rev-parse --short HEAD)
+
+ printf "%s.r%s.g%s" "$_version" "$_revision" "$_hash"
+ }
+}
+
+# common functions
+prepare() {
+ _submodule_update() {
+ for key in ${!_submodules[@]} ; do
+ git submodule init "${_submodules[${key}]}"
+ git submodule set-url "${_submodules[${key}]}" "${srcdir}/${key}"
+ git -c protocol.file.allow=always submodule update "${_submodules[${key}]}"
+ done
+ }
+
+ apply-patch() {
+ printf '\nApplying patch %s\n' "$1"
+ patch -Np1 -F100 -i "$1"
+ }
+
+ _prepare_dolphin_emu
+
+ # primehack-rename: copy files
+ local _data_path="$_pkgsrc/Data"
+ for i in -nogui.6 .6 .desktop .png .svg ; do
+ cp --reflink=auto -- "$_data_path/dolphin-emu${i}" "$_data_path/primehack${i}"
+ done
+
+ _data_path="$_pkgsrc/Data/Sys/Resources"
+ cp --reflink=auto -- "$_data_path/dolphin_logo.png" "$_data_path/primehack_logo.png"
+ cp --reflink=auto -- "$_data_path/dolphin_logo@2x.png" "$_data_path/primehack_logo@2x.png"
+
+ # primehack-rename: patch source
+ pushd "$_pkgsrc"
+ #git -c user.name="tmp" -c user.email="tmp@example.com" am "$srcdir/primehack-rename.patch"
+ apply-patch "$srcdir/primehack-rename.patch"
+ popd
+
+ # Fix minizip-ng name for Arch
+ sed -E -e 's@(pkgconfig\(MINIZIP minizip)([^a-z]+)@\1-ng\2@' \
+ -i "${srcdir:?}/$_pkgsrc/CMakeLists.txt"
+
+ # Delete gcc specific options
+ sed '/_ARCHIVE_/d' -i "${srcdir:?}/$_pkgsrc/CMakeLists.txt"
}
build() {
- cd "$srcdir/$_sourcedirectory/"
- cmake -S '.' -B 'build/' \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DUSE_SHARED_ENET=ON \
- -DDISTRIBUTOR=archlinux.org
- make -C 'build/'
+ if [[ "${_build_avx::1}" == "t" ]] ; then
+ export CFLAGS="$(echo "$CFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
+ export CXXFLAGS="$(echo "$CXXFLAGS" | sed -E 's@(\s*-(march|mtune)=\S+\s*)@ @g;s@\s*-O[0-9]\s*@ @g;s@\s+@ @g') -march=x86-64-v3 -mtune=skylake -O3"
+ fi
+
+ local _cmake_options=(
+ -B build
+ -S "$_pkgname"
+
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ -DDISTRIBUTOR='aur.chaotic.cx'
+
+ -DENABLE_AUTOUPDATE=OFF
+ -DENABLE_ANALYTICS=OFF # default:Opt-in
+ # -DUSE_SYSTEM_LIBS=ON # default:AUTO
+
+ -DUSE_SYSTEM_ENET=OFF
+ -DUSE_SYSTEM_LIBMGBA=OFF
+ -DUSE_SYSTEM_XXHASH=OFF
+ -DUSE_SYSTEM_ZLIB=OFF
+
+ -DENABLE_NOGUI=OFF
+ -DENABLE_CLI_TOOL=OFF
+
+ -DENABLE_TESTS=OFF
+ -Wno-dev
+ )
+
+ if [[ "${_build_clang::1}" == "t" ]] ; then
+ export AR=llvm-ar
+ export NM=llvm-nm
+
+ _cmake_options+=(
+ -DCMAKE_C_COMPILER=clang
+ -DCMAKE_CXX_COMPILER=clang++
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON
+ -DENABLE_LTO=ON
+
+ -DCMAKE_EXE_LINKER_FLAGS_INIT="-fuse-ld=lld"
+ -DCMAKE_MODULE_LINKER_FLAGS_INIT="-fuse-ld=lld"
+ -DCMAKE_SHARED_LINKER_FLAGS_INIT="-fuse-ld=lld"
+ )
+ else
+ _cmake_options+=(-DENABLE_LTO=OFF)
+ fi
+
+ cmake "${_cmake_options[@]}"
+ cmake --build build
}
package() {
- pkgdesc="$pkgdesc"
- provides=("$_mainpkgname-git")
- conflicts=("$_mainpkgname-git")
-
- cd "$srcdir/$_sourcedirectory/"
- make DESTDIR="$pkgdir" -C 'build/' install
- install -Dm644 'Data/51-usb-device.rules' "$pkgdir/usr/lib/udev/rules.d/51-usb-device.rules"
-
- rm -rf "$pkgdir/usr/bin/primehack-dolphin"
- rm -rf "$pkgdir/usr/include"
- rm -rf "$pkgdir/usr/lib/libdiscord-rpc.a"
- rm -rf "$pkgdir/usr/share/man/man6/primehack-dolphin.6"
+ DESTDIR="${pkgdir:?}" cmake --install build
+
+ # To use, symlink to /usr/lib/udev/rules.d/
+ install -Dm644 "${srcdir:?}/$_pkgsrc/Data/51-usb-device.rules" \
+ -t "${pkgdir:?}/usr/share/primehack/"
}
+# execute
+_main_package
diff --git a/primehack-rename.patch b/primehack-rename.patch
new file mode 100644
index 000000000000..56364a15e197
--- /dev/null
+++ b/primehack-rename.patch
@@ -0,0 +1,181 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 781e3d01e1..494e9f2d62 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ set(CMAKE_OSX_DEPLOYMENT_TARGET "10.15.0" CACHE STRING "")
+
+ set(CMAKE_USER_MAKE_RULES_OVERRIDE "CMake/FlagsOverride.cmake")
+
+-project(dolphin-emu)
++project(primehack)
+
+ if (MSVC)
+ if (POLICY CMP0117)
+@@ -172,7 +172,7 @@ include(RemoveCompileFlag)
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+
+ # Set up paths
+-set(datadir ${CMAKE_INSTALL_FULL_DATADIR}/dolphin-emu CACHE PATH "datadir")
++set(datadir ${CMAKE_INSTALL_FULL_DATADIR}/primehack CACHE PATH "datadir")
+ add_definitions(-DDATA_DIR="${datadir}/")
+
+ if(CMAKE_SYSROOT)
+@@ -834,27 +834,27 @@ if(NOT CMAKE_SYSTEM_NAME MATCHES "Linux|FreeBSD|OpenBSD|Darwin")
+ endif()
+ if(CMAKE_SYSTEM_NAME MATCHES "Linux|FreeBSD|OpenBSD")
+ # Install the application icon and menu item
+- install(FILES Data/dolphin-emu.svg
++ install(FILES Data/primehack.svg
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/scalable/apps)
+- install(FILES Data/dolphin-emu.png
++ install(FILES Data/primehack.png
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/256x256/apps)
+- install(FILES Data/dolphin-emu.desktop
++ install(FILES Data/primehack.desktop
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)
+ # Install manpages
+- install(FILES Data/dolphin-emu.6
++ install(FILES Data/primehack.6
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man6)
+- install(FILES Data/dolphin-emu-nogui.6
++ install(FILES Data/primehack-nogui.6
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man6)
+ endif()
+
+ # packaging information
+-set(CPACK_PACKAGE_NAME "dolphin-emu")
+-set(CPACK_PACKAGE_VENDOR "Dolphin Team")
++set(CPACK_PACKAGE_NAME "primehack")
++set(CPACK_PACKAGE_VENDOR "PrimeHack Team")
+ set(CPACK_PACKAGE_VERSION_MAJOR ${DOLPHIN_VERSION_MAJOR})
+ set(CPACK_PACKAGE_VERSION_MINOR ${DOLPHIN_VERSION_MINOR})
+ set(CPACK_PACKAGE_VERSION_PATCH ${DOLPHIN_VERSION_PATCH})
+ set(CPACK_PACKAGE_DESCRIPTION_FILE ${PROJECT_SOURCE_DIR}/Data/cpack_package_description.txt)
+-set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "A GameCube and Wii emulator")
++set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "A GameCube and Wii emulator with mouselook controls")
+
+ set(CPACK_RPM_PACKAGE_GROUP System/Emulators/Other)
+ set(CPACK_RPM_PACKAGE_LICENSE GPL-2.0)
+diff --git a/Data/dolphin-emu.desktop b/Data/dolphin-emu.desktop
+index a998ce4370..927c2c63cf 100644
+--- a/Data/dolphin-emu.desktop
++++ b/Data/dolphin-emu.desktop
+@@ -1,10 +1,10 @@
+ [Desktop Entry]
+ Version=1.0
+-Icon=dolphin-emu
+-Exec=env QT_QPA_PLATFORM=xcb dolphin-emu
++Icon=primehack
++Exec=env QT_QPA_PLATFORM=xcb primehack
+ Terminal=false
+ Type=Application
+ Categories=Game;Emulator;
+-Name=Dolphin Emulator
++Name=PrimeHack Emulator
+ GenericName=Wii/GameCube Emulator
+ Comment=A Wii/GameCube Emulator
+diff --git a/Source/Core/Common/CommonPaths.h b/Source/Core/Common/CommonPaths.h
+index 44ada6dd19..0b81d6a33b 100644
+--- a/Source/Core/Common/CommonPaths.h
++++ b/Source/Core/Common/CommonPaths.h
+@@ -17,9 +17,9 @@
+ #elif defined(__APPLE__)
+ #define NORMAL_USER_DIR "Library/Application Support/Dolphin"
+ #elif defined(ANDROID)
+-#define NORMAL_USER_DIR "/sdcard/dolphin-emu"
++#define NORMAL_USER_DIR "/sdcard/primehack"
+ #else
+-#define NORMAL_USER_DIR "dolphin-emu"
++#define NORMAL_USER_DIR "primehack"
+ #endif
+ #else // ifndef STEAM
+ #ifdef _WIN32
+@@ -27,7 +27,7 @@
+ #elif defined(__APPLE__)
+ #define NORMAL_USER_DIR "Library/Application Support/Dolphin (Steam)"
+ #else
+-#define NORMAL_USER_DIR "dolphin-emu-steam"
++#define NORMAL_USER_DIR "primehack-steam"
+ #endif
+ #endif
+
+diff --git a/Source/Core/DolphinNoGUI/CMakeLists.txt b/Source/Core/DolphinNoGUI/CMakeLists.txt
+index 820f01c275..acd419caa4 100644
+--- a/Source/Core/DolphinNoGUI/CMakeLists.txt
++++ b/Source/Core/DolphinNoGUI/CMakeLists.txt
+@@ -22,7 +22,7 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+ target_sources(dolphin-nogui PRIVATE PlatformFBDev.cpp)
+ endif()
+
+-set_target_properties(dolphin-nogui PROPERTIES OUTPUT_NAME dolphin-emu-nogui)
++set_target_properties(dolphin-nogui PROPERTIES OUTPUT_NAME primehack-nogui)
+
+ target_link_libraries(dolphin-nogui
+ PRIVATE
+diff --git a/Source/Core/DolphinQt/CMakeLists.txt b/Source/Core/DolphinQt/CMakeLists.txt
+index b585027898..63353bcd16 100644
+--- a/Source/Core/DolphinQt/CMakeLists.txt
++++ b/Source/Core/DolphinQt/CMakeLists.txt
+@@ -536,7 +536,7 @@ if(GETTEXT_MSGFMT_EXECUTABLE)
+ set(mo ${mo_dir}/${lang}.mo)
+ else()
+ set(mo_dir ${CMAKE_CURRENT_BINARY_DIR}/${lang})
+- set(mo ${mo_dir}/dolphin-emu.mo)
++ set(mo ${mo_dir}/primehack.mo)
+ endif()
+
+ target_sources(dolphin-emu PRIVATE ${mo})
+@@ -644,6 +644,7 @@ if(APPLE)
+ COMMAND /usr/bin/codesign -f -s "${MACOS_CODE_SIGNING_IDENTITY}" --deep --options=runtime --entitlements "${CMAKE_SOURCE_DIR}/Source/Core/DolphinQt/DolphinEmu$<$<CONFIG:Debug>:Debug>.entitlements" "$<TARGET_BUNDLE_DIR:dolphin-emu>")
+ endif()
+ else()
++ set_target_properties(dolphin-emu PROPERTIES OUTPUT_NAME primehack)
+ install(TARGETS dolphin-emu RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+
+diff --git a/Source/Core/DolphinQt/Resources.cpp b/Source/Core/DolphinQt/Resources.cpp
+index 84fbcc8df8..0e9186d874 100644
+--- a/Source/Core/DolphinQt/Resources.cpp
++++ b/Source/Core/DolphinQt/Resources.cpp
+@@ -94,7 +94,7 @@ void Resources::Init()
+ }
+
+ m_misc.append(GetResourceIcon("nobanner"));
+- m_misc.append(GetResourceIcon("dolphin_logo"));
++ m_misc.append(GetResourceIcon("primehack_logo"));
+ }
+
+ QIcon Resources::GetPlatform(DiscIO::Platform platform)
+diff --git a/Source/Core/DolphinQt/Translation.cpp b/Source/Core/DolphinQt/Translation.cpp
+index 83404d6a76..e3eda53770 100644
+--- a/Source/Core/DolphinQt/Translation.cpp
++++ b/Source/Core/DolphinQt/Translation.cpp
+@@ -280,12 +280,12 @@ static bool TryInstallTranslator(const QString& exact_language_code)
+ #if defined _WIN32
+ fmt::format("{}/Languages/{}.mo", File::GetExeDirectory(), lang)
+ #elif defined __APPLE__
+- fmt::format("{}/Contents/Resources/{}.lproj/dolphin-emu.mo", File::GetBundleDirectory(),
++ fmt::format("{}/Contents/Resources/{}.lproj/primehack.mo", File::GetBundleDirectory(),
+ lang)
+ #elif defined LINUX_LOCAL_DEV
+- fmt::format("{}/../Source/Core/DolphinQt/{}/dolphin-emu.mo", File::GetExeDirectory(), lang)
++ fmt::format("{}/../Source/Core/DolphinQt/{}/primehack.mo", File::GetExeDirectory(), lang)
+ #else
+- fmt::format("{}/../locale/{}/LC_MESSAGES/dolphin-emu.mo", DATA_DIR, lang)
++ fmt::format("{}/../locale/{}/LC_MESSAGES/primehack.mo", DATA_DIR, lang)
+ #endif
+ ;
+
+diff --git a/Source/Core/DolphinTool/CMakeLists.txt b/Source/Core/DolphinTool/CMakeLists.txt
+index e2c8c8cdd1..0d2b594a1f 100644
+--- a/Source/Core/DolphinTool/CMakeLists.txt
++++ b/Source/Core/DolphinTool/CMakeLists.txt
+@@ -9,7 +9,7 @@ add_executable(dolphin-tool
+ ToolMain.cpp
+ )
+
+-set_target_properties(dolphin-tool PROPERTIES OUTPUT_NAME dolphin-tool)
++set_target_properties(dolphin-tool PROPERTIES OUTPUT_NAME primehack-tool)
+
+ target_link_libraries(dolphin-tool
+ PRIVATE