summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach Jaggi2015-06-14 19:19:22 -0400
committerZach Jaggi2015-06-14 19:19:22 -0400
commit28aba6217b2bc2b16369327933d1dad72779e006 (patch)
treeeb939ccc6fdb05fd3dae0eb6f86443ee8ac91eec
downloadaur-28aba6217b2bc2b16369327933d1dad72779e006.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD56
-rw-r--r--dolphin-emu.sh6
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fab49367342
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = dolphin-emu-vr-git
+ pkgdesc = A GameCube / Wii / Triforce emulator, with Oculus Rift VR support
+ pkgver = 4.0.2.r6926.5eb7305
+ pkgrel = 2
+ url = http://www.dolphin-emu.org/
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ depends = bluez-libs
+ depends = ffmpeg
+ depends = libao
+ depends = lzo
+ depends = miniupnpc
+ depends = polarssl
+ depends = portaudio
+ depends = sdl2
+ depends = sfml
+ depends = soundtouch
+ depends = wxgtk
+ depends = xdg-utils
+ depends = oculus-rift-sdk>=0.5.0.1
+ optdepends = pulseaudio: PulseAudio backend
+ optdepends = oculus-udev: Rules to let users access the Oculus Rift
+ provides = dolphin-emu
+ conflicts = dolphin-emu
+ options = !emptydirs
+ source = dolphin-emu::git+https://github.com/feilen/dolphin.git#branch=VR-Hydra
+ source = dolphin-emu.sh
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = dolphin-emu-vr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db93e4baef26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Zach Jaggi <feilen1000@gmail.com>
+
+pkgname=dolphin-emu-vr-git
+pkgver=4.0.2.r6926.5eb7305
+pkgrel=2
+pkgdesc='A GameCube / Wii / Triforce emulator, with Oculus Rift VR support'
+arch=('x86_64')
+url='http://www.dolphin-emu.org/'
+license=('GPL2')
+depends=('bluez-libs' 'ffmpeg' 'libao' 'lzo' 'miniupnpc' 'polarssl' 'portaudio'
+ 'sdl2' 'sfml' 'soundtouch' 'wxgtk' 'xdg-utils' 'oculus-rift-sdk>=0.5.0.1')
+makedepends=('cmake' 'git')
+optdepends=('pulseaudio: PulseAudio backend'
+ 'oculus-udev: Rules to let users access the Oculus Rift')
+provides=('dolphin-emu')
+conflicts=('dolphin-emu')
+options=('!emptydirs')
+source=('dolphin-emu::git+https://github.com/feilen/dolphin.git#branch=VR-Hydra'
+ 'dolphin-emu.sh')
+
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd dolphin-emu
+
+ _tag='4.0.2'
+
+ printf "%s.r%s.%s" "${_tag}" "$(git rev-list --count ${_tag}..HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd dolphin-emu
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_CXX_FLAGS='-fno-inline-functions -msse2 -fpermissive' \
+ -DENABLE_LTO='true'
+ make
+}
+
+package() {
+ cd dolphin-emu/build
+
+ make DESTDIR="${pkgdir}" install
+ mv ${pkgdir}/usr/bin/dolphin-emu ${pkgdir}/usr/share/dolphin-emu/dolphin-emu
+ install -m 755 ${srcdir}/dolphin-emu.sh ${pkgdir}/usr/bin/dolphin-emu
+ install -m 755 Binaries/dolphin-emu-nogui "${pkgdir}"/usr/bin/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/dolphin-emu.sh b/dolphin-emu.sh
new file mode 100644
index 000000000000..a87b48af0eca
--- /dev/null
+++ b/dolphin-emu.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+# Enable Nvidia threaded optimizations
+export __GL_THREADED_OPTIMIZATIONS=1
+
+exec /usr/share/dolphin-emu/dolphin-emu ${@}