summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes Mann2017-05-21 18:06:30 +0200
committerHannes Mann2017-05-21 18:06:30 +0200
commit3b32705e7ffb5dae143277981940617dccd6a347 (patch)
treefc39da7402aab3241afdb66ba24daf9d332b3983
downloadaur-3b32705e7ffb5dae143277981940617dccd6a347.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD56
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7d2aaa044b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = dolphin-hau-git
+ pkgdesc = A Wii/GameCube Emulator (Melee/Project M)
+ pkgver = 5.0_hau.1
+ pkgrel = 1
+ url = http://github.com/HannesMann/dolphin-hau
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = bluez-libs
+ depends = enet
+ depends = ffmpeg
+ depends = libao
+ depends = libevdev
+ depends = mbedtls
+ depends = miniupnpc
+ depends = openal
+ depends = portaudio
+ depends = soundtouch
+ depends = xdg-utils
+ depends = wxgtk
+ optdepends = pulseaudio: PulseAudio backend
+ options = !emptydirs
+ source = dolphin-hau::git+https://github.com/HannesMann/dolphin-hau.git
+ sha256sums = SKIP
+
+pkgname = dolphin-hau-git
+ provides = dolphin-hau
+ conflicts = dolphin-hau
+
+pkgname = dolphin-hau-cli-git
+ depends = dolphin-hau-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c5847be272f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Hannes Mann <hannesmann2000@gmail.com>
+# Based on: https://aur.archlinux.org/dolphin-emu-git.git
+
+pkgbase=dolphin-hau-git
+pkgname=('dolphin-hau-git' 'dolphin-hau-cli-git')
+pkgver=5.0_hau.1
+pkgrel=1
+pkgdesc='A Wii/GameCube Emulator (Melee/Project M)'
+arch=('x86_64')
+url='http://github.com/HannesMann/dolphin-hau'
+license=('GPL')
+depends=('bluez-libs' 'enet' 'ffmpeg' 'libao' 'libevdev' 'mbedtls' 'miniupnpc'
+ 'openal' 'portaudio' 'soundtouch' 'xdg-utils' 'wxgtk')
+makedepends=('cmake' 'git')
+optdepends=('pulseaudio: PulseAudio backend')
+options=('!emptydirs')
+source=('dolphin-hau::git+https://github.com/HannesMann/dolphin-hau.git')
+sha256sums=('SKIP')
+
+prepare() {
+ cd dolphin-hau
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd dolphin-hau/build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package_dolphin-hau-git() {
+ provides=('dolphin-hau')
+ conflicts=('dolphin-hau')
+
+ cd dolphin-hau/build
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/bin/dolphin-hau-{nogui}
+
+ install -Dm 644 ../Data/51-usb-device.rules -t "${pkgdir}"/usr/lib/udev/rules.d/
+}
+
+package_dolphin-hau-cli-git() {
+ depends=('dolphin-hau-git')
+
+ cd dolphin-hau/build
+
+ install -dm 755 "${pkgdir}"/usr/bin
+ install -m 755 Binaries/dolphin-hau-nogui "${pkgdir}"/usr/bin/dolphin-hau-cli
+}