summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2021-02-08 03:15:33 +0800
committerzhullyb2021-02-08 03:15:33 +0800
commit7f5b4f40d6d5a6f7ee9f8920695cb0cd65006de2 (patch)
tree066b052d775e58bdf16b4028599f3201d28b50da
downloadaur-7f5b4f40d6d5a6f7ee9f8920695cb0cd65006de2.tar.gz
First Version on AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..303e7fc83262
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dolphin-megasync-bin
+ pkgdesc = Extension for KDE based file managers to interact with Megasync
+ pkgver = 3.6.6
+ pkgrel = 2
+ url = http://mega.nz
+ arch = x86_64
+ license = custom
+ depends = megasync>=3.5
+ depends = dolphin
+ provides = dolphin-megasync=3.6.6
+ conflicts = dolphin-megasync
+ conflicts = dolphin-megasync-git
+ source = http://mega.nz/linux/MEGAsync/Arch_Extra/x86_64/dolphin-megasync-3.6.6-2-x86_64.pkg.tar.xz
+ md5sums = 882a2bb9f4bec41ae285ae2b353d730b
+
+pkgname = dolphin-megasync-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6a96ef24568
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: zhullyb <zhullyb at outlook dot com>
+pkgname=dolphin-megasync-bin
+pkgver=3.6.6
+pkgrel=2
+pkgdesc="Extension for KDE based file managers to interact with Megasync"
+arch=('x86_64')
+url="http://mega.nz"
+license=('custom')
+provides=("dolphin-megasync=$pkgver")
+conflicts=('dolphin-megasync' 'dolphin-megasync-git')
+depends=('megasync>=3.5'
+ 'dolphin')
+source=("${url}/linux/MEGAsync/Arch_Extra/x86_64/dolphin-megasync-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz")
+md5sums=('882a2bb9f4bec41ae285ae2b353d730b')
+
+package() {
+ cp -R "${srcdir}/usr" "${pkgdir}/"
+}
+