summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2021-09-02 17:39:32 -0400
committerAndy Kluger2021-09-02 17:40:40 -0400
commit2c1fc05ba1f288ee63d6c6668a91330f05636781 (patch)
treef74212a094369e2485a4c683a9507ea1e7f7137e
parentead3106f4ebb239c5706b4a1e46c29aaacadbc0d (diff)
downloadaur-2c1fc05ba1f288ee63d6c6668a91330f05636781.tar.gz
merge in changes from Arch repo
-rw-r--r--.SRCINFO17
-rw-r--r--27bfcde4.patch97
-rw-r--r--PKGBUILD18
3 files changed, 116 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5643af0ec467..79902d728a87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-meld
pkgdesc = KDE File Manager, using Meld rather than Kompare
- pkgver = 21.04.3
+ pkgver = 21.08.1
pkgrel = 1
url = https://apps.kde.org/dolphin/
arch = x86_64
@@ -9,13 +9,11 @@ pkgbase = dolphin-meld
license = LGPL
makedepends = extra-cmake-modules
makedepends = kdoctools
- makedepends = packagekit-qt5
depends = baloo-widgets
depends = knewstuff
depends = kio-extras
depends = kcmutils
depends = kparts
- depends = kinit
depends = kactivities
depends = kuserfeedback
optdepends = kde-cli-tools: for editing file type options
@@ -23,17 +21,18 @@ pkgbase = dolphin-meld
optdepends = kdegraphics-thumbnailers: PDF and PS thumbnails
optdepends = konsole: terminal panel
optdepends = purpose: share context menu
- optdepends = packagekit-qt5: service menu installer
- provides = dolphin=21.04.3
- conflicts = dolphin=21.04.3
- source = https://download.kde.org/stable/release-service/21.04.3/src/dolphin-21.04.3.tar.xz
- source = https://download.kde.org/stable/release-service/21.04.3/src/dolphin-21.04.3.tar.xz.sig
+ provides = dolphin=21.08.1
+ conflicts = dolphin=21.08.1
+ source = https://download.kde.org/stable/release-service/21.08.1/src/dolphin-21.08.1.tar.xz
+ source = https://download.kde.org/stable/release-service/21.08.1/src/dolphin-21.08.1.tar.xz.sig
source = dolphin-meld.patch
+ source = 27bfcde4.patch
validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
validpgpkeys = D81C0CB38EB725EF6691C385BB463350D6EF31EF
- sha256sums = e3a1560c216efaa80c3ec99138c4657e9602e17aea250a418b18c2fc85295264
+ sha256sums = 6e5dce2629f8333b426074d0f35dc96d40b528948db101443f8270ea554cb3ee
sha256sums = SKIP
sha256sums = 9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a
+ sha256sums = 9c17ce284b0623982b152fa76418ca3005e31c3977120f1f6bb5be351918e318
pkgname = dolphin-meld
diff --git a/27bfcde4.patch b/27bfcde4.patch
new file mode 100644
index 000000000000..b41a7ad6e9d9
--- /dev/null
+++ b/27bfcde4.patch
@@ -0,0 +1,97 @@
+From 27bfcde4efaf936243fc41e4a61d0cac32105ef6 Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Tue, 31 Aug 2021 09:09:14 -0600
+Subject: [PATCH] Port to KTerminalLauncherJob
+
+Dolphin still uses KToolInvocation::invokeTerminal() which is
+deprecated and requires KInit. However Dolphin was ported away from
+requiring it in other ways, so it is now possible to have Dolphin
+running but not KInit, which breaks the "Open in Terminal"
+functionality.
+
+Using KTerminalLauncherJob fixes this. It was introduced in Frameworks
+5.83, so the CMake dependency version is accordingly increased.
+
+BUG: 441072
+FIXED-IN: 21.12
+---
+ CMakeLists.txt | 2 +-
+ src/dolphinmainwindow.cpp | 14 ++++++++++----
+ src/dolphinpart.cpp | 6 ++++--
+ 3 files changed, 15 insertions(+), 7 deletions(-)
+
+diff --git a/src/dolphinmainwindow.cpp b/src/dolphinmainwindow.cpp
+index 62e347032..f3a5e3b4e 100644
+--- a/src/dolphinmainwindow.cpp
++++ b/src/dolphinmainwindow.cpp
+@@ -56,10 +56,10 @@
+ #include <KStandardAction>
+ #include <KStartupInfo>
+ #include <KSycoca>
++#include <KTerminalLauncherJob>
+ #include <KToggleAction>
+ #include <KToolBar>
+ #include <KToolBarPopupAction>
+-#include <KToolInvocation>
+ #include <KUrlComboBox>
+ #include <KUrlNavigator>
+ #include <KWindowSystem>
+@@ -1033,7 +1033,9 @@ void DolphinMainWindow::openTerminal()
+ const QUrl url = m_activeViewContainer->url();
+
+ if (url.isLocalFile()) {
+- KToolInvocation::invokeTerminal(QString(), {}, url.toLocalFile());
++ auto job = new KTerminalLauncherJob(QString());
++ job->setWorkingDirectory(url.toLocalFile());
++ job->start();
+ return;
+ }
+
+@@ -1047,14 +1049,18 @@ void DolphinMainWindow::openTerminal()
+ statUrl = job->mostLocalUrl();
+ }
+
+- KToolInvocation::invokeTerminal(QString(), {}, statUrl.isLocalFile() ? statUrl.toLocalFile() : QDir::homePath());
++ auto job = new KTerminalLauncherJob(QString());
++ job->setWorkingDirectory(statUrl.isLocalFile() ? statUrl.toLocalFile() : QDir::homePath());
++ job->start();
+ });
+
+ return;
+ }
+
+ // Nothing worked, just use $HOME
+- KToolInvocation::invokeTerminal(QString(), {}, QDir::homePath());
++ auto job = new KTerminalLauncherJob(QString());
++ job->setWorkingDirectory(QDir::homePath());
++ job->start();
+ }
+
+ void DolphinMainWindow::editSettings()
+diff --git a/src/dolphinpart.cpp b/src/dolphinpart.cpp
+index 9c551d67a..8d528f418 100644
+--- a/src/dolphinpart.cpp
++++ b/src/dolphinpart.cpp
+@@ -32,7 +32,7 @@
+ #include <KPluginFactory>
+ #include <KIO/CommandLauncherJob>
+ #include <KSharedConfig>
+-#include <KToolInvocation>
++#include <KTerminalLauncherJob>
+
+ #include <QActionGroup>
+ #include <QApplication>
+@@ -567,7 +567,9 @@ QString DolphinPart::localFilePathOrHome() const
+
+ void DolphinPart::slotOpenTerminal()
+ {
+- KToolInvocation::invokeTerminal(QString(), {}, localFilePathOrHome());
++ auto job = new KTerminalLauncherJob(QString());
++ job->setWorkingDirectory(localFilePathOrHome());
++ job->start();
+ }
+
+ void DolphinPart::slotFindFile()
+--
+GitLab
+
diff --git a/PKGBUILD b/PKGBUILD
index 356c4c09cd5c..e170b2c74fcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=dolphin-meld
_pkgname=dolphin
-pkgver=21.04.3
+pkgver=21.08.1
pkgrel=1
pkgdesc='KDE File Manager, using Meld rather than Kompare'
arch=(x86_64)
@@ -15,21 +15,25 @@ url='https://apps.kde.org/dolphin/'
license=(LGPL)
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname=$pkgver")
-depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kinit kactivities kuserfeedback)
-makedepends=(extra-cmake-modules kdoctools packagekit-qt5)
+depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kactivities kuserfeedback)
+makedepends=(extra-cmake-modules kdoctools)
optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video thumbnails' 'kdegraphics-thumbnailers: PDF and PS thumbnails'
- 'konsole: terminal panel' 'purpose: share context menu' 'packagekit-qt5: service menu installer')
+ 'konsole: terminal panel' 'purpose: share context menu')
groups=(kde-applications kde-system)
source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig}
- "dolphin-meld.patch")
-sha256sums=('e3a1560c216efaa80c3ec99138c4657e9602e17aea250a418b18c2fc85295264'
+ "dolphin-meld.patch"
+ 27bfcde4.patch)
+sha256sums=('6e5dce2629f8333b426074d0f35dc96d40b528948db101443f8270ea554cb3ee'
'SKIP'
- '9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a')
+ '9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a'
+ '9c17ce284b0623982b152fa76418ca3005e31c3977120f1f6bb5be351918e318')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
prepare() {
+ patch -d $_pkgname-$pkgver -p1 < 27bfcde4.patch # Fix opening terminal without kinit
+
mkdir -p build
cd $_pkgname-$pkgver
patch -p1 -i ../$pkgname.patch