summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2020-08-15 02:10:39 -0400
committerAndy Kluger2020-08-15 02:10:39 -0400
commitde29e4816950dafb4d2681d2b045364838159990 (patch)
tree556422b200a547a34080e690bbe88e21c88b812f
parented106821222756c07d0e0dd898bed5f55ff19cc1 (diff)
downloadaur-de29e4816950dafb4d2681d2b045364838159990.tar.gz
recreate meld patch based on newer dolphin release
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--dolphin-meld.patch25
3 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e6dde0771f5..e073b396d43d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -31,7 +31,7 @@ pkgbase = dolphin-meld
validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
sha256sums = fe5a68d9afd0771ba9ffc2d5d79e7bc43da85fd3ee3c2493a9a2d5c359c3cd6f
sha256sums = SKIP
- sha256sums = 13107b72348bd7eea5665196dc4a37c21bff131bbc8457efe77ef8c3e9450c7b
+ sha256sums = 9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a
pkgname = dolphin-meld
diff --git a/PKGBUILD b/PKGBUILD
index ae5a5490fd31..a9b2f89048a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ source=("https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$
"dolphin-meld.patch")
sha256sums=('fe5a68d9afd0771ba9ffc2d5d79e7bc43da85fd3ee3c2493a9a2d5c359c3cd6f'
'SKIP'
- '13107b72348bd7eea5665196dc4a37c21bff131bbc8457efe77ef8c3e9450c7b')
+ '9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
diff --git a/dolphin-meld.patch b/dolphin-meld.patch
index f5b2ff5f913a..6e2a45e993db 100644
--- a/dolphin-meld.patch
+++ b/dolphin-meld.patch
@@ -1,7 +1,8 @@
-diff -ura dolphin-18.08.3.orig/src/dolphinmainwindow.cpp dolphin-18.08.3.new/src/dolphinmainwindow.cpp
---- dolphin-18.08.3.orig/src/dolphinmainwindow.cpp 2018-11-09 14:38:47.556089139 -0500
-+++ dolphin-18.08.3.new/src/dolphinmainwindow.cpp 2018-11-09 14:45:24.522392872 -0500
-@@ -273,7 +273,7 @@
+diff --git a/src/dolphinmainwindow.cpp b/src/dolphinmainwindow.cpp
+index 5741e8943..63253e681 100644
+--- a/src/dolphinmainwindow.cpp
++++ b/src/dolphinmainwindow.cpp
+@@ -330,7 +330,7 @@ void DolphinMainWindow::slotSelectionChanged(const KFileItemList& selection)
const int selectedUrlsCount = m_tabWidget->currentTabPage()->selectedItemsCount();
QAction* compareFilesAction = actionCollection()->action(QStringLiteral("compare_files"));
@@ -10,7 +11,7 @@ diff -ura dolphin-18.08.3.orig/src/dolphinmainwindow.cpp dolphin-18.08.3.new/src
compareFilesAction->setEnabled(isKompareInstalled());
} else {
compareFilesAction->setEnabled(false);
-@@ -705,7 +705,7 @@
+@@ -925,7 +925,7 @@ void DolphinMainWindow::goHomeInNewTab()
void DolphinMainWindow::compareFiles()
{
const KFileItemList items = m_tabWidget->currentTabPage()->selectedItems();
@@ -19,7 +20,7 @@ diff -ura dolphin-18.08.3.orig/src/dolphinmainwindow.cpp dolphin-18.08.3.new/src
// The action is disabled in this case, but it could have been triggered
// via D-Bus, see https://bugs.kde.org/show_bug.cgi?id=325517
return;
-@@ -714,12 +714,18 @@
+@@ -934,14 +934,20 @@ void DolphinMainWindow::compareFiles()
QUrl urlA = items.at(0).url();
QUrl urlB = items.at(1).url();
@@ -29,18 +30,20 @@ diff -ura dolphin-18.08.3.orig/src/dolphinmainwindow.cpp dolphin-18.08.3.new/src
command.append("\" \"");
command.append(urlB.toDisplayString(QUrl::PreferLocalFile));
command.append('\"');
-- KRun::runCommand(command, QStringLiteral("Kompare"), QStringLiteral("kompare"), this);
+ if (items.count() == 3) {
+ QUrl urlC = items.at(2).url();
+ command.append(" \"");
+ command.append(urlC.toDisplayString(QUrl::PreferLocalFile));
+ command.append('\"');
+ }
-+ KRun::runCommand(command, QStringLiteral("Meld"), QStringLiteral("meld"), this);
+
+ KIO::CommandLauncherJob *job = new KIO::CommandLauncherJob(command, this);
+- job->setDesktopName(QStringLiteral("org.kde.kompare"));
++ job->setDesktopName(QStringLiteral("org.gnome.meld"));
+ job->start();
}
- void DolphinMainWindow::toggleShowMenuBar()
-@@ -1181,7 +1187,7 @@
+@@ -1549,7 +1555,7 @@ void DolphinMainWindow::setupActions()
QAction* compareFiles = actionCollection()->addAction(QStringLiteral("compare_files"));
compareFiles->setText(i18nc("@action:inmenu Tools", "Compare Files"));
@@ -49,7 +52,7 @@ diff -ura dolphin-18.08.3.orig/src/dolphinmainwindow.cpp dolphin-18.08.3.new/src
compareFiles->setEnabled(false);
connect(compareFiles, &QAction::triggered, this, &DolphinMainWindow::compareFiles);
-@@ -1576,7 +1582,7 @@
+@@ -2151,7 +2157,7 @@ bool DolphinMainWindow::isKompareInstalled() const
if (!initialized) {
// TODO: maybe replace this approach later by using a menu
// plugin like kdiff3plugin.cpp