summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2021-12-10 23:31:21 -0500
committerAndy Kluger2021-12-10 23:31:21 -0500
commitf0c4ad4aec2589668a2291fd085f377119fd0c9b (patch)
treee5320d6985db275750dc5c216f38085312d3ea7a
parent7f9c57238a6eb67f2bc3aff49f210bdb421fcdd4 (diff)
downloadaur-f0c4ad4aec2589668a2291fd085f377119fd0c9b.tar.gz
update to match base pkgbuild
-rw-r--r--.SRCINFO14
-rw-r--r--27bfcde4.patch97
-rw-r--r--PKGBUILD12
3 files changed, 10 insertions, 113 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b9acd97d161..39a96e89db3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-meld
pkgdesc = KDE File Manager, using Meld rather than Kompare
- pkgver = 21.08.3
+ pkgver = 21.12.0
pkgrel = 1
url = https://apps.kde.org/dolphin/
arch = x86_64
@@ -21,18 +21,16 @@ pkgbase = dolphin-meld
optdepends = kdegraphics-thumbnailers: PDF and PS thumbnails
optdepends = konsole: terminal panel
optdepends = purpose: share context menu
- provides = dolphin=21.08.3
- conflicts = dolphin=21.08.3
- source = https://download.kde.org/stable/release-service/21.08.3/src/dolphin-21.08.3.tar.xz
- source = https://download.kde.org/stable/release-service/21.08.3/src/dolphin-21.08.3.tar.xz.sig
+ provides = dolphin=21.12.0
+ conflicts = dolphin=21.12.0
+ source = https://download.kde.org/stable/release-service/21.12.0/src/dolphin-21.12.0.tar.xz
+ source = https://download.kde.org/stable/release-service/21.12.0/src/dolphin-21.12.0.tar.xz.sig
source = dolphin-meld.patch
- source = 27bfcde4.patch
validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
validpgpkeys = D81C0CB38EB725EF6691C385BB463350D6EF31EF
- sha256sums = 3b17bfd81dcb04d37810cea0d52d098ce5244289a2eb0173f575291ca97bd9a7
+ sha256sums = e70fc08ee292c5f9bfd4fc3bb12eef524528bee8e856d294bf484b3eff7b2669
sha256sums = SKIP
sha256sums = 9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a
- sha256sums = 9c17ce284b0623982b152fa76418ca3005e31c3977120f1f6bb5be351918e318
pkgname = dolphin-meld
diff --git a/27bfcde4.patch b/27bfcde4.patch
deleted file mode 100644
index b41a7ad6e9d9..000000000000
--- a/27bfcde4.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From 27bfcde4efaf936243fc41e4a61d0cac32105ef6 Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Tue, 31 Aug 2021 09:09:14 -0600
-Subject: [PATCH] Port to KTerminalLauncherJob
-
-Dolphin still uses KToolInvocation::invokeTerminal() which is
-deprecated and requires KInit. However Dolphin was ported away from
-requiring it in other ways, so it is now possible to have Dolphin
-running but not KInit, which breaks the "Open in Terminal"
-functionality.
-
-Using KTerminalLauncherJob fixes this. It was introduced in Frameworks
-5.83, so the CMake dependency version is accordingly increased.
-
-BUG: 441072
-FIXED-IN: 21.12
----
- CMakeLists.txt | 2 +-
- src/dolphinmainwindow.cpp | 14 ++++++++++----
- src/dolphinpart.cpp | 6 ++++--
- 3 files changed, 15 insertions(+), 7 deletions(-)
-
-diff --git a/src/dolphinmainwindow.cpp b/src/dolphinmainwindow.cpp
-index 62e347032..f3a5e3b4e 100644
---- a/src/dolphinmainwindow.cpp
-+++ b/src/dolphinmainwindow.cpp
-@@ -56,10 +56,10 @@
- #include <KStandardAction>
- #include <KStartupInfo>
- #include <KSycoca>
-+#include <KTerminalLauncherJob>
- #include <KToggleAction>
- #include <KToolBar>
- #include <KToolBarPopupAction>
--#include <KToolInvocation>
- #include <KUrlComboBox>
- #include <KUrlNavigator>
- #include <KWindowSystem>
-@@ -1033,7 +1033,9 @@ void DolphinMainWindow::openTerminal()
- const QUrl url = m_activeViewContainer->url();
-
- if (url.isLocalFile()) {
-- KToolInvocation::invokeTerminal(QString(), {}, url.toLocalFile());
-+ auto job = new KTerminalLauncherJob(QString());
-+ job->setWorkingDirectory(url.toLocalFile());
-+ job->start();
- return;
- }
-
-@@ -1047,14 +1049,18 @@ void DolphinMainWindow::openTerminal()
- statUrl = job->mostLocalUrl();
- }
-
-- KToolInvocation::invokeTerminal(QString(), {}, statUrl.isLocalFile() ? statUrl.toLocalFile() : QDir::homePath());
-+ auto job = new KTerminalLauncherJob(QString());
-+ job->setWorkingDirectory(statUrl.isLocalFile() ? statUrl.toLocalFile() : QDir::homePath());
-+ job->start();
- });
-
- return;
- }
-
- // Nothing worked, just use $HOME
-- KToolInvocation::invokeTerminal(QString(), {}, QDir::homePath());
-+ auto job = new KTerminalLauncherJob(QString());
-+ job->setWorkingDirectory(QDir::homePath());
-+ job->start();
- }
-
- void DolphinMainWindow::editSettings()
-diff --git a/src/dolphinpart.cpp b/src/dolphinpart.cpp
-index 9c551d67a..8d528f418 100644
---- a/src/dolphinpart.cpp
-+++ b/src/dolphinpart.cpp
-@@ -32,7 +32,7 @@
- #include <KPluginFactory>
- #include <KIO/CommandLauncherJob>
- #include <KSharedConfig>
--#include <KToolInvocation>
-+#include <KTerminalLauncherJob>
-
- #include <QActionGroup>
- #include <QApplication>
-@@ -567,7 +567,9 @@ QString DolphinPart::localFilePathOrHome() const
-
- void DolphinPart::slotOpenTerminal()
- {
-- KToolInvocation::invokeTerminal(QString(), {}, localFilePathOrHome());
-+ auto job = new KTerminalLauncherJob(QString());
-+ job->setWorkingDirectory(localFilePathOrHome());
-+ job->start();
- }
-
- void DolphinPart::slotFindFile()
---
-GitLab
-
diff --git a/PKGBUILD b/PKGBUILD
index 00fb58ae23a5..11a35c2d06b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=dolphin-meld
_pkgname=dolphin
-pkgver=21.08.3
+pkgver=21.12.0
pkgrel=1
pkgdesc='KDE File Manager, using Meld rather than Kompare'
arch=(x86_64)
@@ -21,19 +21,15 @@ optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video
'konsole: terminal panel' 'purpose: share context menu')
groups=(kde-applications kde-system)
source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig}
- "dolphin-meld.patch"
- 27bfcde4.patch)
-sha256sums=('3b17bfd81dcb04d37810cea0d52d098ce5244289a2eb0173f575291ca97bd9a7'
+ "dolphin-meld.patch")
+sha256sums=('e70fc08ee292c5f9bfd4fc3bb12eef524528bee8e856d294bf484b3eff7b2669'
'SKIP'
- '9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a'
- '9c17ce284b0623982b152fa76418ca3005e31c3977120f1f6bb5be351918e318')
+ '9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
prepare() {
- patch -d $_pkgname-$pkgver -p1 < 27bfcde4.patch # Fix opening terminal without kinit
-
mkdir -p build
cd $_pkgname-$pkgver
patch -p1 -i ../$pkgname.patch