summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCpt_Huntsman2022-04-21 22:35:52 +0800
committerCpt_Huntsman2022-04-21 23:15:18 +0800
commit643797c324794dc9fef57d254b7eaa043ccc4dd9 (patch)
treec475bb579d39a077b057ab434fd191cac291051e
downloadaur-643797c324794dc9fef57d254b7eaa043ccc4dd9.tar.gz
Upload first PKGBUILD
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD35
-rw-r--r--ducksoft-want-my-space-back.patch46
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..259611c91404
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = dolphin-nospace
+ pkgdesc = KDE File Manager (with DuckSoft's Space Patch)
+ pkgver = 22.04.0
+ pkgrel = 1
+ url = https://kde.org/applications/system/dolphin/
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = packagekit-qt5
+ depends = baloo-widgets
+ depends = knewstuff
+ depends = kio-extras
+ depends = kcmutils
+ depends = kparts
+ depends = kinit
+ depends = kactivities
+ depends = kuserfeedback
+ optdepends = kde-cli-tools: for editing file type options
+ optdepends = ffmpegthumbs: video thumbnails
+ optdepends = kdegraphics-thumbnailers: PDF and PS thumbnails
+ optdepends = konsole: terminal panel
+ optdepends = purpose: share context menu
+ optdepends = packagekit-qt5: service menu installer
+ provides = dolphin
+ conflicts = dolphin
+ source = https://download.kde.org/stable/release-service/22.04.0/src/dolphin-22.04.0.tar.xz
+ source = ducksoft-want-my-space-back.patch
+ sha256sums = 58c6cdd0d3b8ac41880e5ea2322cad92380c8c45336150c3c39f9357dfa4f100
+ sha256sums = 21a50881ce6dce2a831d8fc0e2d1339a158aaabc65986bbe3c9e990a4a71fcbe
+
+pkgname = dolphin-nospace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5663f57f36b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Cpt_Huntsman <other.plan1133@fastmail.com>
+
+pkgname=dolphin-nospace
+_pkgname=dolphin
+pkgver=22.04.0
+pkgrel=1
+pkgdesc="KDE File Manager (with DuckSoft's Space Patch)"
+arch=(x86_64)
+url="https://kde.org/applications/system/dolphin/"
+license=(LGPL)
+provides=(dolphin)
+conflicts=(dolphin)
+depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kinit kactivities kuserfeedback)
+makedepends=(extra-cmake-modules kdoctools packagekit-qt5)
+optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video thumbnails' 'kdegraphics-thumbnailers: PDF and PS thumbnails'
+ 'konsole: terminal panel' 'purpose: share context menu' 'packagekit-qt5: service menu installer')
+source=("https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz"
+ "ducksoft-want-my-space-back.patch")
+sha256sums=('58c6cdd0d3b8ac41880e5ea2322cad92380c8c45336150c3c39f9357dfa4f100'
+ '21a50881ce6dce2a831d8fc0e2d1339a158aaabc65986bbe3c9e990a4a71fcbe')
+
+prepare() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ patch -p1 < ../ducksoft-want-my-space-back.patch
+}
+
+build() {
+ cmake -B build -S $_pkgname-$pkgver \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
diff --git a/ducksoft-want-my-space-back.patch b/ducksoft-want-my-space-back.patch
new file mode 100644
index 000000000000..67a84ffd5bd7
--- /dev/null
+++ b/ducksoft-want-my-space-back.patch
@@ -0,0 +1,46 @@
+From 67f0185ac119188c881a3041d810f2e5d84cd611 Mon Sep 17 00:00:00 2001
+From: DuckSoft <ducksoft@build.archlinuxcn.org>
+Date: Sun, 13 Dec 2020 20:11:14 +0800
+Subject: [PATCH] Revert "Compute text width taking into account the zoom
+ level"
+
+This reverts commit c7d4c37534fd4c7107497a3bb67e8ffe96ce775c.
+---
+ src/views/dolphinitemlistview.cpp | 14 ++++----------
+ 1 file changed, 4 insertions(+), 10 deletions(-)
+
+diff --git a/src/views/dolphinitemlistview.cpp b/src/views/dolphinitemlistview.cpp
+index 9fa91a674..df28a0858 100644
+--- a/src/views/dolphinitemlistview.cpp
++++ b/src/views/dolphinitemlistview.cpp
+@@ -17,7 +17,6 @@
+ #include "zoomlevelinfo.h"
+
+ #include <KIO/PreviewJob>
+-#include <QtMath>
+
+
+ DolphinItemListView::DolphinItemListView(QGraphicsWidget* parent) :
+@@ -164,16 +163,11 @@ void DolphinItemListView::updateGridSize()
+
+ switch (itemLayout()) {
+ case KFileItemListView::IconsLayout: {
++ const int minItemWidth = 48;
++ itemWidth = minItemWidth + IconsModeSettings::textWidthIndex() * 64;
+
+- // an exponential factor based on zoom, 0 -> 1, 4 -> 1.36 8 -> ~1.85, 16 -> 3.4
+- auto zoomFactor = qExp(m_zoomLevel / 13.0);
+- // 9 is the average char width for 10pt Noto Sans, making fontFactor =1
+- // by each pixel the font gets larger the factor increases by 1/9
+- auto fontFactor = option.fontMetrics.averageCharWidth() / 9.0;
+- itemWidth = 48 + IconsModeSettings::textWidthIndex() * 64 * fontFactor * zoomFactor;
+-
+- if (itemWidth < iconSize + padding * 2 * zoomFactor) {
+- itemWidth = iconSize + padding * 2 * zoomFactor;
++ if (itemWidth < iconSize + padding * 2) {
++ itemWidth = iconSize + padding * 2;
+ }
+
+ itemHeight = padding * 3 + iconSize + option.fontMetrics.lineSpacing();
+--
+2.29.2